Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1497980

Re: [PATCH v3 00/17] pinctrl: exynos/samsung: Add header with values used for configuration

From Krzysztof Kozlowski <krzk@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH v3 00/17] pinctrl: exynos/samsung: Add header with values used for configuration
Date 2016-10-09 19:00 +0200
Message-ID <sqpC9-6FS-5@gated-at.bofh.it> (permalink)
References <sdDth-o3-5@gated-at.bofh.it> <sqgpc-17r-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Sun, Oct 09, 2016 at 04:04:11PM +0900, Tomasz Figa wrote:
> Hi Krzysztof,
> 
> 2016-09-04 20:04 GMT+09:00 Krzysztof Kozlowski <krzk@kernel.org>:
> >
> > Hi,
> >
> > Changes since v2
> > ================
> > 1. Combine separate patchsets into one. Previously I sent separately the fixes
> >    and changes for S3C platforms.
> > 2. Fix issues pointed during review.
> > 3. Add review tags.
> >
> > Changes since v1
> > ================
> > 1. Follow Arnd's suggestion about moving the macros to common place.
> > 2. Subjects: replace "GPIO" with "pinctrl".
> > 3. There were some major changes here so I did not add Javier's
> >    reviewed-by and tested-by tags.
> >
> > Merging
> > =======
> > Patches #1 and #2 should probably go through pinctrl tree. In that case I would
> > appreciate a stable branch/tag so DTS could base on top of it.
> >
> > Goal
> > ====
> > Increase readability:
> >         uart0_data: uart0-data {
> >                 samsung,pins = "gpa0-0", "gpa0-1";
> > -               samsung,pin-function = <2>;
> > -               samsung,pin-pud = <0>;
> > -               samsung,pin-drv = <0>;
> > +               samsung,pin-function = <EXYNOS_PIN_FUNC_2>;
> > +               samsung,pin-pud = <EXYNOS_PIN_PULL_NONE>;
> > +               samsung,pin-drv = <EXYNOS4_PIN_DRV_LV1>;
> 
> I like the idea, thanks for cleaning this up. However I'd like to
> bikeshed the prefix a bit. Since the properties are already prefixed
> by "samsung,", I think it would make much more sense to also prefix
> the generic values with "SAMSUNG_". Of course for soc/family-specific
> values, the soc/family name prefix sounds right.

I am lost. Sorry, I don't get what kind of final prefixes you would like
to have.

SAMSUNG_EXYNOS4_PIN_DRV_LV1
SAMSUNG_EXYNOS5260_PIN_DRV_LV1
?

> Similarly for rest of the value names, such as SAMSUNG_PIN_PUD instead
> of SAMSUNG_PIN_PULL, which obviously sounds more like correct English,
> however hurts the consistency and could confuse the people writing new
> dts files.

SAMSUNG_S3C64XX_PIN_PUD_NONE
SAMSUNG_EXYNOS_PIN_PUD_NONE

?

Best regards,
Krzysztof

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [PATCH v3 00/17] pinctrl: exynos/samsung: Add header with values  used for configuration Tomasz Figa <tomasz.figa@gmail.com> - 2016-10-09 09:10 +0200
  Re: [PATCH v3 00/17] pinctrl: exynos/samsung: Add header with values  used for configuration Krzysztof Kozlowski <krzk@kernel.org> - 2016-10-09 19:00 +0200
    Re: [PATCH v3 00/17] pinctrl: exynos/samsung: Add header with values  used for configuration Tomasz Figa <tomasz.figa@gmail.com> - 2016-10-09 19:50 +0200
      Re: [PATCH v3 00/17] pinctrl: exynos/samsung: Add header with values  used for configuration Krzysztof Kozlowski <krzk@kernel.org> - 2016-10-09 20:00 +0200

csiph-web