Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > comp.os.linux.networking > #2039

Re: time server ??

From Moe Trin <ibuprofin@painkiller.example.tld.invalid>
Newsgroups comp.os.linux.networking
Subject Re: time server ??
Date 2013-03-17 18:20 +0000
Organization Crash Test Dummy Training Academy
Message-ID <slrnkkc2fd.len.ibuprofin@fermi.phx.az.us> (permalink)
References <4e574c78$0$5036$ba620e4c@news.skynet.be> <6493d69a-b488-4d62-9e09-961e41924fba@googlegroups.com> <KoH0t.324664$J13.89423@newsfe08.iad> <ki46oo$2q2e$1@saria.nerim.net> <ki4kcp$dru$2@dont-email.me>

Show all headers | View raw


On Sun, 17 Mar 2013, in the Usenet newsgroup comp.os.linux.networking, in
article <ki4kcp$dru$2@dont-email.me>, J G Miller wrote:

>And rather than use pool.ntp.org, it is advisable and preferable
>to see if there is a "national" pool to use instead,
>eg for those living in Canuckistan, ca.pool.ntp.org
>or for those in the hexagon, fr.pool.ntp.org, or those
>in Deutschland, de.pool.ntp.org, etc etc.

More useful in "spreading the load" than anything else.

>Even Andorra has its own pool designation, ad.ntp.pool.org,
>actually provided by somebody else at hover.com which 
>also serves for the Faroe Islands and probably
>quite a few others.

[fermi ~]$ host ad.ntp.pool.org
ad.ntp.pool.org has address 64.99.80.30
[fermi ~]$ whois 64.99.80.30
   [SNIP]
    96 Mowat Avenue
    Toronto, ON M6K 3M1
    CA
   [SNIP]
[fermi ~]$

>After all it makes sense to use the time servers
>closest to your location in order to minimize delays.

Physical distance does not reliably translate into network distance.
Above, the last I looked neither Andorra or the Faroe Islands are
located on or close to Mowat Avenue in Toronto, Canada.

One need only play with tools like hping2, hping3, mtr, nmap,
tracepath, traceroute and/or tcptraceroute to discover things about
network distances which translate into timing delays.  The man page
for the original LBL traceroute (contained in the tarball at
ftp://ftp.ee.lbl.gov/traceroute.tar.gz) has more details than the
man page from the traceroute.sourceforge.net version found in many
current distributions or the rewrite from Olaf Kirch then at Caldera.

Further, you really do want to read and understand RFC5905

  5905 Network Time Protocol Version 4: Protocol and Algorithms
       Specification. D. Mills, J. Martin, Ed., J. Burbank, W. Kasch.
       June 2010. (Format: TXT=241096 bytes) (Obsoletes RFC1305,
       RFC4330) (Status: PROPOSED STANDARD)

although the explanation in Appendix H of RFC1305

  1305 Network Time Protocol (Version 3) Specification, Implementation
       and Analysis. D. Mills. March 1992. (Format: TXT=307085,
       PDF=442493 bytes) (Obsoletes RFC0958, RFC1059, RFC1119)
       (Obsoleted by RFC5905) (Status: DRAFT STANDARD)

may be more readable.  The TimePrecision-HOWTO from the Linux Doc
Project is also a useful document:

-rw-rw-r-- 1 gferg   ldp        43295 Nov 18  2005 TimePrecision-HOWTO

        Old guy

Back to comp.os.linux.networking | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

time server ?? Andre <pas@pourmois.be> - 2011-08-26 07:34 +0000
  Re: time server ?? Thad Floryan <thad@thadlabs.com> - 2011-08-26 00:48 -0700
    Re: time server ?? Andre <pas@pourmois.be> - 2011-08-26 08:30 +0000
    Re: time server ?? unruh <unruh@wormhole.physics.ubc.ca> - 2011-08-26 14:13 +0000
  Re: time server ?? unruh <unruh@wormhole.physics.ubc.ca> - 2011-08-26 14:09 +0000
  Re: time server ?? passion.rp@gmail.com - 2013-03-15 00:27 -0700
    Re: time server ?? Jorgen Grahn <grahn+nntp@snipabacken.se> - 2013-03-15 11:26 +0000
      Re: time server ?? Michael Black <et472@ncf.ca> - 2013-03-15 20:33 -0400
        Re: time server ?? J G Miller <miller@yoyo.ORG> - 2013-03-16 15:31 +0000
        Re: time server ?? Jorgen Grahn <grahn+nntp@snipabacken.se> - 2013-03-18 21:01 +0000
    Re: time server ?? unruh <unruh@invalid.ca> - 2013-03-15 15:47 +0000
      Re: time server ?? Pascal Hambourg <boite-a-spam@plouf.fr.eu.org> - 2013-03-17 11:43 +0100
        Re: time server ?? J G Miller <miller@yoyo.ORG> - 2013-03-17 14:36 +0000
          Re: time server ?? Moe Trin <ibuprofin@painkiller.example.tld.invalid> - 2013-03-17 18:20 +0000
            Re: time server ?? Chris Davies <chris-usenet@roaima.co.uk> - 2013-03-18 13:16 +0000
              Re: time server ?? Moe Trin <ibuprofin@painkiller.example.tld.invalid> - 2013-03-18 19:53 +0000
                Re: time server ?? unruh <unruh@invalid.ca> - 2013-03-18 20:40 +0000
                Re: time server ?? Chris Davies <chris-usenet@roaima.co.uk> - 2013-03-19 10:58 +0000
                Re: time server ?? Moe Trin <ibuprofin@painkiller.example.tld.invalid> - 2013-03-19 19:55 +0000
                Re: time server ?? unruh <unruh@invalid.ca> - 2013-03-19 20:32 +0000
                Re: time server ?? Moe Trin <ibuprofin@painkiller.example.tld.invalid> - 2013-03-20 03:25 +0000
                Re: time server ?? unruh <unruh@invalid.ca> - 2013-03-20 16:28 +0000
                Re: time server ?? Moe Trin <ibuprofin@painkiller.example.tld.invalid> - 2013-03-21 03:37 +0000

csiph-web