Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1484988

Re: [PATCH v2 16/17] UBI: hide EBA internals

From Richard Weinberger <richard@nod.at>
Newsgroups linux.kernel
Subject Re: [PATCH v2 16/17] UBI: hide EBA internals
Date 2016-09-16 15:30 +0200
Message-ID <si1nj-5f0-11@gated-at.bofh.it> (permalink)
References <se3H3-5qz-3@gated-at.bofh.it> <se3H4-5qz-55@gated-at.bofh.it> <shYSu-3xA-11@gated-at.bofh.it> <shZER-44g-23@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Boris,

On 16.09.2016 13:38, Boris Brezillon wrote:
> ubi_eba_destroy_table() was only exported (made non-static) to let vmt
> code free an EBA table if the resize operation fails in the middle
> (between ubi_eba_create_table() and ubi_eba_set_table() calls).
> 
>> I'm also not really happy with the name ubi_eba_set_table() because it does
>> more the setting the table. It destroys also the old one.
> 
> I can definitely rename the function. How about ubi_eba_replace_table().

Reads much better (to me). :-)

>>
>> What I'm trying to say is, when we bite the bullet and introduce lots of new wrapper
>> functions to hide internals I want very clear and describing names for them.
> 
> I understand and I agree.
> I thought ubi_eba_set_table() was accurately describing the function
> purpose: assigning an EBA table to a volume. The fact that the old
> table (if any) is freed when the new one is assigned is just an
> internal detail, and that should not impact the user behavior.
> But I'm perfectly fine renaming this function.

Thanks,
//richard

Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

Re: [PATCH v2 16/17] UBI: hide EBA internals Richard Weinberger <richard@nod.at> - 2016-09-16 12:50 +0200
  Re: [PATCH v2 16/17] UBI: hide EBA internals Boris Brezillon <boris.brezillon@free-electrons.com> - 2016-09-16 13:40 +0200
    Re: [PATCH v2 16/17] UBI: hide EBA internals Richard Weinberger <richard@nod.at> - 2016-09-16 15:30 +0200

csiph-web