Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1481637

Re: [PATCH 12/15] sis900: use IS_ENABLED() instead of checking for built-in or module

From Daniele Venzano <venza@brownhat.org>
Newsgroups linux.kernel
Subject Re: [PATCH 12/15] sis900: use IS_ENABLED() instead of checking for built-in or module
Date 2016-09-12 19:20 +0200
Message-ID <sgD3J-6fr-65@gated-at.bofh.it> (permalink)
References <sgA5P-4ka-3@gated-at.bofh.it> <sgA5R-4ka-49@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw



On 12 September 2016 16:03:43 CEST, Javier Martinez Canillas <javier@osg.samsung.com> wrote:
>The IS_ENABLED() macro checks if a Kconfig symbol has been enabled
>either
>built-in or as a module, use that macro instead of open coding the
>same.
>
>Using the macro makes the code more readable by helping abstract away
>some
>of the Kconfig built-in and module enable details.
>
>Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>

Acked-by: Daniele Venzano <venza@brownhat.org>

Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 00/15] drivers: net: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-09-12 16:10 +0200
  [PATCH 11/15] sfc: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-09-12 16:10 +0200
    Re: [PATCH 11/15] sfc: use IS_ENABLED() instead of checking for  built-in or module Bert Kenward <bkenward@solarflare.com> - 2016-09-12 16:40 +0200
  [PATCH 12/15] sis900: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-09-12 16:10 +0200
    Re: [PATCH 12/15] sis900: use IS_ENABLED() instead of checking for built-in or module Daniele Venzano <venza@brownhat.org> - 2016-09-12 19:20 +0200
  Re: [PATCH 00/15] drivers: net: use IS_ENABLED() instead of  checking for built-in or module David Miller <davem@davemloft.net> - 2016-09-13 05:30 +0200

csiph-web