Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1558870
| From | Michal Hocko <mhocko@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/6] mm: support __GFP_REPEAT in kvmalloc_node for >=64kB |
| Date | 2017-01-14 09:50 +0100 |
| Message-ID | <sZsca-3Kt-13@gated-at.bofh.it> (permalink) |
| References | <sYPNw-5HL-19@gated-at.bofh.it> <sYPNw-5HL-25@gated-at.bofh.it> <sZmzL-ly-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Sat 14-01-17 11:42:09, Tetsuo Handa wrote: > On 2017/01/13 0:37, Michal Hocko wrote: [...] > > diff --git a/mm/util.c b/mm/util.c > > index 7e0c240b5760..9306244b9f41 100644 > > --- a/mm/util.c > > +++ b/mm/util.c > > @@ -333,7 +333,8 @@ EXPORT_SYMBOL(vm_mmap); > > * Uses kmalloc to get the memory but if the allocation fails then falls back > > * to the vmalloc allocator. Use kvfree for freeing the memory. > > * > > - * Reclaim modifiers - __GFP_NORETRY, __GFP_REPEAT and __GFP_NOFAIL are not supported > > + * Reclaim modifiers - __GFP_NORETRY and __GFP_NOFAIL are not supported. __GFP_REPEAT > > + * is supported only for large (>64kB) allocations > > Isn't this ">32kB" (i.e. __GFP_REPEAT is supported for 64kB allocation) ? True, I will update the patch to use >32kB Thanks! -- Michal Hocko SUSE Labs
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 2/6] mm: support __GFP_REPEAT in kvmalloc_node for >=64kB Michal Hocko <mhocko@kernel.org> - 2017-01-12 16:50 +0100
Re: [PATCH 2/6] mm: support __GFP_REPEAT in kvmalloc_node for >=64kB "Michael S. Tsirkin" <mst@redhat.com> - 2017-01-12 17:20 +0100
Re: [PATCH 2/6] mm: support __GFP_REPEAT in kvmalloc_node for >=64kB Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp> - 2017-01-14 03:50 +0100
Re: [PATCH 2/6] mm: support __GFP_REPEAT in kvmalloc_node for >=64kB Michal Hocko <mhocko@kernel.org> - 2017-01-14 09:50 +0100
csiph-web