Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1526471

Re: [PATCH 1/4] time: alarmtimer: Add the trcepoints for alarmtimer

From Baolin Wang <baolin.wang@linaro.org>
Newsgroups linux.kernel
Subject Re: [PATCH 1/4] time: alarmtimer: Add the trcepoints for alarmtimer
Date 2016-11-21 10:10 +0100
Message-ID <sFSLU-7Fl-43@gated-at.bofh.it> (permalink)
References <sF5UR-78-3@gated-at.bofh.it> <sF5UR-78-11@gated-at.bofh.it> <sFRZw-7a5-17@gated-at.bofh.it> <sFSsx-7jA-5@gated-at.bofh.it> <sFSCe-7mV-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 21 November 2016 at 16:56, Thomas Gleixner <tglx@linutronix.de> wrote:
> On Mon, 21 Nov 2016, Baolin Wang wrote:
>> On 21 November 2016 at 16:13, Ingo Molnar <mingo@kernel.org> wrote:
>> > Hm, there's a weirdness here: if freezer_delta != 0 when alarmtimer_suspend() is
>> > called then type might be '0', although it's not alarm_bases[0] this value is
>> > picked up from.
>> >
>> > Wouldn't it be better to initialize 'type' to -1 instead? (And rename it to
>> > min_type or so.)
>>
>> Make sense. I will send out new patch to fix this. Thanks for your comments.
>
> Can you please fix the subject line while at it? 'trcepoints' does not look right

Sorry for mistake, I will fix that. Thanks.

-- 
Baolin.wang
Best Regards

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[GIT PULL][PATCH 0/4] Timekeeping items for 4.10 John Stultz <john.stultz@linaro.org> - 2016-11-19 06:00 +0100
  [PATCH 3/4] timekeeping: Ignore the bogus sleep time if pm_trace is enabled John Stultz <john.stultz@linaro.org> - 2016-11-19 06:00 +0100
    Re: [PATCH 3/4] timekeeping: Ignore the bogus sleep time if pm_trace  is enabled Ingo Molnar <mingo@kernel.org> - 2016-11-21 09:20 +0100
      RE: [PATCH 3/4] timekeeping: Ignore the bogus sleep time if  pm_trace is enabled "Chen, Yu C" <yu.c.chen@intel.com> - 2016-11-24 11:00 +0100
  [PATCH 1/4] time: alarmtimer: Add the trcepoints for alarmtimer John Stultz <john.stultz@linaro.org> - 2016-11-19 06:00 +0100
    Re: [PATCH 1/4] time: alarmtimer: Add the trcepoints for alarmtimer Ingo Molnar <mingo@kernel.org> - 2016-11-21 09:20 +0100
      Re: [PATCH 1/4] time: alarmtimer: Add the trcepoints for alarmtimer Baolin Wang <baolin.wang@linaro.org> - 2016-11-21 09:50 +0100
        Re: [PATCH 1/4] time: alarmtimer: Add the trcepoints for  alarmtimer Thomas Gleixner <tglx@linutronix.de> - 2016-11-21 10:00 +0100
          Re: [PATCH 1/4] time: alarmtimer: Add the trcepoints for alarmtimer Baolin Wang <baolin.wang@linaro.org> - 2016-11-21 10:10 +0100
  [PATCH 2/4] selftests/timers: Fix spelling mistake "Asyncrhonous" -> "Asynchronous" John Stultz <john.stultz@linaro.org> - 2016-11-19 06:00 +0100

csiph-web