Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1454348
| From | Steven Rostedt <rostedt@goodmis.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1080/1285] Replace numeric parameter like 0444 with macro |
| Date | 2016-08-02 15:30 +0200 |
| Message-ID | <s1HVE-50V-45@gated-at.bofh.it> (permalink) |
| References | <s1HVE-50V-47@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, 2 Aug 2016 20:14:36 +0800
Baole Ni <baolex.ni@intel.com> wrote:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
>
NACK!
I find 0444 more readable than S_IRUSR | S_IRGRP | S_IROTH.
-- Steve
> Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
> Signed-off-by: Baole Ni <baolex.ni@intel.com>
> ---
> lib/dynamic_debug.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/lib/dynamic_debug.c b/lib/dynamic_debug.c
> index fe42b6e..853158e 100644
> --- a/lib/dynamic_debug.c
> +++ b/lib/dynamic_debug.c
> @@ -63,7 +63,7 @@ struct ddebug_iter {
> static DEFINE_MUTEX(ddebug_lock);
> static LIST_HEAD(ddebug_tables);
> static int verbose;
> -module_param(verbose, int, 0644);
> +module_param(verbose, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
>
> /* Return the path relative to source root */
> static inline const char *trim_prefix(const char *path)
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [PATCH 1080/1285] Replace numeric parameter like 0444 with macro Steven Rostedt <rostedt@goodmis.org> - 2016-08-02 15:30 +0200
csiph-web