Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1452895
| From | Jason Cooper <jason@lakedaemon.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 1/7] random: Simplify API for random address requests |
| Date | 2016-07-31 23:00 +0200 |
| Message-ID | <s1601-50L-1@gated-at.bofh.it> (permalink) |
| References | <s012p-3rN-3@gated-at.bofh.it> <s0EGt-4lH-3@gated-at.bofh.it> <s0EGu-4lH-15@gated-at.bofh.it> <s1265-2zl-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Sun, Jul 31, 2016 at 09:46:53AM -0700, Kees Cook wrote: > On Sat, Jul 30, 2016 at 8:42 AM, Jason Cooper <jason@lakedaemon.net> wrote: > > To date, all callers of randomize_range() have set the length to 0, and > > check for a zero return value. For the current callers, the only way > > to get zero returned is if end <= start. Since they are all adding a > > constant to the start address, this is unnecessary. > > > > We can remove a bunch of needless checks by simplifying the API to do > > just what everyone wants, return an address between [start, start + > > range). > > > > While we're here, s/get_random_int/get_random_long/. No current call > > site is adversely affected by get_random_int(), since all current range > > requests are < UINT_MAX. However, we should match caller expectations > > to avoid coming up short (ha!) in the future. > > > > All current callers to randomize_range() chose to use the start address > > if randomize_range() failed. Therefore, we simplify things by just > > returning the start address on error. > > > > randomize_range() will be removed once all callers have been converted > > over to randomize_addr(). > > > > Signed-off-by: Jason Cooper <jason@lakedaemon.net> > > --- > > Changes from v1: > > - Explicitly mention page_aligned start assumption (Yann Droneaud) > > - pick random pages vice random addresses (Yann Droneaud) > > - catch range=0 last > > > > drivers/char/random.c | 28 ++++++++++++++++++++++++++++ > > include/linux/random.h | 1 + > > 2 files changed, 29 insertions(+) > > > > diff --git a/drivers/char/random.c b/drivers/char/random.c > > index 0158d3bff7e5..3bedf69546d6 100644 > > --- a/drivers/char/random.c > > +++ b/drivers/char/random.c > > @@ -1840,6 +1840,34 @@ randomize_range(unsigned long start, unsigned long end, unsigned long len) > > return PAGE_ALIGN(get_random_int() % range + start); > > } > > > > +/** > > + * randomize_addr - Generate a random, page aligned address > > + * @start: The smallest acceptable address the caller will take. > > + * @range: The size of the area, starting at @start, within which the > > + * random address must fall. > > + * > > + * If @start + @range would overflow, @range is capped. > > + * > > + * NOTE: Historical use of randomize_range, which this replaces, presumed that > > + * @start was already page aligned. This assumption still holds. > > + * > > + * Return: A page aligned address within [start, start + range). On error, > > + * @start is returned. > > + */ > > +unsigned long > > +randomize_addr(unsigned long start, unsigned long range) > > Since we're changing other things about this, let's try to document > its behavior in its name too and call this "randomize_page" instead. Ack. Definitely more accurate. > If it requires a page-aligned value, we should probably also BUG_ON > it, or adjust the start too. merf. So, this whole series started from a suggested cleanup by William to s/get_random_int/get_random_long/. The current users have all been stable the way they are for a long time. Like pre-git long. So, if this is just a cleanup for those callers, I don't think we need to do more than we already are. However, if the intent is for this function to see wider use, then by all means, we need to handle start != PAGE_ALIGN(start). Do you have any new call sites in mind? thx, Jason.
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/7] char/random: Simplify random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-28 23:30 +0200
[PATCH 1/7] random: Simplify API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-28 23:30 +0200
Re: [PATCH 1/7] random: Simplify API for random address requests Yann Droneaud <ydroneaud@opteya.com> - 2016-07-29 11:00 +0200
Re: [PATCH 1/7] random: Simplify API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-29 20:30 +0200
[PATCH 5/7] tile: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-28 23:30 +0200
[PATCH 7/7] random: Remove unused randomize_range() Jason Cooper <jason@lakedaemon.net> - 2016-07-28 23:30 +0200
[PATCH 6/7] unicore32: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-28 23:30 +0200
[PATCH 4/7] arm64: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-28 23:30 +0200
Re: [PATCH 4/7] arm64: Use simpler API for random address requests Will Deacon <will.deacon@arm.com> - 2016-07-29 15:50 +0200
[PATCH 3/7] ARM: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-28 23:30 +0200
[PATCH v2 7/7] random: Remove unused randomize_range() Jason Cooper <jason@lakedaemon.net> - 2016-07-30 17:50 +0200
[PATCH v2 4/7] arm64: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-30 17:50 +0200
[PATCH v2 2/7] x86: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-30 17:50 +0200
[PATCH v2 5/7] tile: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-30 17:50 +0200
[PATCH v2 3/7] ARM: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-30 17:50 +0200
[PATCH v2 1/7] random: Simplify API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-30 17:50 +0200
Re: [PATCH v2 1/7] random: Simplify API for random address requests Kees Cook <keescook@chromium.org> - 2016-07-31 18:50 +0200
Re: [PATCH v2 1/7] random: Simplify API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-31 23:00 +0200
Re: [PATCH v2 1/7] random: Simplify API for random address requests Kees Cook <keescook@chromium.org> - 2016-08-01 21:50 +0200
Re: [PATCH v2 1/7] random: Simplify API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-08-02 01:20 +0200
Re: [kernel-hardening] Re: [PATCH v2 1/7] random: Simplify API for random address requests Michael Ellerman <mpe@ellerman.id.au> - 2016-08-02 05:40 +0200
Re: [kernel-hardening] Re: [PATCH v2 1/7] random: Simplify API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-08-03 20:50 +0200
[PATCH v2 0/7] char/random: Simplify random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-30 17:50 +0200
[PATCH v2 6/7] unicore32: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-07-30 17:50 +0200
[PATCH v3 2/7] x86: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-08-04 01:50 +0200
[PATCH v3 6/7] unicore32: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-08-04 01:50 +0200
[PATCH v3 5/7] tile: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-08-04 01:50 +0200
[PATCH v3 7/7] random: Remove unused randomize_range() Jason Cooper <jason@lakedaemon.net> - 2016-08-04 01:50 +0200
Re: [PATCH v3 7/7] random: Remove unused randomize_range() Andrew Morton <akpm@linux-foundation.org> - 2016-08-04 01:50 +0200
Re: [PATCH v3 7/7] random: Remove unused randomize_range() Jason Cooper <jason@lakedaemon.net> - 2016-08-04 02:20 +0200
[PATCH v3 0/7] char/random: Simplify random address requests Jason Cooper <jason@lakedaemon.net> - 2016-08-04 01:50 +0200
[PATCH v3 4/7] arm64: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-08-04 01:50 +0200
[PATCH v3 1/7] random: Simplify API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-08-04 01:50 +0200
Re: [PATCH v3 1/7] random: Simplify API for random address requests Yann Droneaud <ydroneaud@opteya.com> - 2016-08-04 14:50 +0200
[PATCH v3 3/7] ARM: Use simpler API for random address requests Jason Cooper <jason@lakedaemon.net> - 2016-08-04 01:50 +0200
Re: [PATCH v3 0/7] char/random: Simplify random address requests Kees Cook <keescook@chromium.org> - 2016-08-04 04:50 +0200
csiph-web