Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1401638
| From | Pantelis Antoniou <pantelis.antoniou@konsulko.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v2 0/5] of: generic infrastructure fixes |
| Date | 2016-05-16 19:00 +0200 |
| Message-ID | <rzu25-13S-7@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
The first patch renames the *_node_sysfs methods to _node_post since this is more accurate when more work takes place besides sysfs tweaking when the next patch is using a hashtable for phandles. This is a win for very large blobs with a large number of phandles. Current we use an exhaustive search which is not optimal at all. The third patch adds a unittest/benchmark for hashed phandles along with figures about performance. A long standing request of applied overlays populating the symbol list is implemented; this allows staggered overlay application with a symbol from a previous overlay being used by another after it. Finally a pr_fmt for the overlay files is used for uncluttering the printout a bit. Changes since v1: * Reworked phandle hash according to maintainer requests * Added unittest/benchmark for phandle hash * Reworked the overlay symbol patch * Added pr_fmt patch Pantelis Antoniou (5): of: rename *_node_sysfs to _node_post of: Support hashtable lookups for phandles of: unittest: hashed phandles unitest of: overlay: Pick up label symbols from overlays. of: overlay: Add pr_fmt for clarity drivers/of/base.c | 45 +++++++++++-- drivers/of/dynamic.c | 18 +++-- drivers/of/of_private.h | 37 ++++++++++- drivers/of/overlay.c | 173 ++++++++++++++++++++++++++++++++++++------------ drivers/of/unittest.c | 72 +++++++++++++++++++- include/linux/of.h | 2 + 6 files changed, 289 insertions(+), 58 deletions(-) -- 1.7.12
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH v2 0/5] of: generic infrastructure fixes Pantelis Antoniou <pantelis.antoniou@konsulko.com> - 2016-05-16 19:00 +0200
[PATCH v2 3/5] of: unittest: hashed phandles unitest Pantelis Antoniou <pantelis.antoniou@konsulko.com> - 2016-05-16 19:00 +0200
Re: [PATCH v2 3/5] of: unittest: hashed phandles unitest Geert Uytterhoeven <geert@linux-m68k.org> - 2016-05-16 21:10 +0200
Re: [PATCH v2 3/5] of: unittest: hashed phandles unitest Rob Herring <robherring2@gmail.com> - 2016-05-16 21:40 +0200
[PATCH v2 4/5] of: overlay: Pick up label symbols from overlays. Pantelis Antoniou <pantelis.antoniou@konsulko.com> - 2016-05-16 19:00 +0200
Re: [PATCH v2 4/5] of: overlay: Pick up label symbols from overlays. Geert Uytterhoeven <geert@linux-m68k.org> - 2016-05-16 21:10 +0200
Re: [PATCH v2 4/5] of: overlay: Pick up label symbols from overlays. Pantelis Antoniou <pantelis.antoniou@konsulko.com> - 2016-05-16 21:30 +0200
Re: [PATCH v2 4/5] of: overlay: Pick up label symbols from overlays. Geert Uytterhoeven <geert@linux-m68k.org> - 2016-05-16 21:50 +0200
Re: [PATCH v2 4/5] of: overlay: Pick up label symbols from overlays. Geert Uytterhoeven <geert@linux-m68k.org> - 2016-05-17 08:40 +0200
csiph-web