Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1391275

Re: [PATCH] gpio: tegra: Implement gpio_get_direction callback

From Stephen Warren <swarren@wwwdotorg.org>
Newsgroups linux.kernel
Subject Re: [PATCH] gpio: tegra: Implement gpio_get_direction callback
Date 2016-04-29 18:20 +0200
Message-ID <rtjj4-Bp-11@gated-at.bofh.it> (permalink)
References <rtg1S-657-41@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 04/29/2016 06:31 AM, Laxman Dewangan wrote:
> Implement gpio_get_direction() callback for Tegra GPIO.
> The direction is only valid if the pin is configured as
> GPIO. If pin is not configured in GPIO mode then this
> function return error.
>
> This makes debugfs and initial reading of the state of
> the lines more accurate.

> +static int tegra_gpio_get_direction(struct gpio_chip *chip, unsigned offset)
> +{
> +	struct tegra_gpio_info *tgi = gpiochip_get_data(chip);
> +	u32 pin_mask = BIT(GPIO_BIT(offset));
> +	u32 cnf, oe;
> +
> +	cnf = tegra_gpio_readl(tgi, GPIO_CNF(tgi, offset));
> +	oe = tegra_gpio_readl(tgi, GPIO_OE(tgi, offset));
> +	if (cnf & pin_mask) {
> +		if (oe & pin_mask)
> +			return GPIOF_DIR_OUT;
> +
> +		return GPIOF_DIR_IN;
> +	}
> +
> +	return -EINVAL;
> +}

Conceptually looks fine, but I have similar comments to Jon; whenever 
there's an error condition, just fail immediately. That way you avoid 
the entire rest of the function being indented:

cnf = ...
if (!(cnf ...)
     return -EINVAL;
oe = ...
return ...

The only indented code there is the error handling. At least to me, this 
makes the code a lot more readable since there are far fewer 
combinations of conditionals.

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH] gpio: tegra: Implement gpio_get_direction callback Laxman Dewangan <ldewangan@nvidia.com> - 2016-04-29 14:50 +0200
  Re: [PATCH] gpio: tegra: Implement gpio_get_direction callback Jon Hunter <jonathanh@nvidia.com> - 2016-04-29 17:40 +0200
  Re: [PATCH] gpio: tegra: Implement gpio_get_direction callback Stephen Warren <swarren@wwwdotorg.org> - 2016-04-29 18:20 +0200

csiph-web