Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1386392

Re: [PATCH] make dt_scan_depth1_nodes more readable

From Stefano Stabellini <sstabellini@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH] make dt_scan_depth1_nodes more readable
Date 2016-04-25 15:00 +0200
Message-ID <rrOhm-643-27@gated-at.bofh.it> (permalink)
References (1 earlier) <rrMpc-4ls-9@gated-at.bofh.it> <rrMyR-4Ln-5@gated-at.bofh.it> <rrMIy-4QJ-21@gated-at.bofh.it> <rrMSf-4Wa-37@gated-at.bofh.it> <rrOhk-643-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Mon, 25 Apr 2016, Will Deacon wrote:
> On Mon, Apr 25, 2016 at 12:24:03PM +0100, Stefano Stabellini wrote:
> > On Mon, 25 Apr 2016, Will Deacon wrote:
> > > On Mon, Apr 25, 2016 at 12:04:53PM +0100, Stefano Stabellini wrote:
> > > > On Mon, 25 Apr 2016, Will Deacon wrote:
> > > > > On Mon, Apr 25, 2016 at 11:25:11AM +0100, Stefano Stabellini wrote:
> > > > > > From: Mark Rutland <mark.rutland@arm.com>
> > > > > > 
> > > > > > Improve the readability of dt_scan_depth1_nodes by removing the nested
> > > > > > conditionals.
> > > > > > 
> > > > > > Signed-off-by: Mark Rutland <mark.rutland@arm.com>
> > > > > > Signed-off-by: Stefano Stabellini <sstabellini@kernel.org>
> > > > > > 
> > > > > > ---
> > > > > > 
> > > > > > Note: this patch is based on xentip/for-linus-4.7
> > > > > 
> > > > > So how should I merge it? :/
> > > > 
> > > > I think that if you would like to merge it, it would be easier this time
> > > > for me to carry it in my tree. Otherwise you would have to base your
> > > > for-linus-4.7 on xentip/for-linus-4.7 and send the pull request after
> > > > the Xen pull request -- undesirable.
> > > 
> > > Ok, doesn't look like we'll run into conflicts. I just find it weird that
> > > you'd have a patch with no functional change as a dependency, hence my
> > > preference to queue it in the arm64 tree (where conflicts are more likely).
> >  
> > I see, that makes sense. In that case, would you be happy to take:
> > 
> > https://git.kernel.org/cgit/linux/kernel/git/xen/tip.git/commit/?h=for-linus-4.7&id=df115bb0a0b8ad2f6dc62f8d094c21e77b367e7c
> > 
> > in your tree? That would get rid of any cross dependecies between the
> > two tree.
> 
> I can take that and the other patch on top too.

Perfect. I'll remove df115bb0a0b8ad2f6dc62f8d094c21e77b367e7c from xentip/for-linus-4.7.

Thanks,

Stefano

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH] make dt_scan_depth1_nodes more readable Stefano Stabellini <sstabellini@kernel.org> - 2016-04-25 12:30 +0200
  Re: [PATCH] make dt_scan_depth1_nodes more readable Will Deacon <will.deacon@arm.com> - 2016-04-25 13:00 +0200
    Re: [PATCH] make dt_scan_depth1_nodes more readable Stefano Stabellini <sstabellini@kernel.org> - 2016-04-25 13:10 +0200
      Re: [PATCH] make dt_scan_depth1_nodes more readable Will Deacon <will.deacon@arm.com> - 2016-04-25 13:20 +0200
        Re: [PATCH] make dt_scan_depth1_nodes more readable Stefano Stabellini <sstabellini@kernel.org> - 2016-04-25 13:30 +0200
          Re: [PATCH] make dt_scan_depth1_nodes more readable Will Deacon <will.deacon@arm.com> - 2016-04-25 15:00 +0200
            Re: [PATCH] make dt_scan_depth1_nodes more readable Stefano Stabellini <sstabellini@kernel.org> - 2016-04-25 15:00 +0200

csiph-web