Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1376672

[PATCH 27/28] mm: vmstat: Replace __count_zone_vm_events with a zone id equivalent

From Mel Gorman <mgorman@techsingularity.net>
Newsgroups linux.kernel
Subject [PATCH 27/28] mm: vmstat: Replace __count_zone_vm_events with a zone id equivalent
Date 2016-04-12 12:50 +0200
Message-ID <rn43n-643-1@gated-at.bofh.it> (permalink)
References <rn3K1-5ST-3@gated-at.bofh.it> <rn43n-643-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


This is partially a preparation patch for more vmstat work but it also
has the slight advantage that __count_zid_vm_events is cheaper to
calculate than __count_zone_vm_events().

Signed-off-by: Mel Gorman <mgorman@techsingularity.net>
---
 include/linux/vmstat.h | 5 ++---
 mm/page_alloc.c        | 2 +-
 2 files changed, 3 insertions(+), 4 deletions(-)

diff --git a/include/linux/vmstat.h b/include/linux/vmstat.h
index 24bca20ede8f..9360ef611f3e 100644
--- a/include/linux/vmstat.h
+++ b/include/linux/vmstat.h
@@ -101,9 +101,8 @@ static inline void vm_events_fold_cpu(int cpu)
 #define count_vm_vmacache_event(x) do {} while (0)
 #endif
 
-#define __count_zone_vm_events(item, zone, delta) \
-		__count_vm_events(item##_NORMAL - ZONE_NORMAL + \
-		zone_idx(zone), delta)
+#define __count_zid_vm_events(item, zid, delta) \
+	__count_vm_events(item##_NORMAL - ZONE_NORMAL + zid, delta)
 
 /*
  * Zone and node-based page accounting with per cpu differentials.
diff --git a/mm/page_alloc.c b/mm/page_alloc.c
index 490a3cd34b7d..6b20efec0f60 100644
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
@@ -2466,7 +2466,7 @@ struct page *buffered_rmqueue(struct zone *preferred_zone,
 					  get_pcppage_migratetype(page));
 	}
 
-	__count_zone_vm_events(PGALLOC, zone, 1 << order);
+	__count_zid_vm_events(PGALLOC, page_zonenum(page), 1 << order);
 	zone_statistics(preferred_zone, zone, gfp_flags);
 	local_irq_restore(flags);
 
-- 
2.6.4

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 00/28] Move LRU page reclaim from zones to nodes v4 Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:30 +0200
  [PATCH 03/28] mm, vmscan: Move lru_lock to the node Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:30 +0200
  [PATCH 09/28] mm, vmscan: Simplify the logic deciding whether kswapd sleeps Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:30 +0200
  [PATCH 11/28] mm, vmscan: Clear congestion, dirty and need for compaction on a per-node basis Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:30 +0200
  [PATCH 27/28] mm: vmstat: Replace __count_zone_vm_events with a zone id equivalent Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:50 +0200
  [PATCH 21/28] mm, vmscan: Update classzone_idx if buffer_heads_over_limit Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:50 +0200
  [PATCH 24/28] mm, vmscan: Add classzone information to tracepoints Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:50 +0200
  [PATCH 28/28] mm: vmstat: Account per-zone stalls and pages skipped during reclaim Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:50 +0200
  [PATCH 17/28] mm: Move page mapped accounting to the node Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:50 +0200
  [PATCH 26/28] mm: page_alloc: Cache the last node whose dirty limit is reached Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:50 +0200
  [PATCH 25/28] mm, page_alloc: Remove fair zone allocation policy Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:50 +0200
  [PATCH 14/28] mm, memcg: Move memcg limit enforcement from zones to nodes Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:50 +0200
    [PATCH 15/28] mm, workingset: Make working set detection node-aware Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:50 +0200
    [PATCH 23/28] mm: Convert zone_reclaim to node_reclaim Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:50 +0200
    [PATCH 20/28] mm: Move vmscan writes and file write accounting to the node Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:50 +0200
    [PATCH 16/28] mm, page_alloc: Consider dirtyable memory in terms of nodes Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:50 +0200
    [PATCH 18/28] mm: Rename NR_ANON_PAGES to NR_ANON_MAPPED Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:50 +0200
    [PATCH 22/28] mm, vmscan: Only wakeup kswapd once per node for the requested classzone Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:50 +0200
    [PATCH 19/28] mm: Move most file-based accounting to the node Mel Gorman <mgorman@techsingularity.net> - 2016-04-12 12:50 +0200

csiph-web