Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1365379

Re: [PATCH v6 2/4] power: reset: add reboot mode driver

From Krzysztof Kozlowski <k.kozlowski@samsung.com>
Newsgroups linux.kernel
Subject Re: [PATCH v6 2/4] power: reset: add reboot mode driver
Date 2016-03-28 10:10 +0200
Message-ID <rhApj-49N-1@gated-at.bofh.it> (permalink)
References (1 earlier) <rfsPf-3If-1@gated-at.bofh.it> <rg3F7-4lI-1@gated-at.bofh.it> <rg8v8-8at-9@gated-at.bofh.it> <rhz0e-36r-17@gated-at.bofh.it> <rhA5X-3M4-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 28.03.2016 16:40, Andy Yan wrote:
> Hi Krzysztof :
> 
> On 2016年03月28日 14:34, Krzysztof Kozlowski wrote:
>> On 24.03.2016 17:03, Andy Yan wrote:
>>> Hi Krzystof:
>> (...)
>>
>>>>> +static int get_reboot_mode_magic(struct reboot_mode_driver *reboot,
>>>>> +                                const char *cmd)
>>>>> +{
>>>>> +       const char *normal = "normal";
>>>>> +       int magic = 0;
>>>>> +       struct mode_info *info;
>>>>> +
>>>>> +       if (!cmd)
>>>>> +               cmd = normal;
>>>>> +
>>>>> +       list_for_each_entry(info, &reboot->head, list) {
>>>>> +               if (!strcmp(info->mode, cmd)) {
>>>>> +                       magic = info->magic;
>>>>> +                       break;
>>>>> +               }
>>>>> +       }
>>>>> +
>>>>> +       return magic;
>>>> In absence of 'normal' mode (it is not described as required property)
>>>> the magic will be '0'. It would be nice to document that in bindings.
>>>> Imagine someone forgets about this and will wonder why 0x0 is written
>>>> to his precious register on normal reboot...
>>>      If the magic value is '0', we won't touch the register, please see
>>> reboot_mode_notify bellow.
>> Ah, indeed... so we cannot use value of '0' for magic (e.g. to clear any
>> existing value for normal reboot)?
> 
>     It seems that the value '0' cannot be used.

How about mentioning it in bindings documentation?

(...)

>>>>> +               strcpy(info->mode, prop->name + len);
>>>> Ehm, and how do you protect that name of mode is shorter than 32
>>>> characters?
>>>      How about info->mode = prop->name + len ?
>> I don't get your answer.
>> As fair as I read the code, the prop->name can be very long and you are
>> copying it from 5 character. If the name of the mode has bazillion
>> characters then again my question: how do you protect that it will fit
>> in 32 bytes of 'mode'?
> 
>     What I mean is set info->mode as a pointer point to prop->name + len
> 
>    struct mode_info {
>             char *mode;
>             ..........
>             .........
>    }
> 
>    info->mode = prop->name + len

Ahh, I get it. Then I guess you should also do of_node_get() and
of_node_put()... and use kstrdup_const(). Looks good but I am not
familiar with overlays and life-cycle of OF nodes (documentation for the
life-cycle is a todo list item: Documentation/devicetree/todo.txt).

Best regards,
Krzysztof

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH v6 2/4] power: reset: add reboot mode driver Andy Yan <andy.yan@rock-chips.com> - 2016-03-22 12:40 +0100
  Re: [PATCH v6 2/4] power: reset: add reboot mode driver Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-03-24 04:00 +0100
    Re: [PATCH v6 2/4] power: reset: add reboot mode driver Andy Yan <andy.yan@rock-chips.com> - 2016-03-24 09:10 +0100
      Re: [PATCH v6 2/4] power: reset: add reboot mode driver Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-03-28 08:40 +0200
        Re: [PATCH v6 2/4] power: reset: add reboot mode driver Andy Yan <andy.yan@rock-chips.com> - 2016-03-28 09:50 +0200
          Re: [PATCH v6 2/4] power: reset: add reboot mode driver Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-03-28 10:10 +0200

csiph-web