Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1449787

Re: [PATCH -next] mm: Drop unnecessary include file

From Johannes Weiner <hannes@cmpxchg.org>
Newsgroups linux.kernel
Subject Re: [PATCH -next] mm: Drop unnecessary include file
Date 2016-07-25 22:40 +0200
Message-ID <rYUPn-HU-9@gated-at.bofh.it> (permalink)
References <rYkCe-402-13@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Sat, Jul 23, 2016 at 10:50:08PM -0700, Guenter Roeck wrote:
> Commmit e9be930fa6b5 ("mm: fix vm-scalability regression in cgroup-aware
> workingset code") adds '#include <linux/mm.h>' to
> include/linux/memcontrol.h. This results in the following build error
> when building hexagon images.
> 
> In file included from ./include/linux/memcontrol.h:32:0,
>                  from ./include/linux/swap.h:8,
> 		 from ./arch/hexagon/include/asm/pgtable.h:27,
> 		 from mm/init-mm.c:9:
> ./include/linux/mm.h:322:2: error: unknown type name 'pmd_t'
> ./include/linux/mm.h:353:7: error: unknown type name 'pmd_t'
> ./include/linux/mm.h:414:30: error: unknown type name 'pmd_t'
> 
> The include file does not appear to be necessary, so just drop it.
> 
> Fixes: e9be930fa6b5 ("mm: fix vm-scalability regression in cgroup-aware workingset code")
> Cc: Johannes Weiner <hannes@cmpxchg.org>
> Signed-off-by: Guenter Roeck <linux@roeck-us.net>

It was needed because mem_cgroup_zone_zoneinfo() used zone_to_nid().
Mel's nodelru patches have since renamed it to mem_cgroup_nodeinfo()
and dropped the zone_to_nid() reference, that's why it's no longer
necessary.

Acked-by: Johannes Weiner <hannes@cmpxchg.org>

[ I'd put it in after the nodelru patches, though, to maintain
  bisectability on x86 over hexagon. ]

Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

[PATCH -next] mm: Drop unnecessary include file Guenter Roeck <linux@roeck-us.net> - 2016-07-24 08:00 +0200
  Re: [PATCH -next] mm: Drop unnecessary include file Michal Hocko <mhocko@kernel.org> - 2016-07-25 10:10 +0200
  Re: [PATCH -next] mm: Drop unnecessary include file Johannes Weiner <hannes@cmpxchg.org> - 2016-07-25 22:40 +0200

csiph-web