Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1415837

[PATCH v4 06/14] of_numa: Use of_get_next_parent to simplify code

From Zhen Lei <thunder.leizhen@huawei.com>
Newsgroups linux.kernel
Subject [PATCH v4 06/14] of_numa: Use of_get_next_parent to simplify code
Date 2016-06-07 10:20 +0200
Message-ID <rHkoX-gO-35@gated-at.bofh.it> (permalink)
References <rHkff-6M-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Kefeng Wang <wangkefeng.wang@huawei.com>

Use of_get_next_parent() instead of open-code.

Signed-off-by: Kefeng Wang <wangkefeng.wang@huawei.com>
---
 drivers/of/of_numa.c | 6 +-----
 1 file changed, 1 insertion(+), 5 deletions(-)

diff --git a/drivers/of/of_numa.c b/drivers/of/of_numa.c
index 3157130..ed7bd22 100644
--- a/drivers/of/of_numa.c
+++ b/drivers/of/of_numa.c
@@ -153,8 +153,6 @@ int of_node_to_nid(struct device_node *device)
 	np = of_node_get(device);

 	while (np) {
-		struct device_node *parent;
-
 		r = of_property_read_u32(np, "numa-node-id", &nid);
 		/*
 		 * -EINVAL indicates the property was not found, and
@@ -165,9 +163,7 @@ int of_node_to_nid(struct device_node *device)
 		if (r != -EINVAL)
 			break;

-		parent = of_get_parent(np);
-		of_node_put(np);
-		np = parent;
+		np = of_get_next_parent(np);
 	}
 	if (np && r)
 		pr_warn("NUMA: Invalid \"numa-node-id\" property in node %s\n",
--
2.5.0

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v4 00/14] fix some type infos and bugs for arm64/of numa Zhen Lei <thunder.leizhen@huawei.com> - 2016-06-07 10:20 +0200
  [PATCH v4 06/14] of_numa: Use of_get_next_parent to simplify code Zhen Lei <thunder.leizhen@huawei.com> - 2016-06-07 10:20 +0200
  [PATCH v4 11/14] arm64/numa: support HAVE_MEMORYLESS_NODES Zhen Lei <thunder.leizhen@huawei.com> - 2016-06-07 10:20 +0200
    Re: [PATCH v4 11/14] arm64/numa: support HAVE_MEMORYLESS_NODES Ganapatrao Kulkarni <gpkulkarni@gmail.com> - 2016-06-07 10:40 +0200
      Re: [PATCH v4 11/14] arm64/numa: support HAVE_MEMORYLESS_NODES "Leizhen (ThunderTown)" <thunder.leizhen@huawei.com> - 2016-06-07 15:00 +0200
        Re: [PATCH v4 11/14] arm64/numa: support HAVE_MEMORYLESS_NODES Ganapatrao Kulkarni <gpkulkarni@gmail.com> - 2016-06-07 16:10 +0200
          Re: [PATCH v4 11/14] arm64/numa: support HAVE_MEMORYLESS_NODES "Leizhen (ThunderTown)" <thunder.leizhen@huawei.com> - 2016-06-08 04:30 +0200
            Re: [PATCH v4 11/14] arm64/numa: support HAVE_MEMORYLESS_NODES Ganapatrao Kulkarni <gpkulkarni@gmail.com> - 2016-06-08 06:50 +0200
              Re: [PATCH v4 11/14] arm64/numa: support HAVE_MEMORYLESS_NODES "Leizhen (ThunderTown)" <thunder.leizhen@huawei.com> - 2016-06-08 10:00 +0200
  [PATCH v4 08/14] arm64: numa: Use pr_fmt() Zhen Lei <thunder.leizhen@huawei.com> - 2016-06-07 10:20 +0200
  [PATCH v4 02/14] of/numa: fix a memory@ node can only contains one memory block Zhen Lei <thunder.leizhen@huawei.com> - 2016-06-07 10:20 +0200
  [PATCH v4 01/14] of/numa: remove a duplicated pr_debug information Zhen Lei <thunder.leizhen@huawei.com> - 2016-06-07 10:20 +0200
  [PATCH v4 05/14] arm64/numa: avoid inconsistent information to be printed Zhen Lei <thunder.leizhen@huawei.com> - 2016-06-07 10:20 +0200
  [PATCH v4 09/14] arm64/numa: support HAVE_SETUP_PER_CPU_AREA Zhen Lei <thunder.leizhen@huawei.com> - 2016-06-07 10:20 +0200
  [PATCH v4 12/14] arm64/numa: remove some useless code Zhen Lei <thunder.leizhen@huawei.com> - 2016-06-07 10:20 +0200
    Re: [PATCH v4 12/14] arm64/numa: remove some useless code Ganapatrao Kulkarni <gpkulkarni@gmail.com> - 2016-06-07 10:30 +0200
      Re: [PATCH v4 12/14] arm64/numa: remove some useless code "Leizhen (ThunderTown)" <thunder.leizhen@huawei.com> - 2016-06-07 14:50 +0200
  Re: [PATCH v4 00/14] fix some type infos and bugs for arm64/of numa Will Deacon <will.deacon@arm.com> - 2016-06-07 16:00 +0200
    Re: [PATCH v4 00/14] fix some type infos and bugs for arm64/of numa "Leizhen (ThunderTown)" <thunder.leizhen@huawei.com> - 2016-06-08 11:10 +0200
  Re: [PATCH v4 00/14] fix some type infos and bugs for arm64/of numa Rob Herring <robh+dt@kernel.org> - 2016-06-07 22:40 +0200

csiph-web