Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1417875
| From | David Kershner <david.kershner@unisys.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v4 24/29] staging: unisys: visorbus: Rename function to follow existing convention |
| Date | 2016-06-08 23:20 +0200 |
| Message-ID | <rHT3k-5qw-15@gated-at.bofh.it> (permalink) |
| References | <rHT3k-5qw-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: David Binder <david.binder@unisys.com>
Renames visorchipset_device_pause_response to device_pause_response,
thereby following the convention that other responder functions follow.
Signed-off-by: David Binder <david.binder@unisys.com>
Signed-off-by: David Kershner <david.kershner@unisys.com>
---
drivers/staging/unisys/visorbus/visorbus_main.c | 4 ++--
drivers/staging/unisys/visorbus/visorbus_private.h | 3 +--
drivers/staging/unisys/visorbus/visorchipset.c | 4 ++--
3 files changed, 5 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/unisys/visorbus/visorbus_main.c b/drivers/staging/unisys/visorbus/visorbus_main.c
index c361077..293532f 100644
--- a/drivers/staging/unisys/visorbus/visorbus_main.c
+++ b/drivers/staging/unisys/visorbus/visorbus_main.c
@@ -1218,7 +1218,7 @@ pause_state_change_complete(struct visor_device *dev, int status)
dev->pausing = false;
- visorchipset_device_pause_response(dev, status);
+ device_pause_response(dev, status);
}
/**
@@ -1265,7 +1265,7 @@ initiate_chipset_device_pause_resume(struct visor_device *dev, bool is_pause)
void (*notify_func)(struct visor_device *dev, int response) = NULL;
if (is_pause)
- notify_func = visorchipset_device_pause_response;
+ notify_func = device_pause_response;
else
notify_func = device_resume_response;
if (!notify_func)
diff --git a/drivers/staging/unisys/visorbus/visorbus_private.h b/drivers/staging/unisys/visorbus/visorbus_private.h
index 3b5a8f2..a7b1d4f 100644
--- a/drivers/staging/unisys/visorbus/visorbus_private.h
+++ b/drivers/staging/unisys/visorbus/visorbus_private.h
@@ -35,8 +35,7 @@ void bus_destroy_response(struct visor_device *p, int response);
void device_create_response(struct visor_device *p, int response);
void device_destroy_response(struct visor_device *p, int response);
void device_resume_response(struct visor_device *p, int response);
-void visorchipset_device_pause_response(struct visor_device *p,
- int response);
+void device_pause_response(struct visor_device *p, int response);
/* visorbus init and exit functions */
int visorbus_init(void);
diff --git a/drivers/staging/unisys/visorbus/visorchipset.c b/drivers/staging/unisys/visorbus/visorchipset.c
index ea548df..0b4a138 100644
--- a/drivers/staging/unisys/visorbus/visorchipset.c
+++ b/drivers/staging/unisys/visorbus/visorchipset.c
@@ -1983,8 +1983,8 @@ device_destroy_response(struct visor_device *dev_info, int response)
}
void
-visorchipset_device_pause_response(struct visor_device *dev_info,
- int response)
+device_pause_response(struct visor_device *dev_info,
+ int response)
{
device_changestate_responder(CONTROLVM_DEVICE_CHANGESTATE,
dev_info, response,
--
1.9.1
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
[PATCH v4 24/29] staging: unisys: visorbus: Rename function to follow existing convention David Kershner <david.kershner@unisys.com> - 2016-06-08 23:20 +0200
csiph-web