Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1271031
| From | Bartosz Golaszewski <bgolaszewski@baylibre.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [RESEND PATCH v2 8/9] eeprom: at24: remove a reduntant if |
| Date | 2015-11-17 11:00 +0100 |
| Message-ID | <qvLdo-3kN-29@gated-at.bofh.it> (permalink) |
| References | <qvLdn-3kN-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
It seems as if the second check for I2C_FUNC_I2C functionality had been
introduced accidentally during a merge. Tt's reduntant, so remove it.
Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
---
drivers/misc/eeprom/at24.c | 3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/misc/eeprom/at24.c b/drivers/misc/eeprom/at24.c
index 6e28b02..1288193 100644
--- a/drivers/misc/eeprom/at24.c
+++ b/drivers/misc/eeprom/at24.c
@@ -634,10 +634,7 @@ static int at24_probe(struct i2c_client *client, const struct i2c_device_id *id)
} else {
return -EPFNOSUPPORT;
}
- }
- /* Use I2C operations unless we're stuck with SMBus extensions. */
- if (!i2c_check_functionality(client->adapter, I2C_FUNC_I2C)) {
if (i2c_check_functionality(client->adapter,
I2C_FUNC_SMBUS_WRITE_I2C_BLOCK)) {
use_smbus_write = I2C_SMBUS_I2C_BLOCK_DATA;
--
2.1.4
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[RESEND PATCH v2 0/9] eeprom: at24: at24cs series serial number read Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2015-11-17 11:00 +0100 [RESEND PATCH v2 2/9] eeprom: at24: new flag in platform_data Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2015-11-17 11:00 +0100 [RESEND PATCH v2 5/9] eeprom: at24: export the serial number through sysfs Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2015-11-17 11:00 +0100 [RESEND PATCH v2 8/9] eeprom: at24: remove a reduntant if Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2015-11-17 11:00 +0100 [RESEND PATCH v2 6/9] eeprom: at24: improve the device_id table readability Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2015-11-17 11:00 +0100 [RESEND PATCH v2 3/9] eeprom: at24: tie up an additional address for at24cs series Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2015-11-17 11:00 +0100
csiph-web