Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1248833
| From | Linus Walleij <linus.walleij@linaro.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v9] gpio: Add GPIO support for the ACCES 104-IDIO-16 |
| Date | 2015-10-16 17:10 +0200 |
| Message-ID | <qkeNP-1vA-7@gated-at.bofh.it> (permalink) |
| References | <qhONQ-7Be-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Sat, Oct 10, 2015 at 12:55 AM, William Breathitt Gray
<vilhelm.gray@gmail.com> wrote:
> The ACCES 104-IDIO-16 family of PC/104 utility boards feature 16
> optically isolated inputs and 16 optically isolated FET solid state
> outputs. This driver provides GPIO support for these 32 channels of
> digital I/O. Change-of-State detection interrupts are not supported.
>
> GPIO 0-15 correspond to digital outputs 0-15, while GPIO 16-31
> correspond to digital inputs 0-15. The base port address for the device
> may be set via the a_104_idio_16_base module parameter.
>
> Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
> ---
> Changes in v9:
> - Initialize GPIO device private data structure to 0 to prevent
> garbage data pollution
Getting there...
> +static unsigned a_104_idio_16_base;
> +module_param(a_104_idio_16_base, uint, 0);
> +MODULE_PARM_DESC(a_104_idio_16_base, "ACCES 104-IDIO-16 base address");
This is nice!
> +static int __init a_104_idio_16_probe(struct platform_device *pdev)
> +{
> + struct a_104_idio_16_gpio *const a104idio16gp = pdev->dev.platform_data;
No.
Why not just allocate zeroed it here in probe() like this:
struct a_104_idio_16_gpio *gp;
gp = devm_kzalloc(&pdev->dev, sizeof(*gp), GFP_KERNEL);
if (!gp)
return -ENOMEM;
You may want to rename "a_104_idio_16_gpio" to something more everyday.
This is hard to type.
> +static int __init a_104_idio_16_init(void)
> +{
> + int err;
> + const struct a_104_idio_16_gpio GP = { 0 };
This just works by chance. The keyword you're looking for is not "const"
but "static" if you want this to stay around. But do it as described above
instead.
> + a_104_idio_16_device = platform_device_register_data(NULL,
> + a_104_idio_16_driver.driver.name, -1, &GP, sizeof(GP));
> + if (IS_ERR(a_104_idio_16_device)) {
> + err = PTR_ERR(a_104_idio_16_device);
> + goto out_platform_device;
> + }
Skip all this. Use devm_kzalloc() in probe as described.
> +
> + dev_info(&a_104_idio_16_device->dev, "Initializing module\n");
> +
> + err = platform_driver_probe(&a_104_idio_16_driver, a_104_idio_16_probe);
> + if (err)
> + goto out_platform_driver;
> +
> + return 0;
> +
> +out_platform_driver:
> + platform_device_unregister(a_104_idio_16_device);
> +out_platform_device:
> + return err;
> +}
Then this can be just return platform_driver_probe(...);
Yours,
Linus Walleij
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v9] gpio: Add GPIO support for the ACCES 104-IDIO-16 William Breathitt Gray <vilhelm.gray@gmail.com> - 2015-10-10 01:00 +0200 Re: [PATCH v9] gpio: Add GPIO support for the ACCES 104-IDIO-16 Linus Walleij <linus.walleij@linaro.org> - 2015-10-16 17:10 +0200
csiph-web