Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1306066
| From | Ingo Molnar <mingo@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC 09/13] x86/mm: Disable interrupts when flushing the TLB using CR3 |
| Date | 2016-01-11 12:00 +0100 |
| Message-ID | <qPImE-1cN-47@gated-at.bofh.it> (permalink) |
| References | <qOOu6-5ka-5@gated-at.bofh.it> <qOOu6-5ka-29@gated-at.bofh.it> <qOOX7-5wC-1@gated-at.bofh.it> <qOPq9-5WM-13@gated-at.bofh.it> <qORrX-7fC-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
* Linus Torvalds <torvalds@linux-foundation.org> wrote: > >> Or is there some reason you wanted the odd flags version? If so, that > >> should be documented. > > > > What do you mean "odd"? > > It's odd because it makes no sense for non-pcid (christ, I wish Intel had just > called it "asid" instead, "pcid" always makes me react to "pci"), and I think it > would make more sense to pair up the pcid case with the invpcid rather than have > those preemption rules here. The naming is really painful, so a trivial suggestion: could we just name all the Linux side bits 'asid' or 'ctx_id' (even in x86 arch code) and only use 'PCID' nomenclature in the very lowest level code? I.e. rename pcid_live_cpus et al and most functions to the asid or ctx_id or asid naming scheme or so. That would hide most of the naming ugliness. Thanks, Ingo
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[RFC 09/13] x86/mm: Disable interrupts when flushing the TLB using CR3 Andy Lutomirski <luto@kernel.org> - 2016-01-09 00:20 +0100
Re: [RFC 09/13] x86/mm: Disable interrupts when flushing the TLB using CR3 Linus Torvalds <torvalds@linux-foundation.org> - 2016-01-09 00:50 +0100
Re: [RFC 09/13] x86/mm: Disable interrupts when flushing the TLB using CR3 Andy Lutomirski <luto@amacapital.net> - 2016-01-09 01:20 +0100
Re: [RFC 09/13] x86/mm: Disable interrupts when flushing the TLB using CR3 Linus Torvalds <torvalds@linux-foundation.org> - 2016-01-09 03:30 +0100
Re: [RFC 09/13] x86/mm: Disable interrupts when flushing the TLB using CR3 Ingo Molnar <mingo@kernel.org> - 2016-01-11 12:00 +0100
Re: [RFC 09/13] x86/mm: Disable interrupts when flushing the TLB using CR3 Andy Lutomirski <luto@amacapital.net> - 2016-01-14 00:40 +0100
Re: [RFC 09/13] x86/mm: Disable interrupts when flushing the TLB using CR3 Andy Lutomirski <luto@amacapital.net> - 2016-01-14 00:40 +0100
Re: [RFC 09/13] x86/mm: Disable interrupts when flushing the TLB using CR3 Dave Hansen <dave.hansen@linux.intel.com> - 2016-01-14 00:50 +0100
Re: [RFC 09/13] x86/mm: Disable interrupts when flushing the TLB using CR3 Dave Hansen <dave.hansen@linux.intel.com> - 2016-01-14 01:00 +0100
Re: [RFC 09/13] x86/mm: Disable interrupts when flushing the TLB using CR3 Andy Lutomirski <luto@amacapital.net> - 2016-01-14 01:40 +0100
Re: [RFC 09/13] x86/mm: Disable interrupts when flushing the TLB using CR3 Andy Lutomirski <luto@amacapital.net> - 2016-01-14 01:00 +0100
csiph-web