Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1293944
| From | "Michael S. Tsirkin" <mst@redhat.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] virtio: use smp_load_acquire/smp_store_release |
| Date | 2015-12-17 15:50 +0100 |
| Message-ID | <qGI2t-IG-9@gated-at.bofh.it> (permalink) |
| References | <qGDYS-6sp-13@gated-at.bofh.it> <qGErU-6H4-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thu, Dec 17, 2015 at 11:58:27AM +0100, Peter Zijlstra wrote:
> On Thu, Dec 17, 2015 at 12:29:03PM +0200, Michael S. Tsirkin wrote:
> > +static inline __virtio16 virtio_load_acquire(bool weak_barriers, __virtio16 *p)
> > +{
> > + if (!weak_barriers) {
> > + rmb();
> > + return READ_ONCE(*p);
> > + }
> > +#ifdef CONFIG_SMP
> > + return smp_load_acquire(p);
> > +#else
> > + dma_rmb();
> > + return READ_ONCE(*p);
> > +#endif
> > +}
>
> This too is wrong. Look for example at arm.
>
> dma_rmb() is dmb(osh), while the smp_mb() used by smp_load_acquire() is
> dmb(ish). They order completely different types of memory accesses.
>
> Also, load_acquire() is first load, then barrier, and an ACQUIRE barrier
> at that, not a READ barrier.
Yes - it just so happens that READ barrier is enough for where I use it
for virtio.
I really just need virtio_load_acquire that fences reads,
I don't care what happens to writes.
Given the confusion, maybe virtio_load_acquire is a bad name though.
Donnu what a good name would be.
virtio_load_acquire_rmb and virtio_store_release_wmb?
> So your #else branch should look something like:
>
> var = READ_ONCE(*p);
> dma_mb();
> return var;
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH] virtio: use smp_load_acquire/smp_store_release "Michael S. Tsirkin" <mst@redhat.com> - 2015-12-17 11:30 +0100
Re: [PATCH] virtio: use smp_load_acquire/smp_store_release Peter Zijlstra <peterz@infradead.org> - 2015-12-17 12:00 +0100
Re: [PATCH] virtio: use smp_load_acquire/smp_store_release "Michael S. Tsirkin" <mst@redhat.com> - 2015-12-17 15:50 +0100
csiph-web