Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1286095
| From | Arnd Bergmann <arnd@arndb.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PSEUDOPATCH] rename is_compat_task |
| Date | 2015-12-08 00:20 +0100 |
| Message-ID | <qDdex-2Of-9@gated-at.bofh.it> (permalink) |
| References | <qDdex-2Of-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Monday 07 December 2015 15:12:59 Andy Lutomirski wrote: > Hi all- > > Every time I look at is_compat_task, I cringe. That function > determines whether we're in a compat syscall, not whether we're in a > compat task. There are probably architectures (arm64?) under which > these are the same conditions, but they are definitely *not* the same > thing on x86. > > Can we just fix it? I propose the following patch: > > $ find -type f |xargs sed -i -e 's/is_compat_task/in_compat_syscall/g' > > If there's general agreement, can we do that at the end of the next > merge window? > > I could also send a patch series to add in_compat_syscall, change all > the users, then delete the old stuff, but that seems overcomplicated > for something that's literally just renaming a token. As far as I know, x86 is the special case here, on all other architectures, this actually checks the task, and it's impossible to call a system call of the other kind. Arnd -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PSEUDOPATCH] rename is_compat_task Andy Lutomirski <luto@amacapital.net> - 2015-12-08 00:20 +0100
Re: [PSEUDOPATCH] rename is_compat_task Arnd Bergmann <arnd@arndb.de> - 2015-12-08 00:20 +0100
Re: [PSEUDOPATCH] rename is_compat_task Andy Lutomirski <luto@amacapital.net> - 2015-12-08 00:30 +0100
Re: [PSEUDOPATCH] rename is_compat_task Al Viro <viro@ZenIV.linux.org.uk> - 2015-12-08 00:50 +0100
Re: [PSEUDOPATCH] rename is_compat_task Ingo Molnar <mingo@kernel.org> - 2015-12-08 05:40 +0100
Re: [PSEUDOPATCH] rename is_compat_task Al Viro <viro@ZenIV.linux.org.uk> - 2015-12-08 05:50 +0100
Re: [PSEUDOPATCH] rename is_compat_task Ingo Molnar <mingo@kernel.org> - 2015-12-08 06:10 +0100
Re: [PSEUDOPATCH] rename is_compat_task Al Viro <viro@ZenIV.linux.org.uk> - 2015-12-08 06:20 +0100
Re: [PSEUDOPATCH] rename is_compat_task Andy Lutomirski <luto@amacapital.net> - 2015-12-08 07:00 +0100
csiph-web