Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1283034

[PATCH 6/7] spi: lm70llp: remove printk

From Sudip Mukherjee <sudipm.mukherjee@gmail.com>
Newsgroups linux.kernel
Subject [PATCH 6/7] spi: lm70llp: remove printk
Date 2015-12-03 14:10 +0100
Message-ID <qBBO2-5tU-25@gated-at.bofh.it> (permalink)
References <qBBO1-5tU-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Using pr_* macros are more prefferable than using printk. Start using
pr_* family of macros and define pr_fmt to be used with it.
While at it remove DRVNAME from an existing pr_info() as the name is now
being printed by pr_fmt.

Signed-off-by: Sudip Mukherjee <sudip@vectorindia.org>
---
 drivers/spi/spi-lm70llp.c | 13 +++++--------
 1 file changed, 5 insertions(+), 8 deletions(-)

diff --git a/drivers/spi/spi-lm70llp.c b/drivers/spi/spi-lm70llp.c
index 62d0f6d..39cf5dc 100644
--- a/drivers/spi/spi-lm70llp.c
+++ b/drivers/spi/spi-lm70llp.c
@@ -13,6 +13,7 @@
  * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
  * GNU General Public License for more details.
  */
+#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
 
 #include <linux/init.h>
 #include <linux/module.h>
@@ -199,9 +200,7 @@ static void spi_lm70llp_attach(struct parport *p)
 	int			status;
 
 	if (lm70llp) {
-		printk(KERN_WARNING
-			"%s: spi_lm70llp instance already loaded. Aborting.\n",
-			DRVNAME);
+		pr_warn("spi_lm70llp instance already loaded. Aborting.\n");
 		return;
 	}
 
@@ -246,9 +245,7 @@ static void spi_lm70llp_attach(struct parport *p)
 	 */
 	status = spi_bitbang_start(&pp->bitbang);
 	if (status < 0) {
-		printk(KERN_WARNING
-			"%s: spi_bitbang_start failed with status %d\n",
-			DRVNAME, status);
+		pr_warn("spi_bitbang_start failed with status %d\n", status);
 		goto out_off_and_release;
 	}
 
@@ -275,7 +272,7 @@ static void spi_lm70llp_attach(struct parport *p)
 		dev_dbg(&pp->spidev_lm70->dev, "spidev_lm70 at %s\n",
 			dev_name(&pp->spidev_lm70->dev));
 	else {
-		printk(KERN_WARNING "%s: spi_new_device failed\n", DRVNAME);
+		pr_warn("spi_new_device failed\n");
 		status = -ENODEV;
 		goto out_bitbang_stop;
 	}
@@ -296,7 +293,7 @@ out_parport_unreg:
 out_free_master:
 	spi_master_put(master);
 out_fail:
-	pr_info("%s: spi_lm70llp probe fail, status %d\n", DRVNAME, status);
+	pr_info("spi_lm70llp probe fail, status %d\n", status);
 }
 
 static void spi_lm70llp_detach(struct parport *p)
-- 
1.9.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 1/7] spi: lm70llp: remove multiple blank lines Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2015-12-03 14:10 +0100
  [PATCH 3/7] spi: lm70llp: remove cast to void Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2015-12-03 14:10 +0100
  [PATCH 7/7] spi: lm70llp: use new parport device model Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2015-12-03 14:10 +0100
  [PATCH 6/7] spi: lm70llp: remove printk Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2015-12-03 14:10 +0100
    Re: [PATCH 6/7] spi: lm70llp: remove printk Mark Brown <broonie@kernel.org> - 2015-12-04 13:20 +0100
  [PATCH 4/7] spi: lm70llp: correct alignment Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2015-12-03 14:10 +0100
  [PATCH 5/7] spi: lm70llp: remove space Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2015-12-03 14:10 +0100
  [PATCH 2/7] spi: lm70llp: add blank line after declaration Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2015-12-03 14:10 +0100

csiph-web