Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1222411
| From | Chen Gang <xili_gchen_5257@hotmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] mm/mmap.c: Remove useless statement "vma = NULL" in find_vma() |
| Date | 2015-09-11 00:20 +0200 |
| Message-ID | <q7ime-6uu-11@gated-at.bofh.it> (permalink) |
| References | <q5mki-2Hy-11@gated-at.bofh.it> <q6rUB-6Ec-15@gated-at.bofh.it> <q6WlI-8l1-13@gated-at.bofh.it> <q7eLE-11U-23@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 9/11/15 02:19, Oleg Nesterov wrote:
> On 09/10, Chen Gang wrote:
>> - If "addr>= vm_start", we return this vma (else continue searching).
>
> This is optimization, we can stop the search because in this case
> vma == tmp is obviously the 1st vma with "addr < vm_end".
>
OK, thanks.
I guess if we have additional comments for "if (tmp->vm_start <= addr)",
the code will be more readable for readers (especially for newbies).
@@ -2064,7 +2064,7 @@ struct vm_area_struct *find_vma(struct mm_struct *mm, unsigned long addr)
if (tmp->vm_end > addr) {
vma = tmp;
if (tmp->vm_start <= addr)
- break;
+ break; /* It must be 1st "addr < vm_end" */
rb_node = rb_node->rb_left;
} else
rb_node = rb_node->rb_right;
> I simply can't understand your concerns. Perhaps you can make a
> patch, then it will be more clear what me-or-you have missed.
>
I guess, we need not (it is my missing). :-)
Thanks.
--
Chen Gang (陈刚)
Open, share, and attitude like air, water, and life which God blessed
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [PATCH] mm/mmap.c: Remove useless statement "vma = NULL" in find_vma() Chen Gang <xili_gchen_5257@hotmail.com> - 2015-09-08 16:20 +0200
Re: [PATCH] mm/mmap.c: Remove useless statement "vma = NULL" in find_vma() Oleg Nesterov <oleg@redhat.com> - 2015-09-09 18:30 +0200
Re: [PATCH] mm/mmap.c: Remove useless statement "vma = NULL" in find_vma() Chen Gang <xili_gchen_5257@hotmail.com> - 2015-09-10 00:50 +0200
Re: [PATCH] mm/mmap.c: Remove useless statement "vma = NULL" in find_vma() Oleg Nesterov <oleg@redhat.com> - 2015-09-10 20:30 +0200
Re: [PATCH] mm/mmap.c: Remove useless statement "vma = NULL" in find_vma() Chen Gang <xili_gchen_5257@hotmail.com> - 2015-09-11 00:20 +0200
csiph-web