Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1218647
| From | 平松雅巳 / HIRAMATU,MASAMI <masami.hiramatsu.pt@hitachi.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | RE: [RFC/PATCH 2/3] perf probe: Rename __event_package to probe_event_package |
| Date | 2015-09-04 04:20 +0200 |
| Message-ID | <q4OLE-5eV-9@gated-at.bofh.it> (permalink) |
| References | <q4GEq-1WX-7@gated-at.bofh.it> <q4GEq-1WX-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
PiBGcm9tOiBOYW1oeXVuZyBLaW0gW21haWx0bzpuYW1oeXVuZ0BnbWFpbC5jb21dIE9uIEJlaGFs ZiBPZiBOYW1oeXVuZyBLaW0NCj4gDQo+IFRoZSBzdHJ1Y3QgX19ldmVudF9wYWNrYWdlIGNhbiBi ZSBhY2Nlc3NlZCBub3cgZnJvbSBvdGhlciB0aGFuDQo+IHByb2JlLWV2ZW50LmMgY29kZS4gIFNv IHJlbmFtZSBpdCB0byBtb3JlIHNwZWNpZmljIG5hbWUuDQo+IA0KPiBDYzogTWFzYW1pIEhpcmFt YXRzdSA8bWFzYW1pLmhpcmFtYXRzdS5wdEBoaXRhY2hpLmNvbT4NCj4gU2lnbmVkLW9mZi1ieTog TmFtaHl1bmcgS2ltIDxuYW1oeXVuZ0BrZXJuZWwub3JnPg0KPiAtLS0NCj4gIHRvb2xzL3BlcmYv dXRpbC9wcm9iZS1ldmVudC5jIHwgMTggKysrKysrLS0tLS0tLS0tLS0tDQo+ICB0b29scy9wZXJm L3V0aWwvcHJvYmUtZXZlbnQuaCB8IDEwICsrKysrKysrKysNCj4gIDIgZmlsZXMgY2hhbmdlZCwg MTYgaW5zZXJ0aW9ucygrKSwgMTIgZGVsZXRpb25zKC0pDQo+IA0KPiBkaWZmIC0tZ2l0IGEvdG9v bHMvcGVyZi91dGlsL3Byb2JlLWV2ZW50LmMgYi90b29scy9wZXJmL3V0aWwvcHJvYmUtZXZlbnQu Yw0KPiBpbmRleCA4ZWFhMDM0MjhkNzIuLmVlZjM5MzM4YmIyYSAxMDA2NDQNCj4gLS0tIGEvdG9v bHMvcGVyZi91dGlsL3Byb2JlLWV2ZW50LmMNCj4gKysrIGIvdG9vbHMvcGVyZi91dGlsL3Byb2Jl LWV2ZW50LmMNCj4gQEAgLTI3NTksMjAgKzI3NTksMTQgQEAgc3RhdGljIGludCBjb252ZXJ0X3Rv X3Byb2JlX3RyYWNlX2V2ZW50cyhzdHJ1Y3QgcGVyZl9wcm9iZV9ldmVudCAqcGV2LA0KPiAgCXJl dHVybiBmaW5kX3Byb2JlX3RyYWNlX2V2ZW50c19mcm9tX21hcChwZXYsIHRldnMpOw0KPiAgfQ0K PiANCj4gLXN0cnVjdCBfX2V2ZW50X3BhY2thZ2Ugew0KPiAtCXN0cnVjdCBwZXJmX3Byb2JlX2V2 ZW50CQkqcGV2Ow0KPiAtCXN0cnVjdCBwcm9iZV90cmFjZV9ldmVudAkqdGV2czsNCj4gLQlpbnQJ CQkJbnRldnM7DQo+IC19Ow0KPiAtDQo+IC1zdGF0aWMgaW50IF9fYWRkX3BlcmZfcHJvYmVfZXZl bnRzKHN0cnVjdCBwZXJmX3Byb2JlX2V2ZW50ICpwZXZzLCBpbnQgbnBldnMsDQo+IC0JCQkJICAg c3RydWN0IF9fZXZlbnRfcGFja2FnZSAqKnBwa2dzKQ0KPiAraW50IF9fYWRkX3BlcmZfcHJvYmVf ZXZlbnRzKHN0cnVjdCBwZXJmX3Byb2JlX2V2ZW50ICpwZXZzLCBpbnQgbnBldnMsDQo+ICsJCQkg ICAgc3RydWN0IHByb2JlX2V2ZW50X3BhY2thZ2UgKipwcGtncykNCg0KT0ssIHNpbmNlIG5vdyB3 ZSBoYXZlIHByb2JlX2V2ZW50X3BhY2thZ2Ugb2JqZWN0LCB0aGlzIGZ1bmN0aW9uIHNob3VsZCBi ZQ0KcmVmYWN0b3JlZCBhcyBwa2dzID0gcHJvYmVfZXZlbnRfcGFja2FnZXNfX25ldyhwZXZzLCBu cGV2cykoYWxsb2NhdGUsIGluaXRpYWxpemUpDQosIHByb2JlX2V2ZW50X3BhY2thZ2VzX19jb252 ZXJ0KHBrZ3MpIGFuZCBwcm9iZV9ldmVudF9wYWNrYWdlc19fYXBwbHkocGtncykuDQoNCj4gIHsN Cj4gIAlpbnQgaSwgcmV0Ow0KPiAtCXN0cnVjdCBfX2V2ZW50X3BhY2thZ2UgKnBrZ3M7DQo+ICsJ c3RydWN0IHByb2JlX2V2ZW50X3BhY2thZ2UgKnBrZ3M7DQo+IA0KPiAgCXJldCA9IDA7DQo+IC0J cGtncyA9IHphbGxvYyhzaXplb2Yoc3RydWN0IF9fZXZlbnRfcGFja2FnZSkgKiBucGV2cyk7DQo+ ICsJcGtncyA9IHphbGxvYyhzaXplb2Yoc3RydWN0IHByb2JlX2V2ZW50X3BhY2thZ2UpICogbnBl dnMpOw0KPiANCj4gIAlpZiAocGtncyA9PSBOVUxMKQ0KPiAgCQlyZXR1cm4gLUVOT01FTTsNCj4g QEAgLTI4MTMsNyArMjgwNyw3IEBAIHN0YXRpYyBpbnQgX19hZGRfcGVyZl9wcm9iZV9ldmVudHMo c3RydWN0IHBlcmZfcHJvYmVfZXZlbnQgKnBldnMsIGludCBucGV2cywNCj4gIAlyZXR1cm4gMDsN Cj4gIH0NCj4gDQo+IC1zdGF0aWMgdm9pZCBjbGVhbnVwX3BlcmZfcHJvYmVfZXZlbnRzKHN0cnVj dCBfX2V2ZW50X3BhY2thZ2UgKnBrZ3MsIGludCBucGV2cykNCj4gK3ZvaWQgY2xlYW51cF9wZXJm X3Byb2JlX2V2ZW50cyhzdHJ1Y3QgcHJvYmVfZXZlbnRfcGFja2FnZSAqcGtncywgaW50IG5wZXZz KQ0KDQpUaGlzIGFsc28gc2hvdWxkIGJlIHBlcmZfZXZlbnRfcGFjYWtnZXNfX2RlbGV0ZSgpIDop DQoNClRoYW5rcyENCg0KPiAgew0KPiAgCWludCBpLCBqOw0KPiANCj4gQEAgLTI4MzMsNyArMjgy Nyw3IEBAIHN0YXRpYyB2b2lkIGNsZWFudXBfcGVyZl9wcm9iZV9ldmVudHMoc3RydWN0IF9fZXZl bnRfcGFja2FnZSAqcGtncywgaW50IG5wZXZzKQ0KPiAgaW50IGFkZF9wZXJmX3Byb2JlX2V2ZW50 cyhzdHJ1Y3QgcGVyZl9wcm9iZV9ldmVudCAqcGV2cywgaW50IG5wZXZzKQ0KPiAgew0KPiAgCWlu dCByZXQ7DQo+IC0Jc3RydWN0IF9fZXZlbnRfcGFja2FnZSAqcGtncyA9IE5VTEw7DQo+ICsJc3Ry dWN0IHByb2JlX2V2ZW50X3BhY2thZ2UgKnBrZ3MgPSBOVUxMOw0KPiANCj4gIAlyZXQgPSBfX2Fk ZF9wZXJmX3Byb2JlX2V2ZW50cyhwZXZzLCBucGV2cywgJnBrZ3MpOw0KPiAgCWNsZWFudXBfcGVy Zl9wcm9iZV9ldmVudHMocGtncywgbnBldnMpOw0KPiBkaWZmIC0tZ2l0IGEvdG9vbHMvcGVyZi91 dGlsL3Byb2JlLWV2ZW50LmggYi90b29scy9wZXJmL3V0aWwvcHJvYmUtZXZlbnQuaA0KPiBpbmRl eCA2ZTdlYzY4YTRhYTguLjczZjkyMmZhN2NhYyAxMDA2NDQNCj4gLS0tIGEvdG9vbHMvcGVyZi91 dGlsL3Byb2JlLWV2ZW50LmgNCj4gKysrIGIvdG9vbHMvcGVyZi91dGlsL3Byb2JlLWV2ZW50LmgN Cj4gQEAgLTg5LDYgKzg5LDEyIEBAIHN0cnVjdCBwZXJmX3Byb2JlX2V2ZW50IHsNCj4gIAlzdHJ1 Y3QgcGVyZl9wcm9iZV9hcmcJKmFyZ3M7CS8qIEFyZ3VtZW50cyAqLw0KPiAgfTsNCj4gDQo+ICtz dHJ1Y3QgcHJvYmVfZXZlbnRfcGFja2FnZSB7DQo+ICsJc3RydWN0IHBlcmZfcHJvYmVfZXZlbnQJ CSpwZXY7DQo+ICsJc3RydWN0IHByb2JlX3RyYWNlX2V2ZW50CSp0ZXZzOw0KPiArCWludAkJCQlu dGV2czsNCj4gK307DQo+ICsNCj4gIC8qIExpbmUgcmFuZ2UgKi8NCj4gIHN0cnVjdCBsaW5lX3Jh bmdlIHsNCj4gIAljaGFyCQkJKmZpbGU7CQkvKiBGaWxlIG5hbWUgKi8NCj4gQEAgLTEzOCw2ICsx NDQsMTAgQEAgZXh0ZXJuIHZvaWQgbGluZV9yYW5nZV9fY2xlYXIoc3RydWN0IGxpbmVfcmFuZ2Ug KmxyKTsNCj4gIGV4dGVybiBpbnQgbGluZV9yYW5nZV9faW5pdChzdHJ1Y3QgbGluZV9yYW5nZSAq bHIpOw0KPiANCj4gIGV4dGVybiBpbnQgYWRkX3BlcmZfcHJvYmVfZXZlbnRzKHN0cnVjdCBwZXJm X3Byb2JlX2V2ZW50ICpwZXZzLCBpbnQgbnBldnMpOw0KPiArZXh0ZXJuIGludCBfX2FkZF9wZXJm X3Byb2JlX2V2ZW50cyhzdHJ1Y3QgcGVyZl9wcm9iZV9ldmVudCAqcGV2cywgaW50IG5wZXZzLA0K PiArCQkJCSAgIHN0cnVjdCBwcm9iZV9ldmVudF9wYWNrYWdlICoqcHBrZ3MpOw0KPiArZXh0ZXJu IHZvaWQgY2xlYW51cF9wZXJmX3Byb2JlX2V2ZW50cyhzdHJ1Y3QgcHJvYmVfZXZlbnRfcGFja2Fn ZSAqcGtncywNCj4gKwkJCQkgICAgICBpbnQgbnBldnMpOw0KPiAgZXh0ZXJuIGludCBkZWxfcGVy Zl9wcm9iZV9ldmVudHMoc3RydWN0IHN0cmZpbHRlciAqZmlsdGVyKTsNCj4gIGV4dGVybiBpbnQg c2hvd19wZXJmX3Byb2JlX2V2ZW50cyhzdHJ1Y3Qgc3RyZmlsdGVyICpmaWx0ZXIpOw0KPiAgZXh0 ZXJuIGludCBzaG93X2xpbmVfcmFuZ2Uoc3RydWN0IGxpbmVfcmFuZ2UgKmxyLCBjb25zdCBjaGFy ICptb2R1bGUsDQo+IC0tDQo+IDIuNS4wDQoNCg== -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[RFC/PATCH 2/3] perf probe: Rename __event_package to probe_event_package Namhyung Kim <namhyung@kernel.org> - 2015-09-03 19:40 +0200
RE: [RFC/PATCH 2/3] perf probe: Rename __event_package to probe_event_package 平松雅巳 / HIRAMATU,MASAMI <masami.hiramatsu.pt@hitachi.com> - 2015-09-04 04:20 +0200
Re: [RFC/PATCH 2/3] perf probe: Rename __event_package to probe_event_package Namhyung Kim <namhyung@kernel.org> - 2015-09-04 08:30 +0200
RE: Re: [RFC/PATCH 2/3] perf probe: Rename __event_package to probe_event_package 平松雅巳 / HIRAMATU,MASAMI <masami.hiramatsu.pt@hitachi.com> - 2015-09-04 10:00 +0200
csiph-web