Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1210944

Re: [PATCH 3/8] jump_label: introduce DEFINE_STATIC_KEY_{TRUE,FALSE}_ARRAY macros

From Ingo Molnar <mingo@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH 3/8] jump_label: introduce DEFINE_STATIC_KEY_{TRUE,FALSE}_ARRAY macros
Date 2015-08-21 08:50 +0200
Message-ID <pZOjf-4fE-7@gated-at.bofh.it> (permalink)
References <pZwZ4-4Ab-17@gated-at.bofh.it> <pZwZ6-4Ab-53@gated-at.bofh.it> <pZNZX-3SZ-87@gated-at.bofh.it> <pZO9z-44i-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


* Kevin Hao <haokexin@gmail.com> wrote:

> On Fri, Aug 21, 2015 at 08:28:26AM +0200, Ingo Molnar wrote:
> > 
> > * Kevin Hao <haokexin@gmail.com> wrote:
> > 
> > > These are used to define a static_key_{true,false} array.
> > > 
> > > Signed-off-by: Kevin Hao <haokexin@gmail.com>
> > > ---
> > >  include/linux/jump_label.h | 6 ++++++
> > >  1 file changed, 6 insertions(+)
> > > 
> > > diff --git a/include/linux/jump_label.h b/include/linux/jump_label.h
> > > index 7f653e8f6690..5c1d6a49dd6b 100644
> > > --- a/include/linux/jump_label.h
> > > +++ b/include/linux/jump_label.h
> > > @@ -267,6 +267,12 @@ struct static_key_false {
> > >  #define DEFINE_STATIC_KEY_FALSE(name)	\
> > >  	struct static_key_false name = STATIC_KEY_FALSE_INIT
> > >  
> > > +#define DEFINE_STATIC_KEY_TRUE_ARRAY(name, n)	\
> > > +	struct static_key_true name[n] = { [0 ... n - 1] = STATIC_KEY_TRUE_INIT }
> > > +
> > > +#define DEFINE_STATIC_KEY_FALSE_ARRAY(name, n)	\
> > > +	struct static_key_false name[n] = { [0 ... n - 1] = STATIC_KEY_FALSE_INIT }
> > 
> > I think the define makes the code more obfuscated and less clear, the open-coded 
> > initialization is pretty dense and easy to read to begin with.
> 
> OK, I will drop this patch and move the initialization of the array to the 
> corresponding patch.

Please also Cc: peterz and me to the next submission of the series - static key 
(and jump label) changes go through the locking tree normally, and there's a 
number of changes pending already for v4.3:

20f9ed1568c0 locking/static_keys: Make verify_keys() static
412758cb2670 jump label, locking/static_keys: Update docs
2bf9e0ab08c6 locking/static_keys: Provide a selftest
ed79e946732e s390/uaccess, locking/static_keys: employ static_branch_likely()
3bbfafb77a06 x86, tsc, locking/static_keys: Employ static_branch_likely()
1987c947d905 locking/static_keys: Add selftest
11276d5306b8 locking/static_keys: Add a new static_key interface
706249c222f6 locking/static_keys: Rework update logic
e33886b38cc8 locking/static_keys: Add static_key_{en,dis}able() helpers
7dcfd915bae5 jump_label: Add jump_entry_key() helper
a1efb01feca5 jump_label, locking/static_keys: Rename JUMP_LABEL_TYPE_* and related helpers to the static_key* pattern

Thanks,

	Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

[PATCH 0/8] powerpc: use jump label for {cpu,mmu}_has_feature() Kevin Hao <haokexin@gmail.com> - 2015-08-20 14:20 +0200
  [PATCH 8/8] powerpc: use jump label for mmu_has_feature Kevin Hao <haokexin@gmail.com> - 2015-08-20 14:20 +0200
  [PATCH 7/8] powerpc: use the jump label for cpu_has_feature Kevin Hao <haokexin@gmail.com> - 2015-08-20 14:20 +0200
  [PATCH 3/8] jump_label: introduce DEFINE_STATIC_KEY_{TRUE,FALSE}_ARRAY macros Kevin Hao <haokexin@gmail.com> - 2015-08-20 14:20 +0200
    Re: [PATCH 3/8] jump_label: introduce  DEFINE_STATIC_KEY_{TRUE,FALSE}_ARRAY macros Peter Zijlstra <peterz@infradead.org> - 2015-08-20 20:40 +0200
      Re: [PATCH 3/8] jump_label: introduce  DEFINE_STATIC_KEY_{TRUE,FALSE}_ARRAY macros Kevin Hao <haokexin@gmail.com> - 2015-08-21 05:30 +0200
    Re: [PATCH 3/8] jump_label: introduce  DEFINE_STATIC_KEY_{TRUE,FALSE}_ARRAY macros Ingo Molnar <mingo@kernel.org> - 2015-08-21 08:30 +0200
      Re: [PATCH 3/8] jump_label: introduce  DEFINE_STATIC_KEY_{TRUE,FALSE}_ARRAY macros Kevin Hao <haokexin@gmail.com> - 2015-08-21 08:40 +0200
        Re: [PATCH 3/8] jump_label: introduce  DEFINE_STATIC_KEY_{TRUE,FALSE}_ARRAY macros Kevin Hao <haokexin@gmail.com> - 2015-08-21 08:50 +0200
        Re: [PATCH 3/8] jump_label: introduce  DEFINE_STATIC_KEY_{TRUE,FALSE}_ARRAY macros Ingo Molnar <mingo@kernel.org> - 2015-08-21 08:50 +0200

csiph-web