Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1195268
| From | Boris Ostrovsky <boris.ostrovsky@oracle.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 4/8] xen: Use the correctly the Xen memory terminologies |
| Date | 2015-07-29 17:00 +0200 |
| Message-ID | <pRAZQ-2O4-7@gated-at.bofh.it> (permalink) |
| References | (1 earlier) <pReFY-4t9-23@gated-at.bofh.it> <pRizU-1Ck-19@gated-at.bofh.it> <pRxIC-6G2-25@gated-at.bofh.it> <pRAn7-24H-7@gated-at.bofh.it> <pRAwO-2g5-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 07/29/2015 10:23 AM, Julien Grall wrote:
> On 29/07/15 15:14, Boris Ostrovsky wrote:
>>> static inline unsigned long pfn_to_gfn(unsigned long pfn)
>>> {
>>> if (xen_feature(XENFEAT_autotranslated_physmap))
>>> return pfn;
>>> else
>>> return pfn_to_mfn(pfn);
>>> }
>>
>> But you'd still say 'op.arg1.mfn = pfn_to_gfn(pfn);' in xen_do_pin()
>> i.e. assign GFN to MFN, right? That's what I was referring to.
> Well no. I would use op.arg1.mfn = pfn_to_mfn(pfn) given that the code,
> if I'm right, is only executed for PV.
>
> mfn = pfn_to_gfn(...) was valid too because on PV is always an MFN. The
> suggestion of pfn_to_mfn was just for more readability,
Right, and my comments were also not about correctness.
>
>> (In general, I am not sure a guest should ever use 'mfn' as it is purely
>> a hypervisor construct. Including p2m, which I think should really be
>> p2g as this is what we use to figure out what to stick into page tables)
> I think avoid to use mfn in the hypervisor interface is out-of-scope for
> this series. If we ever want to modify the Xen API in Linux, we should
> do in sync with Xen to avoid inconsistency on naming.
>
> Anyway, the oddity of mfn = pfn_to_gfn(...) is mostly contained in the
> x86 specific code. I don't mind to either add pfn_to_mfn and use it or
> add a comment /* PV-specific so mfn == gfn */ for every use of mfn =
> pfn_to_gfn(...).
I think the former is better (even thought it adds a test)
-boris
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [PATCH 4/8] xen: Use the correctly the Xen memory terminologies Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2015-07-29 16:20 +0200
Re: [PATCH 4/8] xen: Use the correctly the Xen memory terminologies Julien Grall <julien.grall@citrix.com> - 2015-07-29 16:30 +0200
Re: [PATCH 4/8] xen: Use the correctly the Xen memory terminologies Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2015-07-29 17:00 +0200
csiph-web