Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1186264
| From | Peter Zijlstra <peterz@infradead.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v3 5/8] perf: Split perf_event_read_value() |
| Date | 2015-07-16 23:20 +0200 |
| Message-ID | <pMYJr-1Go-5@gated-at.bofh.it> (permalink) |
| References | <pMlf3-3in-3@gated-at.bofh.it> <pMlf4-3in-17@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, Jul 14, 2015 at 08:01:52PM -0700, Sukadev Bhattiprolu wrote:
> Move the part of perf_event_read_value() that computes the event
> counts and event times into a new function, perf_event_compute().
>
> This would allow us to call perf_event_compute() independently.
>
> Signed-off-by: Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com>
>
> Changelog[v3]
> Rather than move perf_event_read() into callers and then
> rename, just move the computations into a separate function
> (redesign to address comment from Peter Zijlstra).
> ---
Changelog[] bits go here, below the '---' where they get discarded.
> kernel/events/core.c | 37 ++++++++++++++++++++++++-------------
> 1 file changed, 24 insertions(+), 13 deletions(-)
>
> diff --git a/kernel/events/core.c b/kernel/events/core.c
> index 44fb89d..b1e9a42 100644
> --- a/kernel/events/core.c
> +++ b/kernel/events/core.c
> @@ -3704,6 +3704,29 @@ static int perf_release(struct inode *inode, struct file *file)
> return 0;
> }
>
> +static u64 perf_event_compute(struct perf_event *event, u64 *enabled,
> + u64 *running)
This is a horrible name, 'compute' what?
> +{
> + struct perf_event *child;
> + u64 total;
> +
> + total = perf_event_count(event);
> +
> + *enabled += event->total_time_enabled +
> + atomic64_read(&event->child_total_time_enabled);
> + *running += event->total_time_running +
> + atomic64_read(&event->child_total_time_running);
> +
lockdep_assert_held(&event->child_mutex);
> + list_for_each_entry(child, &event->child_list, child_list) {
> + perf_event_read(child);
> + total += perf_event_count(child);
> + *enabled += child->total_time_enabled;
> + *running += child->total_time_running;
> + }
> +
> + return total;
> +}
> +
> /*
> * Remove all orphanes events from the context.
> */
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v3 0/8] Implement group-read of events using txn interface Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com> - 2015-07-15 05:10 +0200
[PATCH v3 4/8] perf: Split perf_event_read() and perf_event_count() Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com> - 2015-07-15 05:10 +0200
[PATCH v3 7/8] perf: Define PMU_TXN_READ interface Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com> - 2015-07-15 05:10 +0200
Re: [PATCH v3 7/8] perf: Define PMU_TXN_READ interface Peter Zijlstra <peterz@infradead.org> - 2015-07-17 00:30 +0200
Re: [PATCH v3 7/8] perf: Define PMU_TXN_READ interface Peter Zijlstra <peterz@infradead.org> - 2015-07-22 08:00 +0200
[PATCH v3 3/8] perf: Add a flags parameter to pmu txn interfaces Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com> - 2015-07-15 05:10 +0200
Re: [PATCH v3 3/8] perf: Add a flags parameter to pmu txn interfaces Peter Zijlstra <peterz@infradead.org> - 2015-07-16 22:20 +0200
Re: [PATCH v3 3/8] perf: Add a flags parameter to pmu txn interfaces Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com> - 2015-07-16 23:30 +0200
Re: [PATCH v3 3/8] perf: Add a flags parameter to pmu txn interfaces Peter Zijlstra <peterz@infradead.org> - 2015-07-16 22:50 +0200
[PATCH v3 5/8] perf: Split perf_event_read_value() Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com> - 2015-07-15 05:10 +0200
Re: [PATCH v3 5/8] perf: Split perf_event_read_value() Peter Zijlstra <peterz@infradead.org> - 2015-07-16 23:20 +0200
Re: [PATCH v3 5/8] perf: Split perf_event_read_value() Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com> - 2015-07-16 23:50 +0200
[PATCH v3 1/8] powerpc/perf/hv-24x7: Whitespace - fix parameter alignment Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com> - 2015-07-15 05:10 +0200
[PATCH v3 2/8] powerpc/perf/hv-24x7: Simplify extracting counter from result buffer Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com> - 2015-07-15 05:10 +0200
csiph-web