Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1176890

[RFC PATCH 2/3] arm: psci: enable PSCI on UP systems

From Jisheng Zhang <jszhang@marvell.com>
Newsgroups linux.kernel
Subject [RFC PATCH 2/3] arm: psci: enable PSCI on UP systems
Date 2015-07-05 10:50 +0200
Message-ID <pINMD-Ad-43@gated-at.bofh.it> (permalink)
References <pINCW-wQ-13@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


This is to make calls like eg cpu_suspend can be made functional on UP too.

Signed-off-by: Jisheng Zhang <jszhang@marvell.com>
---
 arch/arm/kernel/Makefile | 5 +----
 arch/arm/kernel/psci.c   | 2 ++
 2 files changed, 3 insertions(+), 4 deletions(-)

diff --git a/arch/arm/kernel/Makefile b/arch/arm/kernel/Makefile
index c57b2c0..2b1a60c 100644
--- a/arch/arm/kernel/Makefile
+++ b/arch/arm/kernel/Makefile
@@ -88,9 +88,6 @@ obj-$(CONFIG_DEBUG_LL)	+= debug.o
 obj-$(CONFIG_EARLY_PRINTK)	+= early_printk.o
 
 obj-$(CONFIG_ARM_VIRT_EXT)	+= hyp-stub.o
-ifeq ($(CONFIG_ARM_PSCI),y)
-obj-y				+= psci-call.o
-obj-$(CONFIG_SMP)		+= psci.o
-endif
+obj-$(CONFIG_ARM_PSCI)		+= psci-call.o psci.o
 
 extra-y := $(head-y) vmlinux.lds
diff --git a/arch/arm/kernel/psci.c b/arch/arm/kernel/psci.c
index 61c04b0..7f6ff02 100644
--- a/arch/arm/kernel/psci.c
+++ b/arch/arm/kernel/psci.c
@@ -47,6 +47,7 @@
  *
  */
 
+#ifdef CONFIG_SMP
 extern void secondary_startup(void);
 
 static int psci_boot_secondary(unsigned int cpu, struct task_struct *idle)
@@ -128,3 +129,4 @@ struct smp_operations __initdata psci_smp_ops = {
 	.cpu_kill		= psci_cpu_kill,
 #endif
 };
+#endif
-- 
2.1.4

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

[RFC PATCH 0/3] arm: psci: implement cpuidle_ops Jisheng Zhang <jszhang@marvell.com> - 2015-07-05 10:40 +0200
  [RFC PATCH 1/3] arm: psci: rename psci_smp.c to psci.c Jisheng Zhang <jszhang@marvell.com> - 2015-07-05 10:50 +0200
  [RFC PATCH 3/3] arm: psci: add cpuidle_ops support Jisheng Zhang <jszhang@marvell.com> - 2015-07-05 10:50 +0200
  [RFC PATCH 2/3] arm: psci: enable PSCI on UP systems Jisheng Zhang <jszhang@marvell.com> - 2015-07-05 10:50 +0200

csiph-web