Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1170255

[PATCH 24/27] perf stat: Rename print_interval to process_interval

From Jiri Olsa <jolsa@kernel.org>
Newsgroups linux.kernel
Subject [PATCH 24/27] perf stat: Rename print_interval to process_interval
Date 2015-06-23 00:50 +0200
Message-ID <pEiHn-MJ-5@gated-at.bofh.it> (permalink)
References <pEixI-Bm-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


It suits better, because the function also reads counter's data.

Also the 'print_interval' name will be used in following
generalization of counters display.

Link: http://lkml.kernel.org/n/tip-8dwmf838kipxabe0vay8h0zn@git.kernel.org
Signed-off-by: Jiri Olsa <jolsa@kernel.org>
---
 tools/perf/builtin-stat.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/tools/perf/builtin-stat.c b/tools/perf/builtin-stat.c
index 526f67753664..aa706fca410e 100644
--- a/tools/perf/builtin-stat.c
+++ b/tools/perf/builtin-stat.c
@@ -363,7 +363,7 @@ static void read_counters(bool close)
 	}
 }
 
-static void print_interval(void)
+static void process_interval(void)
 {
 	static int num_print_interval;
 	struct perf_evsel *counter;
@@ -526,7 +526,7 @@ static int __run_perf_stat(int argc, const char **argv)
 		if (interval) {
 			while (!waitpid(child_pid, &status, WNOHANG)) {
 				nanosleep(&ts, NULL);
-				print_interval();
+				process_interval();
 			}
 		}
 		wait(&status);
@@ -544,7 +544,7 @@ static int __run_perf_stat(int argc, const char **argv)
 		while (!done) {
 			nanosleep(&ts, NULL);
 			if (interval)
-				print_interval();
+				process_interval();
 		}
 	}
 
-- 
1.9.3

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCHv4 00/27] perf stat: Introduce --per-thread option Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:40 +0200
  [PATCH 14/27] perf stat: Move perf_evsel__(alloc|free|reset)_stat_priv into stat object Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:40 +0200
  [PATCH 17/27] perf stat: Introduce perf_evsel__alloc_stats function Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:40 +0200
  [PATCH 07/27] perf tools: Make perf_evsel__(nr_)cpus generic Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:40 +0200
  [PATCH 04/27] perf tools: Add reference counting for thread_map object Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:40 +0200
  [PATCH 25/27] perf stat: Using init_stats instead of memset Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:40 +0200
  [PATCH 23/27] perf stat: Remove perf_evsel__read_cb function Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:40 +0200
  [PATCH 18/27] perf stat: Introduce perf_evsel__read function Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:40 +0200
  [PATCH 15/27] perf stat: Move perf_evsel__(alloc|free)_prev_raw_counts into stat object Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:40 +0200
  [PATCH 02/27] perf tools: Add comm string into struct thread_map Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:40 +0200
  [PATCH 21/27] perf stat: Move zero_per_pkg into counter process code Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:40 +0200
  [PATCH 27/27] perf stat: Introduce --per-thread option Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:40 +0200
  [PATCH 11/27] perf stat: Make stats work over the thread dimension Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:40 +0200
  [PATCH 13/27] perf stat: Introduce perf_evlist__reset_stats Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:40 +0200
  [PATCH 06/27] perf tools: Propagate thread maps through the evlist Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:40 +0200
  [PATCH 05/27] perf tools: Propagate cpu maps through the evlist Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:40 +0200
  [PATCH 20/27] perf stat: Separate counters reading and processing Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:50 +0200
  [PATCH 24/27] perf stat: Rename print_interval to process_interval Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:50 +0200
  [PATCH 22/27] perf stat: Move perf_stat initialization counter process code Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:50 +0200
  [PATCH 19/27] perf stat: Introduce read_counters function Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:50 +0200
  [PATCH 08/27] perf tests: Add thread_map object tests Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:50 +0200
  [PATCH 26/27] perf stat: Introduce print_counters function Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:50 +0200
  [PATCH 09/27] perf stat: Introduce perf_counts function Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:50 +0200
  [PATCH 10/27] perf stat: Use xyarray for cpu evsel counts Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:50 +0200
  [PATCH 16/27] perf stat: Move perf_evlist__(alloc|free|reset)_stats into stat object Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:50 +0200
  [PATCH 12/27] perf stat: Rename struct perf_counts::cpu member to values Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:50 +0200
  [PATCH 03/27] perf tools: Add reference counting for cpu_map object Jiri Olsa <jolsa@kernel.org> - 2015-06-23 00:50 +0200
  Re: [PATCHv4 00/27] perf stat: Introduce --per-thread option Arnaldo Carvalho de Melo <acme@kernel.org> - 2015-06-23 01:10 +0200

csiph-web