Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.user > #267974

systemd-resolved resolving fails sometimes on Debian12

From Victor Sudakov <vas@sibptus.ru>
Newsgroups linux.debian.user
Subject systemd-resolved resolving fails sometimes on Debian12
Date 2024-03-01 11:30 +0100
Message-ID <Id8jn-dFmJ-1@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


[Multipart message — attachments visible in raw view] - view raw

Dear Colleagues,

Has anybody encountered this problem using systemd-resolved as a
resolver on Debian12? A DNS request via systemd-resolved fails, but
fails only occasionally. A failure can happen once per a hundred
successful requests or so. If I run:

while resolvectl query myredis.my.domain ; do sleep 1; done

This will eventually happen:

-- Information acquired via protocol DNS in 960us.
-- Data is authenticated: no; Data was acquired via local or encrypted transport: no
-- Data from: cache network
myredis.my.domain: x.x.44.189                -- link: ens5
                  (redis-cache2-002.tqma2d.0001.usw2.cache.amazonaws.com)

-- Information acquired via protocol DNS in 1.1ms.
-- Data is authenticated: no; Data was acquired via local or encrypted transport: no
-- Data from: cache network
myredis.my.domain: x.x.44.189                -- link: ens5
                  (redis-cache2-002.tqma2d.0001.usw2.cache.amazonaws.com)

-- Information acquired via protocol DNS in 2.2ms.
-- Data is authenticated: no; Data was acquired via local or encrypted transport: no
-- Data from: network
myredis.my.domain: resolve call failed: Lookup failed due to system error: Invalid argument

Then it works again for a hundred or so queries. Query monitoring
shows that systemd-resolved occasionally returns "EINVAL", but mostly
"success".

Any ideas please? It is very unpleasant because the AWS Debian AMI has
systemd-resolved as the default caching resolver and it will take some
effort to eradicate it and replace with unbound or something else.

I don't blame the parent DNS server (from AWS) because if I query it
directly, it always answers.

-- 
Victor Sudakov VAS4-RIPE
http://vas.tomsk.ru/
2:5005/49@fidonet

Back to linux.debian.user | Previous | Next — Next in thread | Find similar | Unroll thread


Thread

systemd-resolved resolving fails sometimes on Debian12 Victor Sudakov <vas@sibptus.ru> - 2024-03-01 11:30 +0100
  Re: systemd-resolved resolving fails sometimes on Debian12 jeremy ardley <jeremy.ardley@gmail.com> - 2024-03-01 21:20 +0100
    Re: systemd-resolved resolving fails sometimes on Debian12 Victor Sudakov <vas@sibptus.ru> - 2024-03-02 16:30 +0100
      Re: systemd-resolved resolving fails sometimes on Debian12 jeremy ardley <jeremy.ardley@gmail.com> - 2024-03-03 01:30 +0100
        Re: systemd-resolved resolving fails sometimes on Debian12 Victor Sudakov <vas@sibptus.ru> - 2024-03-03 06:10 +0100
          Re: systemd-resolved resolving fails sometimes on Debian12 jeremy ardley <jeremy.ardley@gmail.com> - 2024-03-03 10:30 +0100
            Re: systemd-resolved resolving fails sometimes on Debian12 Victor Sudakov <vas@sibptus.ru> - 2024-03-03 16:00 +0100
              Re: systemd-resolved resolving fails sometimes on Debian12 jeremy ardley <jeremy.ardley@gmail.com> - 2024-03-04 07:30 +0100
                Re: systemd-resolved resolving fails sometimes on Debian12 Noah Meyerhans <noahm@debian.org> - 2024-05-21 21:40 +0200
      Re: systemd-resolved resolving fails sometimes on Debian12 Marco Moock <mm@dorfdsl.de> - 2024-03-04 08:40 +0100

csiph-web