Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.user > #265983
| From | David Christensen <dpchrist@holgerdanske.com> |
|---|---|
| Newsgroups | linux.debian.user |
| Subject | Re: new thread, are gigastone ssd's good/bad |
| Date | 2024-01-15 09:40 +0100 |
| Message-ID | <HWqFH-3dos-3@gated-at.bofh.it> (permalink) |
| References | <HWgwF-379q-25@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 1/14/24 13:47, gene heskett wrote:
> Regardless of the sata port/card this 5th SSD is plugged into, it
> appears to me that rsync is overpowering the SSD's write bandwidth and
> somewhere between 13.5Gb of data to around 45Gb of data copied, I wind
> up with a machine that begins to stutter a bit, and finally htop says
> rsync is down to zero cpu, and maybe one more file locks everything but
> the mouse up, it still moves but the clock and the rest of the machine
> has stopped. This may take 5 minutes, maybe 15 but its the same story 5
> times now. by the time I've rebooted, smartctl give the SSD a clean bill
> of health. or did til this last try, now it says, for that drive:
>
> ene@coyote:~/src/klipper-docs$ sudo smartctl -a /dev/sde
> [sudo] password for gene:
> smartctl 7.3 2022-02-28 r5338 [x86_64-linux-6.1.0-17-rt-amd64] (local
> build)
> ,,,
> SMART Attributes Data Structure revision number: 1
> Vendor Specific SMART Attributes with Thresholds:
> ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED
> WHEN_FAILED RAW_VALUE
> 1 Raw_Read_Error_Rate 0x0032 100 100 050 Old_age
> Always - 0
> 5 Reallocated_Sector_Ct 0x0032 100 100 050 Old_age
> Always - 0
> 9 Power_On_Hours 0x0032 100 100 050 Old_age
> Always - 912
> 12 Power_Cycle_Count 0x0032 100 100 050 Old_age
> Always - 7
> 160 Unknown_Attribute 0x0032 100 100 050 Old_age Always
> - 0
> 161 Unknown_Attribute 0x0033 100 100 050 Pre-fail Always
> - 100
> 163 Unknown_Attribute 0x0032 100 100 050 Old_age Always
> - 10
> 164 Unknown_Attribute 0x0032 100 100 050 Old_age Always
> - 231
> 165 Unknown_Attribute 0x0032 100 100 050 Old_age Always
> - 2
> 166 Unknown_Attribute 0x0032 100 100 050 Old_age Always
> - 0
> 167 Unknown_Attribute 0x0032 100 100 050 Old_age Always
> - 0
> 168 Unknown_Attribute 0x0032 100 100 050 Old_age Always
> - 1500
> 169 Unknown_Attribute 0x0032 100 100 050 Old_age Always
> - 100
> 175 Program_Fail_Count_Chip 0x0032 100 100 050 Old_age Always
> - 0
> 176 Erase_Fail_Count_Chip 0x0032 100 100 050 Old_age Always
> - 0
> 177 Wear_Leveling_Count 0x0032 100 100 050 Old_age Always
> - 0
> 178 Used_Rsvd_Blk_Cnt_Chip 0x0032 100 100 050 Old_age Always
> - 0
> 181 Program_Fail_Cnt_Total 0x0032 100 100 050 Old_age Always
> - 0
> 182 Erase_Fail_Count_Total 0x0032 100 100 050 Old_age Always
> - 0
> 192 Power-Off_Retract_Count 0x0032 100 100 050 Old_age Always
> - 6
> 194 Temperature_Celsius 0x0022 100 100 050 Old_age Always
> - 40
> 195 Hardware_ECC_Recovered 0x0032 100 100 050 Old_age Always
> - 0
> 196 Reallocated_Event_Count 0x0032 100 100 050 Old_age Always
> - 0
> 197 Current_Pending_Sector 0x0032 100 100 050 Old_age Always
> - 0
> 198 Offline_Uncorrectable 0x0032 100 100 050 Old_age Always
> - 0
> 199 UDMA_CRC_Error_Count 0x0032 100 100 050 Old_age Always
> - 2
> 232 Available_Reservd_Space 0x0032 100 100 050 Old_age Always
> - 100
> 241 Total_LBAs_Written 0x0030 100 100 050 Old_age
> Offline - 5318
> 242 Total_LBAs_Read 0x0030 100 100 050 Old_age
> Offline - 87
> 245 Unknown_Attribute 0x0032 100 100 050 Old_age Always
> - 0
I believe smartctl(8) requests SMART data with binary commands, receives
binary replies, and must decode those replies based upon details from
the manufacturer. I expect that there are time delays between
smartctl(8) supporting a given drive and when that version of
smartctl(8) makes it into Debian stable.
Power_On_Hours raw value is 912. You have stated that this is a
relatively new drive. "Old_age" and "Pre-fail' do not make sense. I
would ignore them.
Another clue is the multiple "Unknown_Attribute" rows. This tells me
that your smartctl(8) does not fully support that Gigastone drive.
The drive is relatively new, so VALUE=100 and WORST=100 for all
attributes makes sense.
> SMART Error Log Version: 1
> ATA Error Count: 2
Note that "ATA Error Count"=2 matches "UDMA_CRC_Error_Count"=2 above.
That indicates communications problems between the drive and the
motherboard or HBA.
Please look for ATA error messages in dmesg and post anything related:
# dmesg | grep -i error
The most likely cause is the SATA cable. I would install a brand new
SATA III 6 Gbps cable with locking connectors.
> Error -2 occurred at disk power-on lifetime: 0 hours (0 days + 0 hours)
More clues that smartctl(8) does not fully support that drive.
> SMART Self-test log structure revision number 1
> Num Test_Description Status Remaining
> LifeTime(hours) LBA_of_first_error
> # 1 Extended offline Completed without error 00% 901 -
The SMART long self-test completed without error, so the drive inards
are good.
> Is there a way to throttle rsync to the write bandwidth of these SSD's?
Yes:
2024-01-15 00:17:44 dpchrist@laalaa ~/paul-christensen/g6950v
$ man rsync | grep bwlimit
--bwlimit=RATE limit socket I/O bandwidth
--bwlimit=RATE limit socket I/O bandwidth
--bwlimit=RATE
"--bwlimit=1.5m"). If no suffix is specified, the value
will be
--bwlimit=RATE
specify a smaller --bwlimit value, but no larger value
will be
But, that will not fix SATA hardware problems.
> Or do I have a pile of duff SSD's?
I doubt it.
David
Back to linux.debian.user | Previous | Next — Previous in thread | Find similar | Unroll thread
new thread, are gigastone ssd's good/bad gene heskett <gheskett@shentel.net> - 2024-01-14 22:50 +0100 Re: new thread, are gigastone ssd's good/bad David Christensen <dpchrist@holgerdanske.com> - 2024-01-15 09:40 +0100
csiph-web