Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.bugs.dist > #1178150
| From | Helmut Grohne <helmut@subdivi.de> |
|---|---|
| Newsgroups | linux.debian.bugs.dist |
| Subject | Bug#1057359: qmake: use qmake6 when QT_SELECT=qt6 |
| Date | 2023-12-11 16:40 +0100 |
| Message-ID | <HJQxX-cREm-3@gated-at.bofh.it> (permalink) |
| References | <HH3L3-aT5N-7@gated-at.bofh.it> <HH3L3-aT5N-7@gated-at.bofh.it> <HHe3M-b2X4-7@gated-at.bofh.it> <HH3L3-aT5N-7@gated-at.bofh.it> <HHe3M-b2X4-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
[Multipart message — attachments visible in raw view] - view raw
Hi, On Mon, Dec 04, 2023 at 10:58:44AM +0100, Salvo Tomaselli wrote: > I use this in my rules when using qt6 > > > %: > dh $@ > > override_dh_auto_configure: > ln -s /usr/bin/qmake6 ./qmake > PATH=`pwd`:$(PATH) dh_auto_configure > > override_dh_auto_clean: > $(RM) qmake > dh_auto_clean This is also being used in src:explosive-c4 now and the approach breaks cross compilation. Please stop doing this, we'll have to touch all of these. Still the use case is real and we need a better way to build packages with qmake6. I was talking with Sune and Lisandro on IRC and their consensus seems to have been that qtchooser and QT_SELECT are dead and should not be used for Qt6. They suggested that we add add a new --buildsystem to debhelper. We already have qmake_qt4 and qmake, why not have qmake6? While changing QT_SELECT from qt5 to qt6 would be convenient, changing it to "dh $@ --buildsystem qmake6" is easy enough, no? The qmake6 build system can reuse qmake just like qmake_qt4 and doing it that way immediately makes cross compilation just work (since we already have <triplet>-qmake6). Lisandro requested naming it qmake6 rather than qmake_qt6. Even though this breaks consistency with earlier use in debhelper, the similarity to how upstream calls it more important. Salvo and Alexandre, do you second this? Can I also get some ack from Qt maintainers such that we can move forward in consensus? Helmut
Back to linux.debian.bugs.dist | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Bug#1057359: qmake: use qmake6 when QT_SELECT=qt6 Alexandre Detiste <alexandre.detiste@gmail.com> - 2023-12-04 00:10 +0100
Bug#1057359: qmake: use qmake6 when QT_SELECT=qt6 Salvo Tomaselli <tiposchi@tiscali.it> - 2023-12-04 11:10 +0100
Bug#1057359: qmake: use qmake6 when QT_SELECT=qt6 Alexandre Detiste <alexandre.detiste@gmail.com> - 2023-12-07 12:40 +0100
Bug#1057359: qmake: use qmake6 when QT_SELECT=qt6 Helmut Grohne <helmut@subdivi.de> - 2023-12-11 16:40 +0100
Bug#1057359: qmake: use qmake6 when QT_SELECT=qt6 Lisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com> - 2023-12-11 17:30 +0100
Bug#1057359: qmake: use qmake6 when QT_SELECT=qt6 Lisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com> - 2023-12-11 17:30 +0100
Bug#1057359: qmake: use qmake6 when QT_SELECT=qt6 Sune Stolborg Vuorela <sune@debian.org> - 2023-12-11 18:20 +0100
Bug#1057359: qmake: use qmake6 when QT_SELECT=qt6 Alexandre Detiste <alexandre.detiste@gmail.com> - 2023-12-12 10:00 +0100
Bug#1057359: qmake: use qmake6 when QT_SELECT=qt6 Salvo Tomaselli <tiposchi@tiscali.it> - 2023-12-13 19:10 +0100
Bug#1057359: qmake: use qmake6 when QT_SELECT=qt6 Lisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com> - 2023-12-16 15:50 +0100
Bug#1057359: qmake: use qmake6 when QT_SELECT=qt6 Alexandre Detiste <alexandre.detiste@gmail.com> - 2023-12-17 23:30 +0100
Bug#1057359: qmake: use qmake6 when QT_SELECT=qt6 Patrick Franz <deltaone@debian.org> - 2023-12-13 19:40 +0100
csiph-web