Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.bugs.dist > #1138681
| From | Christopher Jones <chris@brasskipper.org.uk> |
|---|---|
| Newsgroups | linux.debian.bugs.dist |
| Subject | Bug#1031701: python3-pandas: Pandas requires version '2.0.1' or newer of 'xlrd' |
| Date | 2023-02-20 23:00 +0100 |
| Message-ID | <G1mmt-7koa-5@gated-at.bofh.it> (permalink) |
| References | <G1lA5-7k7W-7@gated-at.bofh.it> <G1mmt-7koa-1@gated-at.bofh.it> <G1lA5-7k7W-7@gated-at.bofh.it> <G1mmt-7koa-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi, Sadly they really are .xls files rather than the more slightly more sane .xlsx. Thanks! — Chris > On 20 Feb 2023, at 22:39, Rebecca N. Palmer <rebecca_palmer@zoho.com> wrote: > > Is the file you're trying to open .xlsx or .xls? Do you have python3-openpyxl installed? If .xlsx and no, try installing it. > > (python3-)xlrd 2.0+ can only open .xls files, not .xlsx. Hence, pandas 1.5+ read_excel() always uses (python3-)openpyxl for .xlsx files. python3-pandas already Recommends python3-openpyxl. (This intentionally isn't a hard Depends because pandas can be used on other data formats without it, but the error message probably should point to openpyxl not xlrd.)
Back to linux.debian.bugs.dist | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Bug#1031701: python3-pandas: Pandas requires version '2.0.1' or newer of 'xlrd' Christopher Jones <chris@brasskipper.org.uk> - 2023-02-20 22:10 +0100
Bug#1031701: python3-pandas: Pandas requires version '2.0.1' or newer of 'xlrd' "Rebecca N. Palmer" <rebecca_palmer@zoho.com> - 2023-02-20 23:00 +0100
Bug#1031701: python3-pandas: Pandas requires version '2.0.1' or newer of 'xlrd' Christopher Jones <chris@brasskipper.org.uk> - 2023-02-20 23:00 +0100
Bug#1031701: python3-pandas: Pandas requires version '2.0.1' or newer of 'xlrd' "Rebecca N. Palmer" <rebecca_palmer@zoho.com> - 2023-02-21 09:20 +0100
Bug#1031701: python3-pandas: Pandas requires version '2.0.1' or newer of 'xlrd' "Rebecca N. Palmer" <rebecca_palmer@zoho.com> - 2023-02-27 09:00 +0100
Bug#1031701: fixed in python-xlrd 2.0.1-1 Diane Trout <diane@ghic.org> - 2023-02-21 23:10 +0100
Bug#1031701: pandas can't open xls (not xlsx) files, xlrd too old Diane Trout <diane@ghic.org> - 2023-02-25 00:30 +0100
csiph-web