Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.bugs.dist > #1132568

Bug#1027476: closed by Debian FTP Masters <ftpmaster@ftp-master.debian.org> (reply to Georges Khaznadar <georgesk@debian.org>) (Bug#1027476: fixed in cron 3.0pl1-155)

From Guillem Jover <guillem@debian.org>
Newsgroups linux.debian.bugs.dist
Subject Bug#1027476: closed by Debian FTP Masters <ftpmaster@ftp-master.debian.org> (reply to Georges Khaznadar <georgesk@debian.org>) (Bug#1027476: fixed in cron 3.0pl1-155)
Date 2023-01-10 06:00 +0100
Message-ID <FMeTT-gRWe-3@gated-at.bofh.it> (permalink)
References <FM7Sq-gMkS-19@gated-at.bofh.it> <FJ66u-eOUD-9@gated-at.bofh.it> <FMeTT-gRWe-5@gated-at.bofh.it> <FJ66u-eOUD-9@gated-at.bofh.it> <FMeTT-gRWe-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Control: reopen -1

Hi!

Although I've not tested nor checked the affected code, the fix done
to close this cannot possibly be correct, see below. :)

On Mon, 2023-01-09 at 21:27:06 +0000, Debian Bug Tracking System wrote:
> Date: Sun, 01 Jan 2023 07:12:58 -0500
> From: "Kevin P. Fleming" <kevin@km6g.us>
> To: Debian Bug Tracking System <submit@bugs.debian.org>
> Subject: cron: postrm script fails because expected dpkg-statoverride is
>  not present

> The postrm script in the current version of the cron package assumes the
> presence of a dpkg-statoverride for /usr/bin/crontab, but no such statoverride
> is present on my systems. As a result when I try to 'purge' the cron package
> the process fails.

I think the description might be read incorrectly. The error is not
that the dpkg-statoverride program is missing, as that's not possible
(w/o force) being part of dpkg which is an Essential package. But that
a statoverride entry setup by some package is missing.

> This results in the following output:
> 
> Reading package lists... Done
> Building dependency tree... Done
> The following packages will be REMOVED:
>   cron*
> 0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
> After this operation, 0 B of additional disk space will be used.
> Do you want to continue? [Y/n] y
> perl: warning: Setting locale failed.
> perl: warning: Please check that your locale settings:
>         LANGUAGE = (unset),
>         LC_ALL = (unset),
>         LANG = "en_US.UTF-8"
>     are supported and installed on your system.
> perl: warning: Falling back to the standard locale ("C").
> E: Can not write log (Is /dev/pts mounted?) - posix_openpt (19: No such device)
> (Reading database ... 11054 files and directories currently installed.)
> Purging configuration files for cron (3.0pl1-154) ...
> dpkg-statoverride: warning: no override present

As can be seen here, the tool is executed and it runs, but it warns that
it cannot find the statoverride entry.

> dpkg: error processing package cron (--purge):
>  installed cron package post-removal script subprocess returned error exit
> status 2
> Errors were encountered while processing:
>  cron
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> 
> Editing /var/lib/dpkg/info/cron.postrm to remove the first section resolves the
> issue.

Adding a dependency on dpkg cannot have solved anything here.

Thanks,
Guillem

Back to linux.debian.bugs.dist | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

Bug#1027476: cron: postrm script fails because expected dpkg-statoverride is not present "Kevin P. Fleming" <kevin@km6g.us> - 2023-01-01 14:00 +0100
  Bug#1027476: cron: postrm script fails because expected dpkg-statoverride is not present Jonas Smedegaard <dr@jones.dk> - 2023-01-02 22:10 +0100
  Bug#1027476: closed by Debian FTP Masters <ftpmaster@ftp-master.debian.org> (reply to Georges Khaznadar <georgesk@debian.org>) (Bug#1027476: fixed in cron 3.0pl1-155) Guillem Jover <guillem@debian.org> - 2023-01-10 06:00 +0100

csiph-web