Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.user > #241084
| From | Tim Woodall <debianuser@woodall.me.uk> |
|---|---|
| Newsgroups | linux.debian.user |
| Subject | ip6tables rule being rejected. |
| Date | 2021-10-10 13:10 +0200 |
| Message-ID | <D6ESm-44O-5@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
Hi,
When I try to add the following rule:
# ip6tables -t nat -A POSTROUTING -s 2001::/64 -d ! 2001:1::/64 -j ACCEPT
Bad argument `2001:1::/64'
Try `ip6tables -h' or 'ip6tables --help' for more information.
It is rejected. (Ignore the fact that this rule doesn't make a huge
amount of sense, it's a very cut down instance of the rule that I'm
really trying to add)
Leaving off the exclusion:
# ip6tables -t nat -A POSTROUTING -s 2001::/64 -d 2001:1::/64 -j ACCEPT
#
And there is no problem
The manpage suggests that it should work:
d, --destination [!] address[/mask]
Destination specification. See the description of the -s (source)
flag for a detailed description of the syntax. The flag --dst is an
alias for this option.
Am I doing something daft or should this work?
Back to linux.debian.user | Previous | Next — Next in thread | Find similar | Unroll thread
ip6tables rule being rejected. Tim Woodall <debianuser@woodall.me.uk> - 2021-10-10 13:10 +0200
Re: ip6tables rule being rejected. Markus Schönhaber <debian-user@list-post.mks-mail.de> - 2021-10-10 14:30 +0200
Re: ip6tables rule being rejected. Reco <recoverym4n@enotuniq.net> - 2021-10-10 14:40 +0200
Re: ip6tables rule being rejected. Tim Woodall <debianuser@woodall.me.uk> - 2021-10-10 18:30 +0200
Re: ip6tables rule being rejected. Andrei POPESCU <andreimpopescu@gmail.com> - 2021-10-11 11:00 +0200
csiph-web