Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.bugs.dist > #1019618
| From | Noah Meyerhans <noahm@debian.org> |
|---|---|
| Newsgroups | linux.debian.bugs.dist |
| Subject | Bug#966451: cloud.debian.org: systemd-growfs@-.service fails on arm64 instance types |
| Date | 2020-07-28 18:40 +0200 |
| Message-ID | <AxANX-5dl-3@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
Package: cloud.debian.org
Severity: important
User: cloud.debian.org@packages.debian.org
Usertags: aws image
Testing the current buster releases for [mcr]6gd.* instance type support
reveals an issue that leads the instances to boot to "degraded" state in
systemd. The failing unit is systemd-growfs@-.service:
admin@ip-172-31-13-14:~$ systemctl status systemd-growfs@-.service
● systemd-growfs@-.service - Grow File System on /
Loaded: loaded (/run/systemd/generator/systemd-growfs@-.service; generated)
Active: failed (Result: exit-code) since Tue 2020-07-28 16:14:54 UTC; 1min 2s ago
Docs: man:systemd-growfs@.service(8)
Process: 271 ExecStart=/lib/systemd/systemd-growfs / (code=exited, status=1/FAILURE)
Main PID: 271 (code=exited, status=1/FAILURE)
Jul 28 16:14:54 debian systemd-growfs[271]: Partition size 8455699968 is not a multiple of the blocksize 4096, ignoring 3584 bytes
Jul 28 16:14:54 debian systemd-growfs[271]: Failed to resize "/" to 2064379 blocks (ext4): Read-only file system
Jul 28 16:14:54 debian systemd[1]: systemd-growfs@-.service: Main process exited, code=exited, status=1/FAILURE
Jul 28 16:14:54 debian systemd[1]: systemd-growfs@-.service: Failed with result 'exit-code'.
Jul 28 16:14:54 debian systemd[1]: Failed to start Grow File System on /.
This does not seem limited to the local-NVMe instance types (with the "d" in
the first field), as I have reproduced the issue on c6g.xlarge as well:
admin@ip-172-31-14-76:~$ systemctl status systemd-growfs@-.service
● systemd-growfs@-.service - Grow File System on /
Loaded: loaded (/run/systemd/generator/systemd-growfs@-.service; generated)
Active: failed (Result: exit-code) since Tue 2020-07-28 16:24:22 UTC; 1min 29s ago
Docs: man:systemd-growfs@.service(8)
Process: 256 ExecStart=/lib/systemd/systemd-growfs / (code=exited, status=1/FAILURE)
Main PID: 256 (code=exited, status=1/FAILURE)
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
admin@ip-172-31-14-76:~$ ec2metadata --instance-type
c6g.xlarge
Instances were tested in us-east-1. I don't think this has always occurred
on the 6g arm64 instance types, but it seems to be reproducible
approximately 100% of the time right now.
Back to linux.debian.bugs.dist | Previous | Next — Next in thread | Find similar | Unroll thread
Bug#966451: cloud.debian.org: systemd-growfs@-.service fails on arm64 instance types Noah Meyerhans <noahm@debian.org> - 2020-07-28 18:40 +0200
Bug#966451: cloud.debian.org: systemd-growfs@-.service fails on arm64 instance types Noah Meyerhans <noahm@debian.org> - 2020-07-28 23:30 +0200
Bug#966451: cloud.debian.org: systemd-growfs@-.service fails on arm64 instance types Noah Meyerhans <noahm@debian.org> - 2020-07-29 00:50 +0200
Bug#966451: cloud.debian.org: systemd-growfs@-.service fails on arm64 instance types Bastian Blank <waldi@debian.org> - 2020-07-29 08:20 +0200
Bug#966451: cloud.debian.org: systemd-growfs@-.service fails on arm64 instance types kula@kulisz.net - 2020-07-29 23:40 +0200
Bug#966451: cloud.debian.org: systemd-growfs@-.service fails on arm64 instance types Bastian Blank <waldi@debian.org> - 2020-07-29 08:20 +0200
Bug#966451: cloud.debian.org: systemd-growfs@-.service fails on arm64 instance types Noah Meyerhans <noahm@debian.org> - 2020-07-29 21:50 +0200
Bug#966451: cloud.debian.org: systemd-growfs@-.service fails on arm64 instance types Noah Meyerhans <noahm@debian.org> - 2020-07-31 19:10 +0200
csiph-web