Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > comp.lang.php > #1761
| Message-Id | <1905396.XAFRqVoOGU@PointedEars.de> |
|---|---|
| From | Thomas 'PointedEars' Lahn <PointedEars@web.de> |
| Organization | PointedEars Software (PES) |
| Date | 2011-05-22 12:45 +0200 |
| Subject | Re: problem saving date fields |
| Newsgroups | comp.lang.php |
| References | (3 earlier) <ms9et65fukkeqtr9l5ki4bq4mt11tuj4ce@4ax.com> <ir8idn$ojm$1@dont-email.me> <cgnft65mk7eet92cio9nnguq1b3fs7krbp@4ax.com> <ir9jom$663$1@dont-email.me> <7otgt6963n7tt7ns1of8ug7d5uf0ne641d@4ax.com> |
| Followup-To | comp.lang.php |
Followups directed to: comp.lang.php
Jeff North wrote: [attribution novels trimmed, quotation prefixes fixed, see <http://learn.to/quote>] > Jerry Stuckle wrote: >> On 5/21/2011 12:08 PM, Jeff North wrote: >> > Jerry Stuckle wrote: >> > There is no need to have variables in the code that aren't being used. >> Yes, there is. In fact, it is quite common to have variables in the >> code which are not being use *at this time*. And very good reasons for >> *not* initializing them - as a *programmer* would know. > > Programmers who know more that just PHP know that you are full of > crap. Please name one that is not you in order to substantiate your claim. Further, please explain what this has to do with Jerry's statement. >> >> > The SQL statement should be ok - it's the "When I change of them >> >> > the other one gets set back to default: 00-00-0000" I'm >> >> > considering. >> >> The SQL statement is NOT ok. As he would find if he printed it out >> >> as was suggested. >> > If the SQL statement was not ok then the record wouldn't be updated. >> Or the row (tables have ROWS, not RECORDS) is not being updated with the >> correct data - which is the case here. But then a *programmer* would >> understand that. > > A row, or record, would NOT be updated if the SQL statement is NOT ok He did not debate that. He offered another possibility: the SQL statement being syntactically correct but attempting to write different data than were desired. > - even a moron like you can understand that - oh you do that is why > you chose to answer the question the way you did. So no need for name-calling. >> >> >> BTW - your sig separator is broken. It needs to be exactly >> >> >> hyphen-hyphen-space-newline. > > [snip] > >> >> It has nothing to do with Thunderbird. It has EVERYTHING to do >> >> with following usenet standards, in this case RFC 3736. >> > >> > Please highlight the line(s) from RFC 3736 that can back up your >> > claim. >> > >> >> But I see you're as clueless about rfcs as you are programming. >> > -- ------------------------------------------------- >> > The supplied code is for guideline purposes only. >> >> Typo - the rfc is 3676, > > 3676 and 3736 is NOT a typo You cannot be sure about that. The Free Online Dictionary defines a typo as follows: ,-<http://www.thefreedictionary.com/typo> | | Noun 1. typo - a mistake in printed matter resulting from mechanical | failures of some kind | Synonyms: erratum, literal, literal error, misprint, typographical | error | Related words: mistake, error - part of a statement that is not | correct; "the book was full of errors" | | Based on WordNet 3.0, Farlex clipart collection. © 2003-2008 Princeton | University, Farlex Inc. So it could very well have been a typo, either caused by mechanical keyboard malfunction or mechanical confusion between the fingers of the (quick) typist when using the keyboard. >> which you could find if you knew how to do a simple google search. > > Everyone would know that they needed to search for "The Text/Plain > Format and DelSp Parameters" to get to the relevant information that > you got wrong in the first place - right? It was a valid assumption. If you search on Google for "rfc 3736 usenet signature" you will be presented with a hyperlink to the correct RFC (3676) at the first position, thanks to Google's implicit error correction. >> But that looks to be beyond your capability, also. > > http://www.apps.ietf.org/rfc/rfc3676.html#sec-4.3 > "There is a long-standing convention in Usenet news which also > commonly appears in Internet mail of using "-- " as the separator line > between the body and the signature of a message. When generating a > Format=Flowed message containing a Usenet-style separator before the > signature, the separator line is sent as-is." > > Now where does it state "It needs to be exactly > hyphen-hyphen-space-newline." A separator line needs to be ended with newline (<CR><LF> in Internet messages, see RFC 5322, section 2.1) in order to separate the line that precedes it from the line that follows it. The definition of a separator line includes that no other characters than those stated, in the stated order, can be part of the line for it to be (recognized as) a separator line. (A separator is a thing that separates other things from one another, and a seperator line is a line that is considered a separator.) So > [snip] > -- ----------------------------------------------------------- this is _not_ a signature separator line, and > "Pr0r3p" <pr0r3p@yahoo.com> wrote: > I said I was aiming at your stupidity, not your brain. > > "Johnny" <wxpprofessional@msn.com> writes: > You missed. You can not hit a non-existent thing. this is is not a properly delimited signature according to RFC 3676 (and 1855). It is also not a proper Usenet signature according to RFC 1855, for with five lines it exceeds the recommended length of four lines by one. > -- ----------------------------------------------------------- And this is a rather pointless string of characters because nothing follows that would be separated from the preceding text. PointedEars -- Anyone who slaps a 'this page is best viewed with Browser X' label on a Web page appears to be yearning for the bad old days, before the Web, when you had very little chance of reading a document written on another computer, another word processor, or another network. -- Tim Berners-Lee
Back to comp.lang.php | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
problem saving date fields Co <vonclausowitz@gmail.com> - 2011-05-20 11:38 -0700
Re: problem saving date fields Luuk <Luuk@invalid.lan> - 2011-05-20 20:50 +0200
Re: problem saving date fields Jeff North <jnorthau@yahoo.com.au> - 2011-05-21 08:58 +1000
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-20 22:35 -0400
Re: problem saving date fields Jeff North <jnorthau@yahoo.com.au> - 2011-05-21 13:13 +1000
Re: problem saving date fields Co <vonclausowitz@gmail.com> - 2011-05-20 23:47 -0700
Re: problem saving date fields Co <vonclausowitz@gmail.com> - 2011-05-21 00:18 -0700
Re: problem saving date fields Luuk <Luuk@invalid.lan> - 2011-05-21 09:54 +0200
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-21 10:37 -0400
Re: problem saving date fields Co <vonclausowitz@gmail.com> - 2011-05-21 08:07 -0700
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-21 19:55 -0400
Re: problem saving date fields Co <vonclausowitz@gmail.com> - 2011-05-22 14:20 -0700
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-22 17:28 -0400
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-21 10:32 -0400
Re: problem saving date fields Jeff North <jnorthau@yahoo.com.au> - 2011-05-22 02:08 +1000
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-21 20:01 -0400
Re: problem saving date fields "Twayne" <nobody@devnull.spamcop.net> - 2011-05-21 20:30 -0400
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-21 23:13 -0400
Re: problem saving date fields Jeff North <jnorthau@yahoo.com.au> - 2011-05-22 14:28 +1000
Re: problem saving date fields Thomas 'PointedEars' Lahn <PointedEars@web.de> - 2011-05-22 12:45 +0200
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-22 08:26 -0400
Re: problem saving date fields "Twayne" <nobody@devnull.spamcop.net> - 2011-05-22 09:20 -0400
Re: problem saving date fields Jeff North <jnorthau@yahoo.com.au> - 2011-05-23 00:08 +1000
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-22 13:47 -0400
Re: problem saving date fields Bill B <me@privacy.net> - 2011-05-22 14:17 -0400
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-22 14:26 -0400
Re: problem saving date fields Bill B <me@privacy.net> - 2011-05-22 16:27 -0400
Re: problem saving date fields Jeff North <jnorthau@yahoo.com.au> - 2011-05-23 09:01 +1000
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-22 20:21 -0400
Re: problem saving date fields Bill B <me@privacy.net> - 2011-05-22 21:36 -0400
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-22 21:46 -0400
Re: problem saving date fields Jeff North <jnorthau@yahoo.com.au> - 2011-05-23 12:20 +1000
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-22 22:30 -0400
Re: problem saving date fields Co <vonclausowitz@gmail.com> - 2011-05-22 21:51 -0700
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-23 07:13 -0400
Re: problem saving date fields Co <vonclausowitz@gmail.com> - 2011-05-23 10:18 -0700
Re: problem saving date fields Co <vonclausowitz@gmail.com> - 2011-05-23 10:27 -0700
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-23 14:16 -0400
Re: problem saving date fields Co <vonclausowitz@gmail.com> - 2011-05-23 12:17 -0700
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-23 18:00 -0400
Re: problem saving date fields Co <vonclausowitz@gmail.com> - 2011-05-23 22:30 -0700
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-24 05:45 -0400
Re: problem saving date fields Co <vonclausowitz@gmail.com> - 2011-05-26 02:10 -0700
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-26 05:43 -0400
Re: problem saving date fields Co <vonclausowitz@gmail.com> - 2011-05-23 14:26 -0700
Re: problem saving date fields Jerry Stuckle <jstucklex@attglobal.net> - 2011-05-23 18:01 -0400
Re: problem saving date fields Thomas 'PointedEars' Lahn <PointedEars@web.de> - 2011-05-23 23:59 +0200
Re: problem saving date fields "Twayne" <nobody@devnull.spamcop.net> - 2011-05-22 09:11 -0400
csiph-web