Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1740434 > unrolled thread

Re: [PATCH v3 1/3] iio: accel: mma8452: Rename structs holding event configuration registers to more appropriate names.

Started byMartin Kepplinger <martink@posteo.de>
First post2017-09-27 09:00 +0200
Last post2017-10-02 12:40 +0200
Articles 4 — 3 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH v3 1/3] iio: accel: mma8452: Rename structs holding  event configuration registers to more appropriate names. Martin Kepplinger <martink@posteo.de> - 2017-09-27 09:00 +0200
    Re: [PATCH v3 1/3] iio: accel: mma8452: Rename structs holding  event configuration registers to more appropriate names. Jonathan Cameron <jic23@kernel.org> - 2017-09-30 20:00 +0200
      Re: [PATCH v3 1/3] iio: accel: mma8452: Rename structs holding event  configuration registers to more appropriate names. Martin Kepplinger <martink@posteo.de> - 2017-10-01 20:20 +0200
        Re: [PATCH v3 1/3] iio: accel: mma8452: Rename structs holding  event configuration registers to more appropriate names. Jonathan Cameron <Jonathan.Cameron@huawei.com> - 2017-10-02 12:40 +0200

#1740434 — Re: [PATCH v3 1/3] iio: accel: mma8452: Rename structs holding event configuration registers to more appropriate names.

FromMartin Kepplinger <martink@posteo.de>
Date2017-09-27 09:00 +0200
SubjectRe: [PATCH v3 1/3] iio: accel: mma8452: Rename structs holding event configuration registers to more appropriate names.
Message-ID<uueu6-7gi-1@gated-at.bofh.it>
Am 25.09.2017 12:40 schrieb Harinath Nampally:
> Improves code readability, no impact on functionality.
> 
> Signed-off-by: Harinath Nampally <harinath922@gmail.com>
> ---

I'd prefer a shorter subject line here too, see patch 2/3.

[toc] | [next] | [standalone]


#1742671

FromJonathan Cameron <jic23@kernel.org>
Date2017-09-30 20:00 +0200
Message-ID<uvuds-7k9-17@gated-at.bofh.it>
In reply to#1740434
On Wed, 27 Sep 2017 08:52:54 +0200
Martin Kepplinger <martink@posteo.de> wrote:

> Am 25.09.2017 12:40 schrieb Harinath Nampally:
> > Improves code readability, no impact on functionality.
> > 
> > Signed-off-by: Harinath Nampally <harinath922@gmail.com>
> > ---  
> 
> I'd prefer a shorter subject line here too, see patch 2/3

Agreed.  I'm unconvinced the change helps.  Perhaps that is
because I don't fully understand why you are making the change?

Thanks,

Jonathan

[toc] | [prev] | [next] | [standalone]


#1742856 — Re: [PATCH v3 1/3] iio: accel: mma8452: Rename structs holding event configuration registers to more appropriate names.

FromMartin Kepplinger <martink@posteo.de>
Date2017-10-01 20:20 +0200
SubjectRe: [PATCH v3 1/3] iio: accel: mma8452: Rename structs holding event configuration registers to more appropriate names.
Message-ID<uvR0m-5s3-9@gated-at.bofh.it>
In reply to#1742671
On 2017-09-30 19:59, Jonathan Cameron wrote:
> On Wed, 27 Sep 2017 08:52:54 +0200
> Martin Kepplinger <martink@posteo.de> wrote:
> 
>> Am 25.09.2017 12:40 schrieb Harinath Nampally:
>>> Improves code readability, no impact on functionality.
>>>
>>> Signed-off-by: Harinath Nampally <harinath922@gmail.com>
>>> ---  
>>
>> I'd prefer a shorter subject line here too, see patch 2/3
> 
> Agreed.  I'm unconvinced the change helps.  Perhaps that is
> because I don't fully understand why you are making the change?
> 

It's understandable for me. It simply uses "transient" and "ff_mt" in
order to describe sets of device-registers instead of "rising" and
"falling". That's more appropriate. I'd apply this if possible.

Even though it should be clear after reading the data sheet, this
particular issue sometimes gets confusing for people. Maybe a short
descriptive comment, pointing to the data sheet, would make sense?

                      martin

[toc] | [prev] | [next] | [standalone]


#1743093

FromJonathan Cameron <Jonathan.Cameron@huawei.com>
Date2017-10-02 12:40 +0200
Message-ID<uw6iK-6a9-19@gated-at.bofh.it>
In reply to#1742856
On Sun, 1 Oct 2017 20:10:49 +0200
Martin Kepplinger <martink@posteo.de> wrote:

> On 2017-09-30 19:59, Jonathan Cameron wrote:
> > On Wed, 27 Sep 2017 08:52:54 +0200
> > Martin Kepplinger <martink@posteo.de> wrote:
> >   
> >> Am 25.09.2017 12:40 schrieb Harinath Nampally:  
> >>> Improves code readability, no impact on functionality.
> >>>
> >>> Signed-off-by: Harinath Nampally <harinath922@gmail.com>
> >>> ---    
> >>
> >> I'd prefer a shorter subject line here too, see patch 2/3  
> > 
> > Agreed.  I'm unconvinced the change helps.  Perhaps that is
> > because I don't fully understand why you are making the change?
> >   
> 
> It's understandable for me. It simply uses "transient" and "ff_mt" in
> order to describe sets of device-registers instead of "rising" and
> "falling". That's more appropriate. I'd apply this if possible.
> 
> Even though it should be clear after reading the data sheet, this
> particular issue sometimes gets confusing for people. Maybe a short
> descriptive comment, pointing to the data sheet, would make sense?
> 

With the addition of some description, this should be fine.

Thanks,

Jonathan

>                       martin
> --
> To unsubscribe from this list: send the line "unsubscribe linux-iio" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web