Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1738074 > unrolled thread
| Started by | Harinath Nampally <harinath922@gmail.com> |
|---|---|
| First post | 2017-09-23 23:00 +0200 |
| Last post | 2017-09-24 15:20 +0200 |
| Articles | 3 — 2 participants |
Back to article view | Back to linux.kernel
[PATCH 0/2] This patchset is for fixes reported by checkpatch.pl Harinath Nampally <harinath922@gmail.com> - 2017-09-23 23:00 +0200
[PATCH 2/2] iio: accel: mma8452: Fix code style warning for unsigned int declarations Harinath Nampally <harinath922@gmail.com> - 2017-09-23 23:00 +0200
Re: [PATCH 2/2] iio: accel: mma8452: Fix code style warning for unsigned int declarations Jonathan Cameron <jic23@kernel.org> - 2017-09-24 15:20 +0200
| From | Harinath Nampally <harinath922@gmail.com> |
|---|---|
| Date | 2017-09-23 23:00 +0200 |
| Subject | [PATCH 0/2] This patchset is for fixes reported by checkpatch.pl |
| Message-ID | <usZGN-7Ze-3@gated-at.bofh.it> |
Please find the following patches:
iio: accel: mma8452: Fix code style warning for symbolic permissions
iio: accel: mma8452: Fix code style warning for unsigned int
declarations
drivers/iio/accel/mma8452.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
--
2.7.4
[toc] | [next] | [standalone]
| From | Harinath Nampally <harinath922@gmail.com> |
|---|---|
| Date | 2017-09-23 23:00 +0200 |
| Subject | [PATCH 2/2] iio: accel: mma8452: Fix code style warning for unsigned int declarations |
| Message-ID | <usZGO-7Ze-17@gated-at.bofh.it> |
| In reply to | #1738074 |
Replace 'unsigned' with 'unsigned int'
to improve code readability.
Issue found by checkpatch.
Signed-off-by: Harinath Nampally <harinath922@gmail.com>
---
drivers/iio/accel/mma8452.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/iio/accel/mma8452.c b/drivers/iio/accel/mma8452.c
index 4a33a26..6194169 100644
--- a/drivers/iio/accel/mma8452.c
+++ b/drivers/iio/accel/mma8452.c
@@ -1088,8 +1088,8 @@ static irqreturn_t mma8452_trigger_handler(int irq, void *p)
}
static int mma8452_reg_access_dbg(struct iio_dev *indio_dev,
- unsigned reg, unsigned writeval,
- unsigned *readval)
+ unsigned int reg, unsigned int writeval,
+ unsigned int *readval)
{
int ret;
struct mma8452_data *data = iio_priv(indio_dev);
--
2.7.4
[toc] | [prev] | [next] | [standalone]
| From | Jonathan Cameron <jic23@kernel.org> |
|---|---|
| Date | 2017-09-24 15:20 +0200 |
| Subject | Re: [PATCH 2/2] iio: accel: mma8452: Fix code style warning for unsigned int declarations |
| Message-ID | <uteZc-JV-7@gated-at.bofh.it> |
| In reply to | #1738076 |
On Sat, 23 Sep 2017 16:56:30 -0400
Harinath Nampally <harinath922@gmail.com> wrote:
> Replace 'unsigned' with 'unsigned int'
> to improve code readability.
>
> Issue found by checkpatch.
>
> Signed-off-by: Harinath Nampally <harinath922@gmail.com>
Applied to the togreg branch of iio.git and pushed out as testing for the
autobuilders to play with it.
Thanks,
Jonathan
> ---
> drivers/iio/accel/mma8452.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/iio/accel/mma8452.c b/drivers/iio/accel/mma8452.c
> index 4a33a26..6194169 100644
> --- a/drivers/iio/accel/mma8452.c
> +++ b/drivers/iio/accel/mma8452.c
> @@ -1088,8 +1088,8 @@ static irqreturn_t mma8452_trigger_handler(int irq, void *p)
> }
>
> static int mma8452_reg_access_dbg(struct iio_dev *indio_dev,
> - unsigned reg, unsigned writeval,
> - unsigned *readval)
> + unsigned int reg, unsigned int writeval,
> + unsigned int *readval)
> {
> int ret;
> struct mma8452_data *data = iio_priv(indio_dev);
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web