Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1728329 > unrolled thread
| Started by | Tycho Andersen <tycho@docker.com> |
|---|---|
| First post | 2017-09-07 19:40 +0200 |
| Last post | 2017-09-18 23:00 +0200 |
| Articles | 6 — 4 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
[PATCH v6 10/11] mm: add a user_virt_to_phys symbol Tycho Andersen <tycho@docker.com> - 2017-09-07 19:40 +0200
Re: [PATCH v6 10/11] mm: add a user_virt_to_phys symbol Christoph Hellwig <hch@infradead.org> - 2017-09-08 10:00 +0200
Re: [PATCH v6 10/11] mm: add a user_virt_to_phys symbol Kees Cook <keescook@chromium.org> - 2017-09-08 17:50 +0200
Re: [PATCH v6 10/11] mm: add a user_virt_to_phys symbol Christoph Hellwig <hch@infradead.org> - 2017-09-11 09:40 +0200
Re: [kernel-hardening] [PATCH v6 10/11] mm: add a user_virt_to_phys symbol Mark Rutland <mark.rutland@arm.com> - 2017-09-14 20:40 +0200
Re: [kernel-hardening] [PATCH v6 10/11] mm: add a user_virt_to_phys symbol Tycho Andersen <tycho@docker.com> - 2017-09-18 23:00 +0200
| From | Tycho Andersen <tycho@docker.com> |
|---|---|
| Date | 2017-09-07 19:40 +0200 |
| Subject | [PATCH v6 10/11] mm: add a user_virt_to_phys symbol |
| Message-ID | <un8Wu-3e6-29@gated-at.bofh.it> |
We need someting like this for testing XPFO. Since it's architecture
specific, putting it in the test code is slightly awkward, so let's make it
an arch-specific symbol and export it for use in LKDTM.
v6: * add a definition of user_virt_to_phys in the !CONFIG_XPFO case
CC: linux-arm-kernel@lists.infradead.org
CC: x86@kernel.org
Signed-off-by: Tycho Andersen <tycho@docker.com>
Tested-by: Marco Benatto <marco.antonio.780@gmail.com>
---
arch/arm64/mm/xpfo.c | 51 ++++++++++++++++++++++++++++++++++++++++++++++
arch/x86/mm/xpfo.c | 57 ++++++++++++++++++++++++++++++++++++++++++++++++++++
include/linux/xpfo.h | 5 +++++
3 files changed, 113 insertions(+)
diff --git a/arch/arm64/mm/xpfo.c b/arch/arm64/mm/xpfo.c
index 342a9ccb93c1..94a667d94e15 100644
--- a/arch/arm64/mm/xpfo.c
+++ b/arch/arm64/mm/xpfo.c
@@ -74,3 +74,54 @@ void xpfo_dma_map_unmap_area(bool map, const void *addr, size_t size,
xpfo_temp_unmap(addr, size, mapping, sizeof(mapping[0]) * num_pages);
}
+
+/* Convert a user space virtual address to a physical address.
+ * Shamelessly copied from slow_virt_to_phys() and lookup_address() in
+ * arch/x86/mm/pageattr.c
+ */
+phys_addr_t user_virt_to_phys(unsigned long addr)
+{
+ phys_addr_t phys_addr;
+ unsigned long offset;
+ pgd_t *pgd;
+ p4d_t *p4d;
+ pud_t *pud;
+ pmd_t *pmd;
+ pte_t *pte;
+
+ pgd = pgd_offset(current->mm, addr);
+ if (pgd_none(*pgd))
+ return 0;
+
+ p4d = p4d_offset(pgd, addr);
+ if (p4d_none(*p4d))
+ return 0;
+
+ pud = pud_offset(p4d, addr);
+ if (pud_none(*pud))
+ return 0;
+
+ if (pud_sect(*pud) || !pud_present(*pud)) {
+ phys_addr = (unsigned long)pud_pfn(*pud) << PAGE_SHIFT;
+ offset = addr & ~PUD_MASK;
+ goto out;
+ }
+
+ pmd = pmd_offset(pud, addr);
+ if (pmd_none(*pmd))
+ return 0;
+
+ if (pmd_sect(*pmd) || !pmd_present(*pmd)) {
+ phys_addr = (unsigned long)pmd_pfn(*pmd) << PAGE_SHIFT;
+ offset = addr & ~PMD_MASK;
+ goto out;
+ }
+
+ pte = pte_offset_kernel(pmd, addr);
+ phys_addr = (phys_addr_t)pte_pfn(*pte) << PAGE_SHIFT;
+ offset = addr & ~PAGE_MASK;
+
+out:
+ return (phys_addr_t)(phys_addr | offset);
+}
+EXPORT_SYMBOL(user_virt_to_phys);
diff --git a/arch/x86/mm/xpfo.c b/arch/x86/mm/xpfo.c
index 6794d6724ab5..d24cf2c600e8 100644
--- a/arch/x86/mm/xpfo.c
+++ b/arch/x86/mm/xpfo.c
@@ -112,3 +112,60 @@ inline void xpfo_flush_kernel_tlb(struct page *page, int order)
flush_tlb_kernel_range(kaddr, kaddr + (1 << order) * size);
}
+
+/* Convert a user space virtual address to a physical address.
+ * Shamelessly copied from slow_virt_to_phys() and lookup_address() in
+ * arch/x86/mm/pageattr.c
+ */
+phys_addr_t user_virt_to_phys(unsigned long addr)
+{
+ phys_addr_t phys_addr;
+ unsigned long offset;
+ pgd_t *pgd;
+ p4d_t *p4d;
+ pud_t *pud;
+ pmd_t *pmd;
+ pte_t *pte;
+
+ pgd = pgd_offset(current->mm, addr);
+ if (pgd_none(*pgd))
+ return 0;
+
+ p4d = p4d_offset(pgd, addr);
+ if (p4d_none(*p4d))
+ return 0;
+
+ if (p4d_large(*p4d) || !p4d_present(*p4d)) {
+ phys_addr = (unsigned long)p4d_pfn(*p4d) << PAGE_SHIFT;
+ offset = addr & ~P4D_MASK;
+ goto out;
+ }
+
+ pud = pud_offset(p4d, addr);
+ if (pud_none(*pud))
+ return 0;
+
+ if (pud_large(*pud) || !pud_present(*pud)) {
+ phys_addr = (unsigned long)pud_pfn(*pud) << PAGE_SHIFT;
+ offset = addr & ~PUD_MASK;
+ goto out;
+ }
+
+ pmd = pmd_offset(pud, addr);
+ if (pmd_none(*pmd))
+ return 0;
+
+ if (pmd_large(*pmd) || !pmd_present(*pmd)) {
+ phys_addr = (unsigned long)pmd_pfn(*pmd) << PAGE_SHIFT;
+ offset = addr & ~PMD_MASK;
+ goto out;
+ }
+
+ pte = pte_offset_kernel(pmd, addr);
+ phys_addr = (phys_addr_t)pte_pfn(*pte) << PAGE_SHIFT;
+ offset = addr & ~PAGE_MASK;
+
+out:
+ return (phys_addr_t)(phys_addr | offset);
+}
+EXPORT_SYMBOL(user_virt_to_phys);
diff --git a/include/linux/xpfo.h b/include/linux/xpfo.h
index 1693af1a0293..be72da5fba26 100644
--- a/include/linux/xpfo.h
+++ b/include/linux/xpfo.h
@@ -19,6 +19,7 @@
#ifdef CONFIG_XPFO
#include <linux/dma-mapping.h>
+#include <linux/types.h>
extern struct page_ext_operations page_xpfo_ops;
@@ -45,6 +46,8 @@ void xpfo_temp_unmap(const void *addr, size_t size, void **mapping,
bool xpfo_enabled(void);
+phys_addr_t user_virt_to_phys(unsigned long addr);
+
#else /* !CONFIG_XPFO */
static inline void xpfo_kmap(void *kaddr, struct page *page) { }
@@ -69,6 +72,8 @@ static inline void xpfo_temp_unmap(const void *addr, size_t size,
static inline bool xpfo_enabled(void) { return false; }
+static inline phys_addr_t user_virt_to_phys(unsigned long addr) { return 0; }
+
#endif /* CONFIG_XPFO */
#endif /* _LINUX_XPFO_H */
--
2.11.0
[toc] | [next] | [standalone]
| From | Christoph Hellwig <hch@infradead.org> |
|---|---|
| Date | 2017-09-08 10:00 +0200 |
| Message-ID | <unmmJ-3PQ-7@gated-at.bofh.it> |
| In reply to | #1728329 |
On Thu, Sep 07, 2017 at 11:36:08AM -0600, Tycho Andersen wrote: > We need someting like this for testing XPFO. Since it's architecture > specific, putting it in the test code is slightly awkward, so let's make it > an arch-specific symbol and export it for use in LKDTM. We really should not add an export for this. I think you'll want to just open code it in your test module.
[toc] | [prev] | [next] | [standalone]
| From | Kees Cook <keescook@chromium.org> |
|---|---|
| Date | 2017-09-08 17:50 +0200 |
| Message-ID | <untHA-xc-21@gated-at.bofh.it> |
| In reply to | #1728667 |
On Fri, Sep 8, 2017 at 12:55 AM, Christoph Hellwig <hch@infradead.org> wrote: > On Thu, Sep 07, 2017 at 11:36:08AM -0600, Tycho Andersen wrote: >> We need someting like this for testing XPFO. Since it's architecture >> specific, putting it in the test code is slightly awkward, so let's make it >> an arch-specific symbol and export it for use in LKDTM. > > We really should not add an export for this. > > I think you'll want to just open code it in your test module. Isn't that going to be fragile? Why not an export? -Kees -- Kees Cook Pixel Security
[toc] | [prev] | [next] | [standalone]
| From | Christoph Hellwig <hch@infradead.org> |
|---|---|
| Date | 2017-09-11 09:40 +0200 |
| Message-ID | <uoru2-8bR-15@gated-at.bofh.it> |
| In reply to | #1729043 |
On Fri, Sep 08, 2017 at 08:44:22AM -0700, Kees Cook wrote: > On Fri, Sep 8, 2017 at 12:55 AM, Christoph Hellwig <hch@infradead.org> wrote: > > On Thu, Sep 07, 2017 at 11:36:08AM -0600, Tycho Andersen wrote: > >> We need someting like this for testing XPFO. Since it's architecture > >> specific, putting it in the test code is slightly awkward, so let's make it > >> an arch-specific symbol and export it for use in LKDTM. > > > > We really should not add an export for this. > > > > I think you'll want to just open code it in your test module. > > Isn't that going to be fragile? Why not an export? It is a little fragile, but it is functionality not needed at all by the kernel, so we should not add it to the kernel image and/or export it.
[toc] | [prev] | [next] | [standalone]
| From | Mark Rutland <mark.rutland@arm.com> |
|---|---|
| Date | 2017-09-14 20:40 +0200 |
| Subject | Re: [kernel-hardening] [PATCH v6 10/11] mm: add a user_virt_to_phys symbol |
| Message-ID | <upHdo-aN-27@gated-at.bofh.it> |
| In reply to | #1728329 |
On Thu, Sep 07, 2017 at 11:36:08AM -0600, Tycho Andersen wrote:
> We need someting like this for testing XPFO. Since it's architecture
> specific, putting it in the test code is slightly awkward, so let's make it
> an arch-specific symbol and export it for use in LKDTM.
>
> v6: * add a definition of user_virt_to_phys in the !CONFIG_XPFO case
>
> CC: linux-arm-kernel@lists.infradead.org
> CC: x86@kernel.org
> Signed-off-by: Tycho Andersen <tycho@docker.com>
> Tested-by: Marco Benatto <marco.antonio.780@gmail.com>
> ---
> arch/arm64/mm/xpfo.c | 51 ++++++++++++++++++++++++++++++++++++++++++++++
> arch/x86/mm/xpfo.c | 57 ++++++++++++++++++++++++++++++++++++++++++++++++++++
> include/linux/xpfo.h | 5 +++++
> 3 files changed, 113 insertions(+)
>
> diff --git a/arch/arm64/mm/xpfo.c b/arch/arm64/mm/xpfo.c
> index 342a9ccb93c1..94a667d94e15 100644
> --- a/arch/arm64/mm/xpfo.c
> +++ b/arch/arm64/mm/xpfo.c
> @@ -74,3 +74,54 @@ void xpfo_dma_map_unmap_area(bool map, const void *addr, size_t size,
>
> xpfo_temp_unmap(addr, size, mapping, sizeof(mapping[0]) * num_pages);
> }
> +
> +/* Convert a user space virtual address to a physical address.
> + * Shamelessly copied from slow_virt_to_phys() and lookup_address() in
> + * arch/x86/mm/pageattr.c
> + */
When can this be called? What prevents concurrent modification of the user page
tables?
i.e. must mmap_sem be held?
> +phys_addr_t user_virt_to_phys(unsigned long addr)
Does this really need to be architecture specific?
Core mm code manages to walk user page tables just fine...
> +{
> + phys_addr_t phys_addr;
> + unsigned long offset;
> + pgd_t *pgd;
> + p4d_t *p4d;
> + pud_t *pud;
> + pmd_t *pmd;
> + pte_t *pte;
> +
> + pgd = pgd_offset(current->mm, addr);
> + if (pgd_none(*pgd))
> + return 0;
Can we please separate the address and return value? e.g. pass the PA by
reference and return an error code.
AFAIK, zero is a valid PA, and even if the tables exist, they might point there
in the presence of an error.
> +
> + p4d = p4d_offset(pgd, addr);
> + if (p4d_none(*p4d))
> + return 0;
> +
> + pud = pud_offset(p4d, addr);
> + if (pud_none(*pud))
> + return 0;
> +
> + if (pud_sect(*pud) || !pud_present(*pud)) {
> + phys_addr = (unsigned long)pud_pfn(*pud) << PAGE_SHIFT;
Was there some problem with:
phys_addr = pmd_page_paddr(*pud);
... and similar for the other levels?
... I'd rather introduce new helpers than more open-coded calculations.
Thanks,
Mark.
[toc] | [prev] | [next] | [standalone]
| From | Tycho Andersen <tycho@docker.com> |
|---|---|
| Date | 2017-09-18 23:00 +0200 |
| Subject | Re: [kernel-hardening] [PATCH v6 10/11] mm: add a user_virt_to_phys symbol |
| Message-ID | <urbj4-32d-5@gated-at.bofh.it> |
| In reply to | #1732505 |
Hi Mark,
On Thu, Sep 14, 2017 at 07:34:02PM +0100, Mark Rutland wrote:
> On Thu, Sep 07, 2017 at 11:36:08AM -0600, Tycho Andersen wrote:
> > We need someting like this for testing XPFO. Since it's architecture
> > specific, putting it in the test code is slightly awkward, so let's make it
> > an arch-specific symbol and export it for use in LKDTM.
> >
> > v6: * add a definition of user_virt_to_phys in the !CONFIG_XPFO case
> >
> > CC: linux-arm-kernel@lists.infradead.org
> > CC: x86@kernel.org
> > Signed-off-by: Tycho Andersen <tycho@docker.com>
> > Tested-by: Marco Benatto <marco.antonio.780@gmail.com>
> > ---
> > arch/arm64/mm/xpfo.c | 51 ++++++++++++++++++++++++++++++++++++++++++++++
> > arch/x86/mm/xpfo.c | 57 ++++++++++++++++++++++++++++++++++++++++++++++++++++
> > include/linux/xpfo.h | 5 +++++
> > 3 files changed, 113 insertions(+)
> >
> > diff --git a/arch/arm64/mm/xpfo.c b/arch/arm64/mm/xpfo.c
> > index 342a9ccb93c1..94a667d94e15 100644
> > --- a/arch/arm64/mm/xpfo.c
> > +++ b/arch/arm64/mm/xpfo.c
> > @@ -74,3 +74,54 @@ void xpfo_dma_map_unmap_area(bool map, const void *addr, size_t size,
> >
> > xpfo_temp_unmap(addr, size, mapping, sizeof(mapping[0]) * num_pages);
> > }
> > +
> > +/* Convert a user space virtual address to a physical address.
> > + * Shamelessly copied from slow_virt_to_phys() and lookup_address() in
> > + * arch/x86/mm/pageattr.c
> > + */
>
> When can this be called? What prevents concurrent modification of the user page
> tables?
>
> i.e. must mmap_sem be held?
Yes, it should be. Since we're moving this back into the lkdtm test
code I think it's less important, since nothing should be modifying
the tables while the thread is doing the lookup, but I'll add it in
the next version.
> > +phys_addr_t user_virt_to_phys(unsigned long addr)
>
> Does this really need to be architecture specific?
>
> Core mm code manages to walk user page tables just fine...
I think so since we don't support section mappings right now, so
p*d_sect will always be false.
> > +{
> > + phys_addr_t phys_addr;
> > + unsigned long offset;
> > + pgd_t *pgd;
> > + p4d_t *p4d;
> > + pud_t *pud;
> > + pmd_t *pmd;
> > + pte_t *pte;
> > +
> > + pgd = pgd_offset(current->mm, addr);
> > + if (pgd_none(*pgd))
> > + return 0;
>
> Can we please separate the address and return value? e.g. pass the PA by
> reference and return an error code.
>
> AFAIK, zero is a valid PA, and even if the tables exist, they might point there
> in the presence of an error.
Sure, I'll rearrange this.
> > +
> > + p4d = p4d_offset(pgd, addr);
> > + if (p4d_none(*p4d))
> > + return 0;
> > +
> > + pud = pud_offset(p4d, addr);
> > + if (pud_none(*pud))
> > + return 0;
> > +
> > + if (pud_sect(*pud) || !pud_present(*pud)) {
> > + phys_addr = (unsigned long)pud_pfn(*pud) << PAGE_SHIFT;
>
> Was there some problem with:
>
> phys_addr = pmd_page_paddr(*pud);
>
> ... and similar for the other levels?
>
> ... I'd rather introduce new helpers than more open-coded calculations.
I wasn't aware of these; we could define a similar set of functions
for x86 and then make it not arch-specific.
I wonder if we could also use follow_page_pte(), since we know that
the page is always present (given that it's been allocated).
Unfortunately follow_page_pte() is not exported.
Tycho
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web