Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1728693 > unrolled thread

Re: [Outreachy kernel] [PATCH] staging: rt8712: xmit_linux: Avoid multiple assignments in a single line

Started byJulia Lawall <julia.lawall@lip6.fr>
First post2017-09-08 10:50 +0200
Last post2017-09-08 11:30 +0200
Articles 2 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [Outreachy kernel] [PATCH] staging: rt8712: xmit_linux: Avoid  multiple assignments in a single line Julia Lawall <julia.lawall@lip6.fr> - 2017-09-08 10:50 +0200
    Re: [Outreachy kernel] [PATCH] staging: rt8712: xmit_linux: Avoid  multiple assignments in a single line Julia Lawall <julia.lawall@lip6.fr> - 2017-09-08 11:30 +0200

#1728693 — Re: [Outreachy kernel] [PATCH] staging: rt8712: xmit_linux: Avoid multiple assignments in a single line

FromJulia Lawall <julia.lawall@lip6.fr>
Date2017-09-08 10:50 +0200
SubjectRe: [Outreachy kernel] [PATCH] staging: rt8712: xmit_linux: Avoid multiple assignments in a single line
Message-ID<unn97-4mN-7@gated-at.bofh.it>

On Fri, 8 Sep 2017, harsha wrote:

> Fixed coding style issue
>
> Signed-off-by: Harsha Sharma <harshasharmaiitr@gmail.com>
> ---
>  drivers/staging/rtl8712/xmit_linux.c | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/rtl8712/xmit_linux.c b/drivers/staging/rtl8712/xmit_linux.c
> index d13fd15..03c6b0c 100644
> --- a/drivers/staging/rtl8712/xmit_linux.c
> +++ b/drivers/staging/rtl8712/xmit_linux.c
> @@ -49,8 +49,10 @@ static uint remainder_len(struct pkt_file *pfile)
>  void _r8712_open_pktfile(_pkt *pktptr, struct pkt_file *pfile)
>  {
>  	pfile->pkt = pktptr;
> -	pfile->cur_addr = pfile->buf_start = pktptr->data;
> -	pfile->pkt_len = pfile->buf_len = pktptr->len;

I think this may be considered to be more readable as is.

julia

> +	pfile->cur_addr = pktptr->data;
> +	pfile->buf_start = pfile->cur_addr;
> +	pfile->pkt_len = pktptr->len;
> +	pfile->buf_len = pfile->pkt_len;
>  	pfile->cur_buffer = pfile->buf_start;
>  }
>
> --
> 1.9.1
>
> --
> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> To post to this group, send email to outreachy-kernel@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/1504859870-13153-1-git-send-email-harshasharmaiitr%40gmail.com.
> For more options, visit https://groups.google.com/d/optout.
>

[toc] | [next] | [standalone]


#1728718

FromJulia Lawall <julia.lawall@lip6.fr>
Date2017-09-08 11:30 +0200
Message-ID<unnLQ-4OG-17@gated-at.bofh.it>
In reply to#1728693

[Multipart message — attachments visible in raw view] — view raw

On Fri, 8 Sep 2017, Harsha Sharma wrote:

> Hi,Thanks for your feedback.
> I will take care about readability from next time.

Don't top post.  You should respond to comments underneath the comment you
are responding to.  The person will have to go find that anyway, to
understand what your comment is about.  Please read the tutorial again, in
particular the following:

https://kernelnewbies.org/PatchPhilosophy
https://kernelnewbies.org/CheckpatchTips
and everything starting from Responding to emails on
https://kernelnewbies.org/Outreachyfirstpatch

thanks,
julia

>
> With regards,
> Harsha Sharma
>
> On Fri, Sep 8, 2017 at 2:16 PM, Julia Lawall <julia.lawall@lip6.fr> wrote:
>
>
>       On Fri, 8 Sep 2017, harsha wrote:
>
>       > Fixed coding style issue
>       >
>       > Signed-off-by: Harsha Sharma <harshasharmaiitr@gmail.com>
>       > ---
>       >  drivers/staging/rtl8712/xmit_linux.c | 6 ++++--
>       >  1 file changed, 4 insertions(+), 2 deletions(-)
>       >
>       > diff --git a/drivers/staging/rtl8712/xmit_linux.c
>       b/drivers/staging/rtl8712/xmit_linux.c
>       > index d13fd15..03c6b0c 100644
>       > --- a/drivers/staging/rtl8712/xmit_linux.c
>       > +++ b/drivers/staging/rtl8712/xmit_linux.c
>       > @@ -49,8 +49,10 @@ static uint remainder_len(struct pkt_file
>       *pfile)
>       >  void _r8712_open_pktfile(_pkt *pktptr, struct pkt_file
>       *pfile)
>       >  {
>       >       pfile->pkt = pktptr;
>       > -     pfile->cur_addr = pfile->buf_start = pktptr->data;
>       > -     pfile->pkt_len = pfile->buf_len = pktptr->len;
>
>       I think this may be considered to be more readable as is.
>
>       julia
>
>       > +     pfile->cur_addr = pktptr->data;
>       > +     pfile->buf_start = pfile->cur_addr;
>       > +     pfile->pkt_len = pktptr->len;
>       > +     pfile->buf_len = pfile->pkt_len;
>       >       pfile->cur_buffer = pfile->buf_start;
>       >  }
>       >
>       > --
>       > 1.9.1
>       >
> > --
> > You received this message because you are subscribed to the Google
> Groups "outreachy-kernel" group.
> > To unsubscribe from this group and stop receiving emails from it,
> send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> > To post to this group, send email to
> outreachy-kernel@googlegroups.com.
> > To view this discussion on the web visithttps://groups.google.com/d/msgid/outreachy-kernel/1504859870-13153-1-git-s
> end-email-harshasharmaiitr%40gmail.com.
> > For more options, visit https://groups.google.com/d/optout.
> >
>
>
>
>

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web