Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1726296 > unrolled thread

Re: [PATCH v11 0/2] Make find_later_rq() choose a closer cpu in topology

Started byByungchul Park <byungchul.park@lge.com>
First post2017-09-05 03:00 +0200
Last post2017-09-05 03:00 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH v11 0/2] Make find_later_rq() choose a closer cpu in  topology Byungchul Park <byungchul.park@lge.com> - 2017-09-05 03:00 +0200

#1726296 — Re: [PATCH v11 0/2] Make find_later_rq() choose a closer cpu in topology

FromByungchul Park <byungchul.park@lge.com>
Date2017-09-05 03:00 +0200
SubjectRe: [PATCH v11 0/2] Make find_later_rq() choose a closer cpu in topology
Message-ID<umanD-47H-5@gated-at.bofh.it>
On Fri, Aug 25, 2017 at 03:40:49PM +0900, Byungchul Park wrote:
> Change from v10
>    -. modify a comment a bit as Steven suggested
> 
> Change from v9
>    -. modify a comment a bit so to be more clear as Juri suggested
> 
> Change from v8
>    -. add suggested-by Peterz
>    -. add several comments
> 
> Change from v7
>    -. fix a trivial typo
>    -. modify commit messages to explain what it does more clearly
>    -. simplify code with an existing macro
> 
> Change from v6
>    -. add a comment about selection of fallback_cpu incase more than one exist
>    -. modify a comment explaining what we do wrt PREFER_SIBLING
> 
> Change from v5
>    -. exclude two patches already picked up by peterz
>       (sched/deadline: Make find_later_rq() choose a closer cpu in topology)
>       (sched/deadline: Change return value of cpudl_find())
>    -. apply what peterz fixed for 'prefer sibling', into deadline and rt
> 
> Change from v4
>    -. remove a patch that might cause huge lock contention
>       (by spin lock(&cpudl.lock) in a hot path of scheduler)
> 
> Change from v3
>    -. rename closest_cpu to best_cpu so that it align with rt
>    -. protect referring cpudl.elements with cpudl.lock
>    -. change return value of cpudl_find() to bool
> 
> Change from v2
>    -. add support for SD_PREFER_SIBLING
> 
> Change from v1
>    -. clean up the patch

Could you let me know your opinion about this?

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web