Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1725672 > unrolled thread

[PATCH][thermal-next] thermal: brcmstb: remove two redundant integer range checks

Started byColin King <colin.king@canonical.com>
First post2017-09-03 15:20 +0200
Last post2017-09-08 05:00 +0200
Articles 3 — 3 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH][thermal-next] thermal: brcmstb: remove two redundant integer range checks Colin King <colin.king@canonical.com> - 2017-09-03 15:20 +0200
    Re: [PATCH][thermal-next] thermal: brcmstb: remove two redundant  integer range checks Brian Norris <computersforpeace@gmail.com> - 2017-09-06 20:50 +0200
      Re: [PATCH][thermal-next] thermal: brcmstb: remove two redundant  integer range checks Eduardo Valentin <edubezval@gmail.com> - 2017-09-08 05:00 +0200

#1725672 — [PATCH][thermal-next] thermal: brcmstb: remove two redundant integer range checks

FromColin King <colin.king@canonical.com>
Date2017-09-03 15:20 +0200
Subject[PATCH][thermal-next] thermal: brcmstb: remove two redundant integer range checks
Message-ID<ulCYF-pv-1@gated-at.bofh.it>
From: Colin Ian King <colin.king@canonical.com>

The comparisons for integer low on low > INT_MAX and also
integer high > INT_MAX are never going to be true since an
int type cannot be greater than INT_MAX.  Remove these redundant
checks.

Detected by: CoverityScan CID#1455245, 1455248 ("Operands don't affect
  result (CONSTANT_EXPRESSION_RESULT)")

Signed-off-by: Colin Ian King <colin.king@canonical.com>
---
 drivers/thermal/broadcom/brcmstb_thermal.c | 4 ----
 1 file changed, 4 deletions(-)

diff --git a/drivers/thermal/broadcom/brcmstb_thermal.c b/drivers/thermal/broadcom/brcmstb_thermal.c
index 87b8e7a86ee3..bcb3945feea6 100644
--- a/drivers/thermal/broadcom/brcmstb_thermal.c
+++ b/drivers/thermal/broadcom/brcmstb_thermal.c
@@ -278,8 +278,6 @@ static int brcmstb_set_trips(void *data, int low, int high)
 	dev_dbg(priv->dev, "set trips %d <--> %d\n", low, high);
 
 	if (low) {
-		if (low > INT_MAX)
-			low = INT_MAX;
 		avs_tmon_set_trip_temp(priv, TMON_TRIP_TYPE_LOW, low);
 		avs_tmon_trip_enable(priv, TMON_TRIP_TYPE_LOW, 1);
 	} else {
@@ -287,8 +285,6 @@ static int brcmstb_set_trips(void *data, int low, int high)
 	}
 
 	if (high < ULONG_MAX) {
-		if (high > INT_MAX)
-			high = INT_MAX;
 		avs_tmon_set_trip_temp(priv, TMON_TRIP_TYPE_HIGH, high);
 		avs_tmon_trip_enable(priv, TMON_TRIP_TYPE_HIGH, 1);
 	} else {
-- 
2.14.1

[toc] | [next] | [standalone]


#1727681 — Re: [PATCH][thermal-next] thermal: brcmstb: remove two redundant integer range checks

FromBrian Norris <computersforpeace@gmail.com>
Date2017-09-06 20:50 +0200
SubjectRe: [PATCH][thermal-next] thermal: brcmstb: remove two redundant integer range checks
Message-ID<umNyF-5FU-1@gated-at.bofh.it>
In reply to#1725672
Hi,

On Sun, Sep 03, 2017 at 02:16:19PM +0100, Colin King wrote:
> From: Colin Ian King <colin.king@canonical.com>
> 
> The comparisons for integer low on low > INT_MAX and also
> integer high > INT_MAX are never going to be true since an
> int type cannot be greater than INT_MAX.  Remove these redundant
> checks.
> 
> Detected by: CoverityScan CID#1455245, 1455248 ("Operands don't affect
>   result (CONSTANT_EXPRESSION_RESULT)")
> 
> Signed-off-by: Colin Ian King <colin.king@canonical.com>
> ---
>  drivers/thermal/broadcom/brcmstb_thermal.c | 4 ----
>  1 file changed, 4 deletions(-)
> 
> diff --git a/drivers/thermal/broadcom/brcmstb_thermal.c b/drivers/thermal/broadcom/brcmstb_thermal.c
> index 87b8e7a86ee3..bcb3945feea6 100644
> --- a/drivers/thermal/broadcom/brcmstb_thermal.c
> +++ b/drivers/thermal/broadcom/brcmstb_thermal.c
> @@ -278,8 +278,6 @@ static int brcmstb_set_trips(void *data, int low, int high)
>  	dev_dbg(priv->dev, "set trips %d <--> %d\n", low, high);
>  
>  	if (low) {
> -		if (low > INT_MAX)
> -			low = INT_MAX;
>  		avs_tmon_set_trip_temp(priv, TMON_TRIP_TYPE_LOW, low);
>  		avs_tmon_trip_enable(priv, TMON_TRIP_TYPE_LOW, 1);
>  	} else {
> @@ -287,8 +285,6 @@ static int brcmstb_set_trips(void *data, int low, int high)
>  	}
>  
>  	if (high < ULONG_MAX) {

Dan's robots noticed that the above condition is not useful either (on
architectures where INT_MAX < ULONG_MAX -- i.e., all?), since 'high' is
'int', not 'unsigned long'.

Should probably fix that

s/ULONG_MAX/INT_MAX/

?

Brian

> -		if (high > INT_MAX)
> -			high = INT_MAX;
>  		avs_tmon_set_trip_temp(priv, TMON_TRIP_TYPE_HIGH, high);
>  		avs_tmon_trip_enable(priv, TMON_TRIP_TYPE_HIGH, 1);
>  	} else {
> -- 
> 2.14.1
> 

[toc] | [prev] | [next] | [standalone]


#1728549 — Re: [PATCH][thermal-next] thermal: brcmstb: remove two redundant integer range checks

FromEduardo Valentin <edubezval@gmail.com>
Date2017-09-08 05:00 +0200
SubjectRe: [PATCH][thermal-next] thermal: brcmstb: remove two redundant integer range checks
Message-ID<unhGp-JG-7@gated-at.bofh.it>
In reply to#1727681
Hello,

On Wed, Sep 06, 2017 at 11:40:46AM -0700, Brian Norris wrote:
> Hi,
> 
> On Sun, Sep 03, 2017 at 02:16:19PM +0100, Colin King wrote:
> > From: Colin Ian King <colin.king@canonical.com>
> > 
> > The comparisons for integer low on low > INT_MAX and also
> > integer high > INT_MAX are never going to be true since an
> > int type cannot be greater than INT_MAX.  Remove these redundant
> > checks.
> > 
> > Detected by: CoverityScan CID#1455245, 1455248 ("Operands don't affect
> >   result (CONSTANT_EXPRESSION_RESULT)")
> > 
> > Signed-off-by: Colin Ian King <colin.king@canonical.com>
> > ---
> >  drivers/thermal/broadcom/brcmstb_thermal.c | 4 ----
> >  1 file changed, 4 deletions(-)
> > 
> > diff --git a/drivers/thermal/broadcom/brcmstb_thermal.c b/drivers/thermal/broadcom/brcmstb_thermal.c
> > index 87b8e7a86ee3..bcb3945feea6 100644
> > --- a/drivers/thermal/broadcom/brcmstb_thermal.c
> > +++ b/drivers/thermal/broadcom/brcmstb_thermal.c
> > @@ -278,8 +278,6 @@ static int brcmstb_set_trips(void *data, int low, int high)
> >  	dev_dbg(priv->dev, "set trips %d <--> %d\n", low, high);
> >  
> >  	if (low) {
> > -		if (low > INT_MAX)
> > -			low = INT_MAX;
> >  		avs_tmon_set_trip_temp(priv, TMON_TRIP_TYPE_LOW, low);
> >  		avs_tmon_trip_enable(priv, TMON_TRIP_TYPE_LOW, 1);
> >  	} else {
> > @@ -287,8 +285,6 @@ static int brcmstb_set_trips(void *data, int low, int high)
> >  	}
> >  
> >  	if (high < ULONG_MAX) {
> 
> Dan's robots noticed that the above condition is not useful either (on
> architectures where INT_MAX < ULONG_MAX -- i.e., all?), since 'high' is
> 'int', not 'unsigned long'.
> 
> Should probably fix that
> 
> s/ULONG_MAX/INT_MAX/

Yeah, that would probably make sense. I might be also the case that the
driver was considering long because that was the type used to represent
temperature some time back in the thermal subsystem. So, the limits on
the driver may be outdated.

> 
> ?
> 
> Brian
> 
> > -		if (high > INT_MAX)
> > -			high = INT_MAX;
> >  		avs_tmon_set_trip_temp(priv, TMON_TRIP_TYPE_HIGH, high);
> >  		avs_tmon_trip_enable(priv, TMON_TRIP_TYPE_HIGH, 1);
> >  	} else {
> > -- 
> > 2.14.1
> > 

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web