Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1714125 > unrolled thread
| Started by | Rob Herring <robh@kernel.org> |
|---|---|
| First post | 2017-08-17 17:20 +0200 |
| Last post | 2017-08-21 20:40 +0200 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH v2 1/3] dt-bindings: i2c: Document the POWER system power supply device Rob Herring <robh@kernel.org> - 2017-08-17 17:20 +0200
Re: [PATCH v2 1/3] dt-bindings: i2c: Document the POWER system power supply device Eddie James <eajames@linux.vnet.ibm.com> - 2017-08-21 20:40 +0200
| From | Rob Herring <robh@kernel.org> |
|---|---|
| Date | 2017-08-17 17:20 +0200 |
| Subject | Re: [PATCH v2 1/3] dt-bindings: i2c: Document the POWER system power supply device |
| Message-ID | <ufuKu-6EM-29@gated-at.bofh.it> |
On Thu, Aug 10, 2017 at 05:19:44PM -0500, Eddie James wrote:
> From: "Edward A. James" <eajames@us.ibm.com>
>
> Signed-off-by: Edward A. James <eajames@us.ibm.com>
> ---
> .../devicetree/bindings/i2c/ibm,power-ps.txt | 21 +++++++++++++++++++++
> 1 file changed, 21 insertions(+)
> create mode 100644 Documentation/devicetree/bindings/i2c/ibm,power-ps.txt
>
> diff --git a/Documentation/devicetree/bindings/i2c/ibm,power-ps.txt b/Documentation/devicetree/bindings/i2c/ibm,power-ps.txt
> new file mode 100644
> index 0000000..2ea8ea2
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/i2c/ibm,power-ps.txt
> @@ -0,0 +1,21 @@
> +Device-tree bindings for IBM POWER system power supplies
> +--------------------------------------------------------
> +
> +Required properties:
> + - compatible = "ibm,power-ps";
> + - reg = < I2C bus address >; : Address of the power supply on the
> + I2C bus.
> +
> +Example:
> +
> + i2c-bus@100 {
> + #address-cells = <1>;
> + #size-cells = <0>;
> + #interrupt-cells = <1>;
> + < more properties >
> +
> + power_ps@68 {
Don't use '_' in node names. Should be a generic name too if possible.
Perhaps "power-supply".
> + compatible = "ibm,power-ps";
> + reg = <0x68>;
> + };
> + };
> --
> 1.8.3.1
>
[toc] | [next] | [standalone]
| From | Eddie James <eajames@linux.vnet.ibm.com> |
|---|---|
| Date | 2017-08-21 20:40 +0200 |
| Message-ID | <ugZMf-7RS-23@gated-at.bofh.it> |
| In reply to | #1714125 |
On 08/17/2017 10:11 AM, Rob Herring wrote:
> On Thu, Aug 10, 2017 at 05:19:44PM -0500, Eddie James wrote:
>> From: "Edward A. James" <eajames@us.ibm.com>
>>
>> Signed-off-by: Edward A. James <eajames@us.ibm.com>
>> ---
>> .../devicetree/bindings/i2c/ibm,power-ps.txt | 21 +++++++++++++++++++++
>> 1 file changed, 21 insertions(+)
>> create mode 100644 Documentation/devicetree/bindings/i2c/ibm,power-ps.txt
>>
>> diff --git a/Documentation/devicetree/bindings/i2c/ibm,power-ps.txt b/Documentation/devicetree/bindings/i2c/ibm,power-ps.txt
>> new file mode 100644
>> index 0000000..2ea8ea2
>> --- /dev/null
>> +++ b/Documentation/devicetree/bindings/i2c/ibm,power-ps.txt
>> @@ -0,0 +1,21 @@
>> +Device-tree bindings for IBM POWER system power supplies
>> +--------------------------------------------------------
>> +
>> +Required properties:
>> + - compatible = "ibm,power-ps";
>> + - reg = < I2C bus address >; : Address of the power supply on the
>> + I2C bus.
>> +
>> +Example:
>> +
>> + i2c-bus@100 {
>> + #address-cells = <1>;
>> + #size-cells = <0>;
>> + #interrupt-cells = <1>;
>> + < more properties >
>> +
>> + power_ps@68 {
> Don't use '_' in node names. Should be a generic name too if possible.
> Perhaps "power-supply".
Yes, the latest patch set switched this to power-supply. The driver name
changed in v3, sorry for the confusion.
Thanks,
Eddie
>
>> + compatible = "ibm,power-ps";
>> + reg = <0x68>;
>> + };
>> + };
>> --
>> 1.8.3.1
>>
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web