Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1704847 > unrolled thread

Re: [PATCH v2 00/17] IB/mlx: Fine-tuning for several function implementations

Started bySF Markus Elfring <elfring@users.sourceforge.net>
First post2017-08-06 16:10 +0200
Last post2017-08-06 16:10 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH v2 00/17] IB/mlx: Fine-tuning for several function  implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2017-08-06 16:10 +0200

#1704847 — Re: [PATCH v2 00/17] IB/mlx: Fine-tuning for several function implementations

FromSF Markus Elfring <elfring@users.sourceforge.net>
Date2017-08-06 16:10 +0200
SubjectRe: [PATCH v2 00/17] IB/mlx: Fine-tuning for several function implementations
Message-ID<ubupI-3f0-3@gated-at.bofh.it>
> Date: Fri, 21 Apr 2017 19:56:54 +0200
> 
> Several update suggestions were taken into account
> from static source code analysis.
> 
> Markus Elfring (17):
>   Use kcalloc() in mlx4_ib_alloc_pv_bufs()
>   Use kmalloc_array() in six functions
>   Improve size determinations in six functions
>   Fix a typo in a comment line
>   Delete four unnecessary return statements
>   Delete an unnecessary check before kfree() in free_pv_object()
>   Move an assignment out of a check in forward_trap()
>   Enclose 46 expressions for sizeof by parentheses
>   Split a condition check in six functions
>   Delete an unnecessary variable in __mlx4_ib_query_gid()
>   Delete an unnecessary variable initialisation in mlx4_ib_add()
>   Delete an unnecessary variable assignment in mlx4_ib_add()
>   Delete an error message for a failed memory allocation in mlx4_ib_add()
>   Delete unnecessary braces in mlx4_ib_add()
>   Delete unwanted spaces behind usages of the sizeof operator
>   Add spaces for better code readability
>   Less function calls in create_kernel_qp() after error detection
> ---
> 
> v2:
> Changes were rebased on source files from Linux next-20170421.
> Some of them were recombined as requested by Doug Ledford.
> 
>  drivers/infiniband/hw/mlx4/mad.c  |  72 ++++++++--------
>  drivers/infiniband/hw/mlx4/main.c | 164 ++++++++++++++++++++----------------
>  drivers/infiniband/hw/mlx4/qp.c   | 173 +++++++++++++++++++-------------------
>  drivers/infiniband/hw/mlx5/qp.c   |  66 ++++++++++-----
>  drivers/infiniband/hw/mlx5/srq.c  |   5 +-
>  5 files changed, 261 insertions(+), 219 deletions(-)

Will the clarification be continued for the shown change possibilities?

Regards,
Markus

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web