Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1705616 > unrolled thread

Re: [PATCH] ASoC: compress: Remove duplicated code

Started byMark Brown <broonie@kernel.org>
First post2017-08-07 17:10 +0200
Last post2017-08-07 17:10 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH] ASoC: compress: Remove duplicated code Mark Brown <broonie@kernel.org> - 2017-08-07 17:10 +0200

#1705616 — Re: [PATCH] ASoC: compress: Remove duplicated code

FromMark Brown <broonie@kernel.org>
Date2017-08-07 17:10 +0200
SubjectRe: [PATCH] ASoC: compress: Remove duplicated code
Message-ID<ubRPk-1xo-15@gated-at.bofh.it>

[Multipart message — attachments visible in raw view] — view raw

On Mon, Aug 07, 2017 at 09:18:09PM +0800, Donglin Peng wrote:

> The value of the variable new_name is assigned repeatedly.

> @@ -737,9 +737,6 @@ int snd_soc_new_compress(struct snd_soc_pcm_runtime
> *rtd, int num)
>         }
> 
>         /* check client and interface hw capabilities */
> -       snprintf(new_name, sizeof(new_name), "%s %s-%d",
> -                       rtd->dai_link->stream_name, codec_dai->name, num);
> -

Are you sure that this is the assignment that should be deleted, and if
so why?  Note that it's both conditionally and unconditionally assigned
later on...  Some words in the commit log about why this copy is removed
would be helpful.

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web