Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1696806 > unrolled thread

[PATCH v6 0/7] drm/rockchip: add all full framework vop support

Started byMark Yao <mark.yao@rock-chips.com>
First post2017-07-26 08:20 +0200
Last post2017-07-31 03:10 +0200
Articles 4 on this page of 24 — 5 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH v6 0/7] drm/rockchip: add all full framework vop support Mark Yao <mark.yao@rock-chips.com> - 2017-07-26 08:20 +0200
    [PATCH v6 3/7] drm/rockchip: vop: move line_flag_num to interrupt registers Mark Yao <mark.yao@rock-chips.com> - 2017-07-26 08:20 +0200
      Re: [PATCH v6 3/7] drm/rockchip: vop: move line_flag_num to interrupt registers Heiko Stuebner <heiko@sntech.de> - 2017-07-27 01:00 +0200
    [PATCH v6 1/7] drm/rockchip: vop: initialize registers directly Mark Yao <mark.yao@rock-chips.com> - 2017-07-26 08:20 +0200
      Re: [PATCH v6 1/7] drm/rockchip: vop: initialize registers directly Heiko Stuebner <heiko@sntech.de> - 2017-07-27 00:50 +0200
      Re: [v6,1/7] drm/rockchip: vop: initialize registers directly jeffy <jeffy.chen@rock-chips.com> - 2017-07-27 10:40 +0200
    [PATCH v6 6/7] dt-bindings: display: rockchip: fill Documents for vop series Mark Yao <mark.yao@rock-chips.com> - 2017-07-26 08:20 +0200
      Re: [PATCH v6 6/7] dt-bindings: display: rockchip: fill Documents for vop series Heiko Stuebner <heiko@sntech.de> - 2017-07-28 11:30 +0200
    [PATCH v6 4/7] drm/rockchip: vop: group vop registers Mark Yao <mark.yao@rock-chips.com> - 2017-07-26 08:30 +0200
      Re: [v6,4/7] drm/rockchip: vop: group vop registers jeffy <jeffy.chen@rock-chips.com> - 2017-07-27 10:50 +0200
      Re: [PATCH v6 4/7] drm/rockchip: vop: group vop registers Heiko Stübner <heiko@sntech.de> - 2017-07-27 12:00 +0200
        Re: [PATCH v6 4/7] drm/rockchip: vop: group vop registers Heiko Stübner <heiko@sntech.de> - 2017-07-27 12:20 +0200
          Re: [PATCH v6 4/7] drm/rockchip: vop: group vop registers Mark yao <mark.yao@rock-chips.com> - 2017-07-28 03:10 +0200
            Re: [PATCH v6 4/7] drm/rockchip: vop: group vop registers Mark yao <mark.yao@rock-chips.com> - 2017-07-28 04:50 +0200
      [PATCH v6.1 4/7] drm/rockchip: vop: group vop registers Mark Yao <mark.yao@rock-chips.com> - 2017-07-28 08:10 +0200
        Re: [PATCH v6.1 4/7] drm/rockchip: vop: group vop registers Heiko Stuebner <heiko@sntech.de> - 2017-07-28 11:30 +0200
    [PATCH v6 7/7] drm/rockchip: vop: rk3328: fix overlay abnormal Mark Yao <mark.yao@rock-chips.com> - 2017-07-26 08:30 +0200
      Re: [v6,7/7] drm/rockchip: vop: rk3328: fix overlay abnormal jeffy <jeffy.chen@rock-chips.com> - 2017-07-27 10:50 +0200
      Re: [PATCH v6 7/7] drm/rockchip: vop: rk3328: fix overlay abnormal Heiko Stuebner <heiko@sntech.de> - 2017-07-28 15:10 +0200
    [PATCH v6 2/7] drm/rockchip: vop: move write_relaxed flags to vop register Mark Yao <mark.yao@rock-chips.com> - 2017-07-26 08:30 +0200
      Re: [PATCH v6 2/7] drm/rockchip: vop: move write_relaxed flags to vop register Heiko Stuebner <heiko@sntech.de> - 2017-07-27 00:50 +0200
      Re: [v6,2/7] drm/rockchip: vop: move write_relaxed flags to vop register jeffy <jeffy.chen@rock-chips.com> - 2017-07-27 10:50 +0200
    Re: [PATCH v6 5/7] drm/rockchip: vop: add a series of vop support Heiko Stuebner <heiko@sntech.de> - 2017-07-28 14:50 +0200
    Re: [PATCH v6 0/7] drm/rockchip: add all full framework vop support Mark yao <mark.yao@rock-chips.com> - 2017-07-31 03:10 +0200

Page 2 of 2 — ← Prev page 1 [2]


#1697606 — Re: [PATCH v6 2/7] drm/rockchip: vop: move write_relaxed flags to vop register

FromHeiko Stuebner <heiko@sntech.de>
Date2017-07-27 00:50 +0200
SubjectRe: [PATCH v6 2/7] drm/rockchip: vop: move write_relaxed flags to vop register
Message-ID<u7DhT-6kZ-5@gated-at.bofh.it>
In reply to#1696815
Am Mittwoch, 26. Juli 2017, 14:19:12 CEST schrieb Mark Yao:
> Since the drm atomic framework, only a small part of the vop
> register needs sync write, Currently seems only following registers
> need sync write:
>    cfg_done, standby and interrupt related register.
> 
> All ctrl registers are using the sync write method that is
> inefficient, hardcode the write_relaxed flags to vop registers,
> then can only do synchronize write for those actual needed register.
> 
> Signed-off-by: Mark Yao <mark.yao@rock-chips.com>

on rk3036 and rk3288
Tested-by: Heiko Stuebner <heiko@sntech.de>


Heiko

[toc] | [prev] | [next] | [standalone]


#1697805 — Re: [v6,2/7] drm/rockchip: vop: move write_relaxed flags to vop register

Fromjeffy <jeffy.chen@rock-chips.com>
Date2017-07-27 10:50 +0200
SubjectRe: [v6,2/7] drm/rockchip: vop: move write_relaxed flags to vop register
Message-ID<u7MEy-3Re-7@gated-at.bofh.it>
In reply to#1696815
Hi mark,

On 07/26/2017 02:19 PM, Mark yao wrote:
> Since the drm atomic framework, only a small part of the vop
> register needs sync write, Currently seems only following registers
> need sync write:
>     cfg_done, standby and interrupt related register.
>
> All ctrl registers are using the sync write method that is
> inefficient, hardcode the write_relaxed flags to vop registers,
> then can only do synchronize write for those actual needed register.
>
> Signed-off-by: Mark Yao<mark.yao@rock-chips.com>
> Tested-by: Heiko Stuebner<heiko@sntech.de>

Reviewed-by: Jeffy Chen <jeffy.chen@rock-chips.com>

[toc] | [prev] | [next] | [standalone]


#1698746 — Re: [PATCH v6 5/7] drm/rockchip: vop: add a series of vop support

FromHeiko Stuebner <heiko@sntech.de>
Date2017-07-28 14:50 +0200
SubjectRe: [PATCH v6 5/7] drm/rockchip: vop: add a series of vop support
Message-ID<u8cSl-3NQ-19@gated-at.bofh.it>
In reply to#1696806
Am Mittwoch, 26. Juli 2017, 14:19:30 CEST schrieb Mark Yao:
> Vop Full framework now has following vops:
> IP version    chipname
>   3.1           rk3288
>   3.2           rk3368
>   3.4           rk3366
>   3.5           rk3399 big
>   3.6           rk3399 lit
>   3.7           rk3228
>   3.8           rk3328
> 
> The above IP version is from H/W define, some of vop support get
> the IP version from VERSION_INFO register, some are not.
> hardcode the IP version for each vop to identify them.
> 
> major version: used for IP structure, Vop full framework is 3,
>                vop little framework is 2.
> minor version: on same structure, newer design vop will bigger
>                then old one.
> 
> Signed-off-by: Mark Yao <mark.yao@rock-chips.com>

on rk3036 and rk3288
Tested-by: Heiko Stuebner <heiko@sntech.de>


Heiko

[toc] | [prev] | [next] | [standalone]


#1699641

FromMark yao <mark.yao@rock-chips.com>
Date2017-07-31 03:10 +0200
Message-ID<u97nz-7UT-5@gated-at.bofh.it>
In reply to#1696806
Hi

Pushed to drm-misc-next.

Thanks Sean Paul, Jeffy Chen's review, Heiko's test and Rob's ack.

Best regards.

On 2017年07月26日 14:18, Mark Yao wrote:
> These patches try to make all current rockchip full framework vop works
> on drm, fill missing vop on full framework.
> Vop Full framework now has following vops:
> IP version    chipname
>        3.1           rk3288
>        3.2           rk3368
>        3.4           rk3366
>        3.5           rk3399 big
>        3.6           rk3399 lit
>        3.7           rk3228
>        3.8           rk3328
>
> Group the vop register, it would make register  definition clearer and
> more easily to reuse same group register define for difference vops.
>
> Tested on rk3399 excavator board with kernel 4.13-rc1.
>
> And other chips tested on rockchip kernel 4.4:
>     https://github.com/rockchip-linux/kernel/tree/release-4.4/drivers/gpu/drm/rockchip
>
> Changes in v6:
> - fix some patches complie error
> - fix rk3036 display blank
>
> Changes in v5:
> - clean document commit title
> - move changes description out of docummit commit msg
>
> Changes in v4:
> - rebase to newest torvalds kernel, fix merge conflict
>
> Changes in v3:
> - group vop register instead using VOP_REG_VER mechanism
> - Explain more on patch commit message
> - move write_relaxed flags to vop registers
> - fix rk3328 overlay abnormal
>
> Changes in v2:
> - rename rk322x to rk3228
> - correct some vop registers define
>
> Mark Yao (7):
>    drm/rockchip: vop: initialize registers directly
>    drm/rockchip: vop: move write_relaxed flags to vop register
>    drm/rockchip: vop: move line_flag_num to interrupt registers
>    drm/rockchip: vop: group vop registers
>    drm/rockchip: vop: add a series of vop support
>    dt-bindings: display: rockchip: fill Documents for vop series
>    drm/rockchip: vop: rk3328: fix overlay abnormal
>
>   .../bindings/display/rockchip/rockchip-vop.txt     |   4 +
>   drivers/gpu/drm/rockchip/rockchip_drm_vop.c        | 109 ++-
>   drivers/gpu/drm/rockchip/rockchip_drm_vop.h        |  81 +-
>   drivers/gpu/drm/rockchip/rockchip_vop_reg.c        | 375 ++++++---
>   drivers/gpu/drm/rockchip/rockchip_vop_reg.h        | 905 ++++++++++++++++-----
>   5 files changed, 1075 insertions(+), 399 deletions(-)
>


-- 
Mark Yao

[toc] | [prev] | [standalone]


Page 2 of 2 — ← Prev page 1 [2]

Back to top | Article view | linux.kernel


csiph-web