Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1692519 > unrolled thread

[PATCH v7 0/3] MFD: add driver for HiSilicon Hi6421v530 PMIC

Started byGuodong Xu <guodong.xu@linaro.org>
First post2017-07-20 09:40 +0200
Last post2017-07-20 11:00 +0200
Articles 3 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH v7 0/3] MFD: add driver for HiSilicon Hi6421v530 PMIC Guodong Xu <guodong.xu@linaro.org> - 2017-07-20 09:40 +0200
    [PATCH v7 2/3] mfd: hi6421-pmic: cleanup: update dev_err messages Guodong Xu <guodong.xu@linaro.org> - 2017-07-20 09:40 +0200
      Re: [PATCH v7 2/3] mfd: hi6421-pmic: cleanup: update dev_err messages Lee Jones <lee.jones@linaro.org> - 2017-07-20 11:00 +0200

#1692519 — [PATCH v7 0/3] MFD: add driver for HiSilicon Hi6421v530 PMIC

FromGuodong Xu <guodong.xu@linaro.org>
Date2017-07-20 09:40 +0200
Subject[PATCH v7 0/3] MFD: add driver for HiSilicon Hi6421v530 PMIC
Message-ID<u5ee2-46l-95@gated-at.bofh.it>
This patchset adds driver for HiSilicon Hi6421v530 PMIC.

Mainline kernel already has driver support to a similar chip, Hi6421.
Hi6421 and Hi6421v530 are both from the same vendor, HiSilicon, but
they are at different revisions. They both use the same Memory-mapped
I/O method to communicate with Main SoC. However, they differ quite a
lot in their regulator designs. Eg. they have completely different LDO
voltage points.

Patch 1 and 2 are hi6421-pmic cleaning up.
Patch 3 extends hi6421-pmic-core.c to support Hi6421v530 revision.

Major changes in v7:
 - rebase to v4.13-rc1 and resend MFD driver patches.
 - As of v6, DTS and regulator parts have been merged into v4.13-rc1.
   So they are not included in v7.

Major changes in v6:
 - Patch 5, solve review comments from Mark Brown, add hi6421v530 regulator
     driver to module device table.
 - Add Acked-by from Arnd Bergmann

Major changes in v5:
 - Patch 3, solve review comments from Lee Johes

Major changes in v4:
 - put hi6421-pmic cleanup in separate patches.
 - solve review comments from Lee Johes.
 - regulator-name should not have '/' character. Otherwise it "Failed to
     create debugfs directory"

Major changes in v3:
 - in hi6421-pmic-core.c
    * use shorter license script.
    * arrange #include in alphabetical order.
    * using recommended error log messages from Lee Jones.
 - in hi6421v530-regulator.c
    * remove unused #include files
    * arrange remaining ones in alphabetical order.

Major changes in v2:
 - instead of writing a new driver, extend hi6421-pmic-core.c
     to support its v530 revision
 - update hi6421v530-regulator.c to use modern regulator driver
     design logics.

*** BLURB HERE ***

Guodong Xu (3):
  mfd: hi6421-pmic: cleanup: change license text to shorter form
  mfd: hi6421-pmic: cleanup: update dev_err messages
  mfd: hi6421-pmic: add support for HiSilicon Hi6421v530

 drivers/mfd/hi6421-pmic-core.c  | 89 ++++++++++++++++++++++++++---------------
 include/linux/mfd/hi6421-pmic.h |  5 +++
 2 files changed, 62 insertions(+), 32 deletions(-)

-- 
2.10.2

[toc] | [next] | [standalone]


#1692522 — [PATCH v7 2/3] mfd: hi6421-pmic: cleanup: update dev_err messages

FromGuodong Xu <guodong.xu@linaro.org>
Date2017-07-20 09:40 +0200
Subject[PATCH v7 2/3] mfd: hi6421-pmic: cleanup: update dev_err messages
Message-ID<u5ee3-46l-117@gated-at.bofh.it>
In reply to#1692519
Update dev_err messages to make them more readable.

Signed-off-by: Guodong Xu <guodong.xu@linaro.org>
Acked-by: Arnd Bergmann <arnd@arndb.de>
---
 drivers/mfd/hi6421-pmic-core.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/mfd/hi6421-pmic-core.c b/drivers/mfd/hi6421-pmic-core.c
index ad9e3d8..b1139d4 100644
--- a/drivers/mfd/hi6421-pmic-core.c
+++ b/drivers/mfd/hi6421-pmic-core.c
@@ -52,8 +52,8 @@ static int hi6421_pmic_probe(struct platform_device *pdev)
 	pmic->regmap = devm_regmap_init_mmio_clk(&pdev->dev, NULL, base,
 						 &hi6421_regmap_config);
 	if (IS_ERR(pmic->regmap)) {
-		dev_err(&pdev->dev,
-			"regmap init failed: %ld\n", PTR_ERR(pmic->regmap));
+		dev_err(&pdev->dev, "Failed to initialise Regmap: %ld\n",
+						PTR_ERR(pmic->regmap));
 		return PTR_ERR(pmic->regmap);
 	}
 
@@ -70,7 +70,7 @@ static int hi6421_pmic_probe(struct platform_device *pdev)
 	ret = devm_mfd_add_devices(&pdev->dev, 0, hi6421_devs,
 				   ARRAY_SIZE(hi6421_devs), NULL, 0, NULL);
 	if (ret) {
-		dev_err(&pdev->dev, "add mfd devices failed: %d\n", ret);
+		dev_err(&pdev->dev, "Failed to add child devices: %d\n", ret);
 		return ret;
 	}
 
-- 
2.10.2

[toc] | [prev] | [next] | [standalone]


#1692607 — Re: [PATCH v7 2/3] mfd: hi6421-pmic: cleanup: update dev_err messages

FromLee Jones <lee.jones@linaro.org>
Date2017-07-20 11:00 +0200
SubjectRe: [PATCH v7 2/3] mfd: hi6421-pmic: cleanup: update dev_err messages
Message-ID<u5ftn-4U4-15@gated-at.bofh.it>
In reply to#1692522
On Thu, 20 Jul 2017, Guodong Xu wrote:

> Update dev_err messages to make them more readable.
> 
> Signed-off-by: Guodong Xu <guodong.xu@linaro.org>
> Acked-by: Arnd Bergmann <arnd@arndb.de>
> ---
>  drivers/mfd/hi6421-pmic-core.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)

Applied, thanks.

> diff --git a/drivers/mfd/hi6421-pmic-core.c b/drivers/mfd/hi6421-pmic-core.c
> index ad9e3d8..b1139d4 100644
> --- a/drivers/mfd/hi6421-pmic-core.c
> +++ b/drivers/mfd/hi6421-pmic-core.c
> @@ -52,8 +52,8 @@ static int hi6421_pmic_probe(struct platform_device *pdev)
>  	pmic->regmap = devm_regmap_init_mmio_clk(&pdev->dev, NULL, base,
>  						 &hi6421_regmap_config);
>  	if (IS_ERR(pmic->regmap)) {
> -		dev_err(&pdev->dev,
> -			"regmap init failed: %ld\n", PTR_ERR(pmic->regmap));
> +		dev_err(&pdev->dev, "Failed to initialise Regmap: %ld\n",
> +						PTR_ERR(pmic->regmap));
>  		return PTR_ERR(pmic->regmap);
>  	}
>  
> @@ -70,7 +70,7 @@ static int hi6421_pmic_probe(struct platform_device *pdev)
>  	ret = devm_mfd_add_devices(&pdev->dev, 0, hi6421_devs,
>  				   ARRAY_SIZE(hi6421_devs), NULL, 0, NULL);
>  	if (ret) {
> -		dev_err(&pdev->dev, "add mfd devices failed: %d\n", ret);
> +		dev_err(&pdev->dev, "Failed to add child devices: %d\n", ret);
>  		return ret;
>  	}
>  

-- 
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web