Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1688135 > unrolled thread

[PATCH 0/3] thermal: core: Fix some error handling code in 'thermal_zone_device_register()'

Started byChristophe JAILLET <christophe.jaillet@wanadoo.fr>
First post2017-07-16 09:00 +0200
Last post2017-07-16 09:00 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.kernel


Contents

  [PATCH 0/3] thermal: core: Fix some error handling code in 'thermal_zone_device_register()' Christophe JAILLET <christophe.jaillet@wanadoo.fr> - 2017-07-16 09:00 +0200

#1688135 — [PATCH 0/3] thermal: core: Fix some error handling code in 'thermal_zone_device_register()'

FromChristophe JAILLET <christophe.jaillet@wanadoo.fr>
Date2017-07-16 09:00 +0200
Subject[PATCH 0/3] thermal: core: Fix some error handling code in 'thermal_zone_device_register()'
Message-ID<u3LH3-3He-5@gated-at.bofh.it>
These 3 patches are all related to error handling in
'thermal_zone_device_register()'. I've splitted them in 3 because each
fixes or cleans something different. They could also be merged together
because they are all related to the same few lines of code.

The 1st one fixes in memory leak.
The 2nd reorders code in the error handling path to have it more logical.
The 3rd simplifies the code.

Not 100% sure, but the 2nd one could also avoid an OOPS because we
try to unregister something that has never been registered.

Christophe JAILLET (3):
  thermal: core: Fix a memory leak in 'thermal_zone_device_register()'
    error handling path
  thermal: core: Reorder 'thermal_zone_device_register()' error handling
    code
  thermal: core: Avoid code duplication in
    'thermal_zone_device_register()'

 drivers/thermal/thermal_core.c | 20 +++++++++-----------
 1 file changed, 9 insertions(+), 11 deletions(-)

-- 
2.11.0

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web