Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1683205 > unrolled thread

[PATCH] ARM: dts: at91: sama5d2_xplained: use pin macros instead of numbers

Started byLudovic Desroches <ludovic.desroches@microchip.com>
First post2017-07-07 16:00 +0200
Last post2017-07-17 11:20 +0200
Articles 5 — 4 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH] ARM: dts: at91: sama5d2_xplained: use pin macros instead of numbers Ludovic Desroches <ludovic.desroches@microchip.com> - 2017-07-07 16:00 +0200
    Re: [PATCH] ARM: dts: at91: sama5d2_xplained: use pin macros instead  of numbers kbuild test robot <lkp@intel.com> - 2017-07-09 01:30 +0200
      [PATCH v2] ARM: dts: at91: sama5d2_xplained: use pin macros instead of numbers Ludovic Desroches <ludovic.desroches@microchip.com> - 2017-07-10 08:20 +0200
        Re: [PATCH v2] ARM: dts: at91: sama5d2_xplained: use pin macros  instead of numbers Nicolas Ferre <nicolas.ferre@microchip.com> - 2017-07-13 14:00 +0200
        Re: [PATCH v2] ARM: dts: at91: sama5d2_xplained: use pin macros  instead of numbers Alexandre Belloni <alexandre.belloni@free-electrons.com> - 2017-07-17 11:20 +0200

#1683205 — [PATCH] ARM: dts: at91: sama5d2_xplained: use pin macros instead of numbers

FromLudovic Desroches <ludovic.desroches@microchip.com>
Date2017-07-07 16:00 +0200
Subject[PATCH] ARM: dts: at91: sama5d2_xplained: use pin macros instead of numbers
Message-ID<u0BXA-4Oh-19@gated-at.bofh.it>
Use pin macros instead of magic numbers to ease interpretation.

Signed-off-by: Ludovic Desroches <ludovic.desroches@microchip.com>
---
 arch/arm/boot/dts/at91-sama5d2_xplained.dts | 24 ++++++++++++------------
 1 file changed, 12 insertions(+), 12 deletions(-)

diff --git a/arch/arm/boot/dts/at91-sama5d2_xplained.dts b/arch/arm/boot/dts/at91-sama5d2_xplained.dts
index 2e2c3d1a1fa2..8dc436631b8d 100644
--- a/arch/arm/boot/dts/at91-sama5d2_xplained.dts
+++ b/arch/arm/boot/dts/at91-sama5d2_xplained.dts
@@ -68,7 +68,7 @@
 
 	ahb {
 		usb0: gadget@00300000 {
-			atmel,vbus-gpio = <&pioA 31 GPIO_ACTIVE_HIGH>;
+			atmel,vbus-gpio = <&pioA PIN_PA31 GPIO_ACTIVE_HIGH>;
 			pinctrl-names = "default";
 			pinctrl-0 = <&pinctrl_usba_vbus>;
 			status = "okay";
@@ -76,8 +76,8 @@
 
 		usb1: ohci@00400000 {
 			num-ports = <3>;
-			atmel,vbus-gpio = <0 /* &pioA 41 GPIO_ACTIVE_HIGH */
-					   &pioA 42 GPIO_ACTIVE_HIGH
+			atmel,vbus-gpio = <0 /* &pioA PIN_PB9 GPIO_ACTIVE_HIGH */
+					   &pioA PIN_PB10 GPIO_ACTIVE_HIGH
 					   0
 					  >;
 			pinctrl-names = "default";
@@ -127,7 +127,7 @@
 				ethernet-phy@1 {
 					reg = <0x1>;
 					interrupt-parent = <&pioA>;
-					interrupts = <73 IRQ_TYPE_LEVEL_LOW>;
+					interrupts = <PIN_PC9 IRQ_TYPE_LEVEL_LOW>;
 				};
 			};
 
@@ -160,9 +160,9 @@
 					compatible = "active-semi,act8945a";
 					reg = <0x5b>;
 					active-semi,vsel-high;
-					active-semi,chglev-gpios = <&pioA 12 GPIO_ACTIVE_HIGH>;
-					active-semi,lbo-gpios = <&pioA 72 GPIO_ACTIVE_LOW>;
-					active-semi,irq_gpios = <&pioA 45 GPIO_ACTIVE_LOW>;
+					active-semi,chglev-gpios = <&pioA PIN_PA12 GPIO_ACTIVE_HIGH>;
+					active-semi,lbo-gpios = <&pioA PIN_PC8 GPIO_ACTIVE_LOW>;
+					active-semi,irq_gpios = <&pioA PIN_PB13 GPIO_ACTIVE_LOW>;
 					active-semi,input-voltage-threshold-microvolt = <6600>;
 					active-semi,precondition-timeout = <40>;
 					active-semi,total-timeout = <3>;
@@ -504,7 +504,7 @@
 
 		bp1 {
 			label = "PB_USER";
-			gpios = <&pioA 41 GPIO_ACTIVE_LOW>;
+			gpios = <&pioA PIN_PB9 GPIO_ACTIVE_LOW>;
 			linux,code = <0x104>;
 		};
 	};
@@ -517,17 +517,17 @@
 
 		red {
 			label = "red";
-			gpios = <&pioA 38 GPIO_ACTIVE_LOW>;
-		};
+			gpios = <&pioA PIN_PB6 GPIO_ACTIVE_LOW>;
+
 
 		green {
 			label = "green";
-			gpios = <&pioA 37 GPIO_ACTIVE_LOW>;
+			gpios = <&pioA PIN_PB5 GPIO_ACTIVE_LOW>;
 		};
 
 		blue {
 			label = "blue";
-			gpios = <&pioA 32 GPIO_ACTIVE_LOW>;
+			gpios = <&pioA PIN_PB0 GPIO_ACTIVE_LOW>;
 			linux,default-trigger = "heartbeat";
 		};
 	};
-- 
2.12.2

[toc] | [next] | [standalone]


#1683677 — Re: [PATCH] ARM: dts: at91: sama5d2_xplained: use pin macros instead of numbers

Fromkbuild test robot <lkp@intel.com>
Date2017-07-09 01:30 +0200
SubjectRe: [PATCH] ARM: dts: at91: sama5d2_xplained: use pin macros instead of numbers
Message-ID<u17kJ-8wk-11@gated-at.bofh.it>
In reply to#1683205

[Multipart message — attachments visible in raw view] — view raw

Hi Ludovic,

[auto build test ERROR on at91/at91-next]
[also build test ERROR on v4.12 next-20170707]
[if your patch is applied to the wrong git tree, please drop us a note to help improve the system]

url:    https://github.com/0day-ci/linux/commits/Ludovic-Desroches/ARM-dts-at91-sama5d2_xplained-use-pin-macros-instead-of-numbers/20170709-040631
base:   https://git.kernel.org/pub/scm/linux/kernel/git/nferre/linux-at91.git at91-next
config: arm-at91_dt_defconfig (attached as .config)
compiler: arm-linux-gnueabi-gcc (Debian 6.1.1-9) 6.1.1 20160705
reproduce:
        wget https://raw.githubusercontent.com/01org/lkp-tests/master/sbin/make.cross -O ~/bin/make.cross
        chmod +x ~/bin/make.cross
        # save the attached .config to linux build tree
        make.cross ARCH=arm 

All errors (new ones prefixed by >>):

>> Error: arch/arm/boot/dts/at91-sama5d2_xplained.dts:538.3-539.1 syntax error
   FATAL ERROR: Unable to parse input tree

---
0-DAY kernel test infrastructure                Open Source Technology Center
https://lists.01.org/pipermail/kbuild-all                   Intel Corporation

[toc] | [prev] | [next] | [standalone]


#1683977 — [PATCH v2] ARM: dts: at91: sama5d2_xplained: use pin macros instead of numbers

FromLudovic Desroches <ludovic.desroches@microchip.com>
Date2017-07-10 08:20 +0200
Subject[PATCH v2] ARM: dts: at91: sama5d2_xplained: use pin macros instead of numbers
Message-ID<u1Ad3-1kU-1@gated-at.bofh.it>
In reply to#1683677
Use pin macros instead of magic numbers to ease interpretation.

Signed-off-by: Ludovic Desroches <ludovic.desroches@microchip.com>
---

I have remove the unexpected brace removal from the first version of this patch.

 arch/arm/boot/dts/at91-sama5d2_xplained.dts | 23 ++++++++++++-----------
 1 file changed, 12 insertions(+), 11 deletions(-)

diff --git a/arch/arm/boot/dts/at91-sama5d2_xplained.dts b/arch/arm/boot/dts/at91-sama5d2_xplained.dts
index 2e2c3d1a1fa2..6eec8dc5143e 100644
--- a/arch/arm/boot/dts/at91-sama5d2_xplained.dts
+++ b/arch/arm/boot/dts/at91-sama5d2_xplained.dts
@@ -68,7 +68,7 @@
 
 	ahb {
 		usb0: gadget@00300000 {
-			atmel,vbus-gpio = <&pioA 31 GPIO_ACTIVE_HIGH>;
+			atmel,vbus-gpio = <&pioA PIN_PA31 GPIO_ACTIVE_HIGH>;
 			pinctrl-names = "default";
 			pinctrl-0 = <&pinctrl_usba_vbus>;
 			status = "okay";
@@ -76,8 +76,8 @@
 
 		usb1: ohci@00400000 {
 			num-ports = <3>;
-			atmel,vbus-gpio = <0 /* &pioA 41 GPIO_ACTIVE_HIGH */
-					   &pioA 42 GPIO_ACTIVE_HIGH
+			atmel,vbus-gpio = <0 /* &pioA PIN_PB9 GPIO_ACTIVE_HIGH */
+					   &pioA PIN_PB10 GPIO_ACTIVE_HIGH
 					   0
 					  >;
 			pinctrl-names = "default";
@@ -127,7 +127,7 @@
 				ethernet-phy@1 {
 					reg = <0x1>;
 					interrupt-parent = <&pioA>;
-					interrupts = <73 IRQ_TYPE_LEVEL_LOW>;
+					interrupts = <PIN_PC9 IRQ_TYPE_LEVEL_LOW>;
 				};
 			};
 
@@ -160,9 +160,9 @@
 					compatible = "active-semi,act8945a";
 					reg = <0x5b>;
 					active-semi,vsel-high;
-					active-semi,chglev-gpios = <&pioA 12 GPIO_ACTIVE_HIGH>;
-					active-semi,lbo-gpios = <&pioA 72 GPIO_ACTIVE_LOW>;
-					active-semi,irq_gpios = <&pioA 45 GPIO_ACTIVE_LOW>;
+					active-semi,chglev-gpios = <&pioA PIN_PA12 GPIO_ACTIVE_HIGH>;
+					active-semi,lbo-gpios = <&pioA PIN_PC8 GPIO_ACTIVE_LOW>;
+					active-semi,irq_gpios = <&pioA PIN_PB13 GPIO_ACTIVE_LOW>;
 					active-semi,input-voltage-threshold-microvolt = <6600>;
 					active-semi,precondition-timeout = <40>;
 					active-semi,total-timeout = <3>;
@@ -504,7 +504,7 @@
 
 		bp1 {
 			label = "PB_USER";
-			gpios = <&pioA 41 GPIO_ACTIVE_LOW>;
+			gpios = <&pioA PIN_PB9 GPIO_ACTIVE_LOW>;
 			linux,code = <0x104>;
 		};
 	};
@@ -517,17 +517,18 @@
 
 		red {
 			label = "red";
-			gpios = <&pioA 38 GPIO_ACTIVE_LOW>;
+			gpios = <&pioA PIN_PB6 GPIO_ACTIVE_LOW>;
 		};
 
+
 		green {
 			label = "green";
-			gpios = <&pioA 37 GPIO_ACTIVE_LOW>;
+			gpios = <&pioA PIN_PB5 GPIO_ACTIVE_LOW>;
 		};
 
 		blue {
 			label = "blue";
-			gpios = <&pioA 32 GPIO_ACTIVE_LOW>;
+			gpios = <&pioA PIN_PB0 GPIO_ACTIVE_LOW>;
 			linux,default-trigger = "heartbeat";
 		};
 	};
-- 
2.12.2

[toc] | [prev] | [next] | [standalone]


#1686473 — Re: [PATCH v2] ARM: dts: at91: sama5d2_xplained: use pin macros instead of numbers

FromNicolas Ferre <nicolas.ferre@microchip.com>
Date2017-07-13 14:00 +0200
SubjectRe: [PATCH v2] ARM: dts: at91: sama5d2_xplained: use pin macros instead of numbers
Message-ID<u2KWJ-58b-9@gated-at.bofh.it>
In reply to#1683977
On 10/07/2017 at 08:12, Ludovic Desroches wrote:
> Use pin macros instead of magic numbers to ease interpretation.
> 
> Signed-off-by: Ludovic Desroches <ludovic.desroches@microchip.com>

Acked-by: Nicolas Ferre <nicolas.ferre@microchip.com>

> ---
> 
> I have remove the unexpected brace removal from the first version of this patch.
> 
>  arch/arm/boot/dts/at91-sama5d2_xplained.dts | 23 ++++++++++++-----------
>  1 file changed, 12 insertions(+), 11 deletions(-)
> 
> diff --git a/arch/arm/boot/dts/at91-sama5d2_xplained.dts b/arch/arm/boot/dts/at91-sama5d2_xplained.dts
> index 2e2c3d1a1fa2..6eec8dc5143e 100644
> --- a/arch/arm/boot/dts/at91-sama5d2_xplained.dts
> +++ b/arch/arm/boot/dts/at91-sama5d2_xplained.dts
> @@ -68,7 +68,7 @@
>  
>  	ahb {
>  		usb0: gadget@00300000 {
> -			atmel,vbus-gpio = <&pioA 31 GPIO_ACTIVE_HIGH>;
> +			atmel,vbus-gpio = <&pioA PIN_PA31 GPIO_ACTIVE_HIGH>;
>  			pinctrl-names = "default";
>  			pinctrl-0 = <&pinctrl_usba_vbus>;
>  			status = "okay";
> @@ -76,8 +76,8 @@
>  
>  		usb1: ohci@00400000 {
>  			num-ports = <3>;
> -			atmel,vbus-gpio = <0 /* &pioA 41 GPIO_ACTIVE_HIGH */
> -					   &pioA 42 GPIO_ACTIVE_HIGH
> +			atmel,vbus-gpio = <0 /* &pioA PIN_PB9 GPIO_ACTIVE_HIGH */
> +					   &pioA PIN_PB10 GPIO_ACTIVE_HIGH
>  					   0
>  					  >;
>  			pinctrl-names = "default";
> @@ -127,7 +127,7 @@
>  				ethernet-phy@1 {
>  					reg = <0x1>;
>  					interrupt-parent = <&pioA>;
> -					interrupts = <73 IRQ_TYPE_LEVEL_LOW>;
> +					interrupts = <PIN_PC9 IRQ_TYPE_LEVEL_LOW>;
>  				};
>  			};
>  
> @@ -160,9 +160,9 @@
>  					compatible = "active-semi,act8945a";
>  					reg = <0x5b>;
>  					active-semi,vsel-high;
> -					active-semi,chglev-gpios = <&pioA 12 GPIO_ACTIVE_HIGH>;
> -					active-semi,lbo-gpios = <&pioA 72 GPIO_ACTIVE_LOW>;
> -					active-semi,irq_gpios = <&pioA 45 GPIO_ACTIVE_LOW>;
> +					active-semi,chglev-gpios = <&pioA PIN_PA12 GPIO_ACTIVE_HIGH>;
> +					active-semi,lbo-gpios = <&pioA PIN_PC8 GPIO_ACTIVE_LOW>;
> +					active-semi,irq_gpios = <&pioA PIN_PB13 GPIO_ACTIVE_LOW>;
>  					active-semi,input-voltage-threshold-microvolt = <6600>;
>  					active-semi,precondition-timeout = <40>;
>  					active-semi,total-timeout = <3>;
> @@ -504,7 +504,7 @@
>  
>  		bp1 {
>  			label = "PB_USER";
> -			gpios = <&pioA 41 GPIO_ACTIVE_LOW>;
> +			gpios = <&pioA PIN_PB9 GPIO_ACTIVE_LOW>;
>  			linux,code = <0x104>;
>  		};
>  	};
> @@ -517,17 +517,18 @@
>  
>  		red {
>  			label = "red";
> -			gpios = <&pioA 38 GPIO_ACTIVE_LOW>;
> +			gpios = <&pioA PIN_PB6 GPIO_ACTIVE_LOW>;
>  		};
>  
> +
>  		green {
>  			label = "green";
> -			gpios = <&pioA 37 GPIO_ACTIVE_LOW>;
> +			gpios = <&pioA PIN_PB5 GPIO_ACTIVE_LOW>;
>  		};
>  
>  		blue {
>  			label = "blue";
> -			gpios = <&pioA 32 GPIO_ACTIVE_LOW>;
> +			gpios = <&pioA PIN_PB0 GPIO_ACTIVE_LOW>;
>  			linux,default-trigger = "heartbeat";
>  		};
>  	};
> 


-- 
Nicolas Ferre

[toc] | [prev] | [next] | [standalone]


#1688805 — Re: [PATCH v2] ARM: dts: at91: sama5d2_xplained: use pin macros instead of numbers

FromAlexandre Belloni <alexandre.belloni@free-electrons.com>
Date2017-07-17 11:20 +0200
SubjectRe: [PATCH v2] ARM: dts: at91: sama5d2_xplained: use pin macros instead of numbers
Message-ID<u4am7-37p-53@gated-at.bofh.it>
In reply to#1683977
On 10/07/2017 at 08:12:05 +0200, Ludovic Desroches wrote:
> Use pin macros instead of magic numbers to ease interpretation.
> 
> Signed-off-by: Ludovic Desroches <ludovic.desroches@microchip.com>
> ---
> 
> I have remove the unexpected brace removal from the first version of this patch.
> 
>  arch/arm/boot/dts/at91-sama5d2_xplained.dts | 23 ++++++++++++-----------
>  1 file changed, 12 insertions(+), 11 deletions(-)
> 
Applied, thanks.

-- 
Alexandre Belloni, Free Electrons
Embedded Linux and Kernel engineering
http://free-electrons.com

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web